VoteCal.Management.Web.Services Namespace

[image]

VoteCal EMS Vendor Integration API Reference
VoteCal.Management.Web.Services Namespace
Send Feedback

Classes

Class | Description
VoteCalEMSIntegrationWebService | The VoteCalEMSIntegrationWebService class provides a variety of web service methods to transfer and sync voters between a County's EMS database and the VoteCal database. Web service methods are also provided facilitate the resolution of various issues with a voter's record through "work items".

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


VoteCalEMSIntegrationWebService Class

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService Class
Members See Also Send Feedback
The VoteCalEMSIntegrationWebService class provides a variety of web service methods to transfer and sync voters between a County's EMS database and the VoteCal database. Web service methods are also provided facilitate the resolution of various issues with a voter's record through "work items".

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class VoteCalEMSIntegrationWebService : WebService
Visual Basic (Declaration)
Public Class VoteCalEMSIntegrationWebService _
    Inherits WebService
Visual C++
public ref class VoteCalEMSIntegrationWebService : public WebService

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.MarshalByValueComponent
System.Web.Services..::.WebService
VoteCal.Management.Web.Services..::.VoteCalEMSIntegrationWebService

See Also

VoteCalEMSIntegrationWebService Members
VoteCal.Management.Web.Services Namespace


VoteCalEMSIntegrationWebService Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService Members
VoteCalEMSIntegrationWebService Class Constructors Methods See Also Send Feedback

The VoteCalEMSIntegrationWebService type exposes the following members.

Constructors

Name | Description
VoteCalEMSIntegrationWebService |

Methods

Name Description
GetDataValidationErrorWorkItems

Purpose:

• Retrieves an array of DataValidationErrorWorkItem objects, each of which contain the DataValidationError information details needed to inform county elections staff of data validation issues with a voter’s record

Called When:

• County elections staff requests one or more DataValidationError Work Items

Logic Rules:

• Returns DataValidationError objects based on an array of WorkItemId Guide objects supplied as a parameter.

GetDeathRecordMatchCaseWorkItems

Purpose:

• Retrieves an array of DeathRecordMatchCaseWorkItem objects, each of which contain the DeathRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more DeathRecordMatchCase Work Items

Logic Rules:

• Retuns DeathRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetDMVChangeOfAddressRecordMatchCaseWorkItems

Purpose:

• Retrieves an array of DMVChangeOfAddressRecordMatchCaseWorkItem objects, each of which contain the DMVChangeOfAddressRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more DMVChangeOfAddressRecordMatchCase Work Items

Logic Rules:

• Retuns DMVChangeOfAddressRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetDuplicateVoterMatchCaseWorkItems

Purpose:

• Retrieves an array of DuplicateRecordMatchCaseWorkItem objects, each of which contain the DuplicateRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more DuplicateRecordMatchCase Work Items

Logic Rules:

• Retuns DuplicateRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetFelonRecordMatchCaseWorkItems

Purpose:

• Retrieves an array of FelonRecordMatchCaseWorkItem objects, each of which contain the FelonRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more FelonRecordMatchCase Work Items

Logic Rules:

• Retuns FelonRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetNationalChangeOfAddressRecordMatchCaseWorkItems

Purpose:

• Retrieves an array of NationalChangeOfAddressRecordMatchCaseWorkItem objects, each of which contain the NationalChangeOfAddressRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more NationalChangeOfAddressRecordMatchCase Work Items

Logic Rules:

• Retuns NationalChangeOfAddressRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetOpenMessages

Purpose:

• Retrieves all open VoteCal messages for a county

• Serves as a heartbeat informing VoteCal that the county EMS job processing service is running.

Called When:

• A county’s EMS job processing service is ready to receive new VoteCal messages (typically on a routine basis every 10 seconds - see: 2.2.7 Transaction Timing).

Logic Rules:

• Returns all messages with a MessageStatus of Open

• Messages will be returned continually by this method until they have a MessageStatus of Closed

GetOpenWorkItemCounts

Purpose:

• Returns the number of open Work Items by type

Called When:

• The number of open Work Items by type is needed, typically for the purpose of alerting elections staff

Logic Rules:

• Returns the number of Work Items by type with a WorkItemStatus of Open

GetOpenWorkItemList

Purpose:

• Retrieves a paged and filtered list of all open VoteCal Work Items for a county

Called When:

• A county EMS User requests a list of Work Items

Logic Rules:

• Returns all Work Items with a WorkItemStatus of Open

• Work Items will be returned continually by this method until they have a WorkItemStatus of Closed

• For the sake of efficiency, this method returns high-level Work Item objects. To retrieve the full and complete details of a Work Item, call the corresponding get method for the Work Item type.

GetStateVoters

Purpose:

• Retrieves the complete voter records from the VoteCal database, including (if specified) associated open and closed Messages, Work Items, and Documents.

Called When:

• County elections staff requests VoteCal Messages, Work Items, or Documents associated with a voter or voters

Logic Rules:

• To include Messages associated with voters in the returned StateVoters object, set the includeMessages parameter to true. The default for this parameter is false.

• To include Work Items associated with voters in the returned StateVoters object, set the includeWorkItems parameter to true. The default for this parameter is false.

• To include Documents associated with voters in the returned StateVoters object, set the includeDocuments parameter to true. The default for this parameter is false.

GetTransferOutWorkItems

Purpose:

• Retrieves an array of TransferOutWorkItem objects, each of which contain the TransferOut information details needed for county elections staff to make a determination on the transfer

Called When:

• County elections staff requests one or more TransferOut Work Items

Logic Rules:

• Retuns TransferOutWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

SearchStateVoters

Purpose:

• Gives the county EMS the ability to search the VoteCal database for voters to determine whether a new voter registration is a potential duplicate or transfer.

Called When:

• A new voter registration is being entered into a county EMS.

Logic Rules:

• Returns abbreviated voter records and corresponding search match confidence ratings for state voters which match the supplied search parameters to an extent which exceeds the search confidence threshold as determined by SOS.

UpdateDataValidationErrorWorkItems

Purpose:

• Updates the DataValidationErrorWorkItemStatus of a DataValidationErrorWorkItem to acknowledge that a county elections staff member has been made aware of the data validation issues with a voter’s record

Called When:

• A DataValidationError Work Item is acknowledged (DataValidtionErrorWorkItemStatus = DataValidationErrorWorkItemStatus.Acknowledged)

Logic Rules:

• Once the DataValidationErrorWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateDeathRecordMatchCaseWorkItems

Purpose:

• Updates the DeathRecordMatchCaseWorkItemStatus of a DeathRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A DeathRecordMatchCase is accepted (DeathRecordMatchCaseWorkItemStatus = DeathRecordMatchCaseWorkItemStatus.Accepted)

• A DeathRecordMatchCase is rejected (DeathRecordMatchCaseWorkItemStatus = DeathRecordMatchCaseWorkItemStatus.Rejected)

Logic Rules:

• Once the DeathRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateDMVChangeOfAddressRecordMatchCaseWorkItems

Purpose:

• Updates the DMVChangeOfAddressRecordMatchCaseWorkItemStatus of a DMVChangeOfAddressRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A DMVChangeOfAddressRecordMatchCase is determined to be valid but will require some manual intervention by elections staff (DMVChangeOfAddressRecordMatchCaseWorkItemStatus = DMVChangeOfAddressRecordMatchCaseWorkItemStatus.StaffUpdating)

• A DMVChangeOfAddressRecordMatchCase is determined to be invalid and will be ignored (DMVChangeOfAddressRecordMatchCaseWorkItemStatus = DMVChangeOfAddressRecordMatchCaseWorkItemStatus.Ignored)

Logic Rules:

• Once the DMVChangeOfAddressRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateDMVChangeOfAddressRecordReceivedMessages

Purpose:

• To update the DMVChangeOfAddressRecordReceivedMessageStatus of DMVChangeOfAddressRecordReceived Messages, ensuring the Message was received and processed by the local county EMS.

Called When:

• The ChangeOfAddressInfo supplied in the Message could not applied to the voter’s record by the local county EMS (DMVChangeOfAddressRecordReceivedMessageStatus = DMVChangeOfAddressRecordReceivedMessageStatus.CannotApplyDMVChangeOfAddress)

Logic Rules:

• Once the DMVChangeOfAddressRecordReceivedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

• Updates to the DMVChangeOfAddressRecordReceivedMessageStatus of DMVChangeOfAddressRecordReceived Messages typically occur by supplying the MessageId as a reference in calls to UpdateStateVoter.. The UpdateDMVChangeOfAddressReceivedMessages method is still made available for cases when (for some reason) the DMV change of address could not be applied to the voter’s record in the local county EMS database.

UpdateDuplicateVoterMatchCaseWorkItems

Purpose:

• Updates the DuplicateRecordMatchCaseWorkItemStatus of a DuplicateRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A DuplicateRecordMatchCase is accepted (DuplicateRecordMatchCaseWorkItemStatus = DuplicateRecordMatchCaseWorkItemStatus.Accepted)

• A DuplicateRecordMatchCase is rejected (DuplicateRecordMatchCaseWorkItemStatus = DuplicateRecordMatchCaseWorkItemStatus.Rejected)

Logic Rules:

• Once the DuplicateRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateFelonRecordMatchCaseWorkItems

Purpose:

• Updates the FelonRecordMatchCaseWorkItemStatus of a FelonRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A FelonRecordMatchCase is accepted (FelonRecordMatchCaseWorkItemStatus = FelonRecordMatchCaseWorkItemStatus.Accepted)

• A FelonRecordMatchCase is rejected (FelonRecordMatchCaseWorkItemStatus = FelonRecordMatchCaseWorkItemStatus.Rejected)

Logic Rules:

• Once the FelonRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateNationalChangeOfAddressRecordMatchCaseWorkItems

Purpose:

• Updates the NationalChangeOfAddressRecordMatchCaseWorkItemStatus of a DMVChangeOfAddressRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A NationalChangeOfAddressRecordMatchCase is determined to be valid but will require some manual intervention by elections staff (NationalChangeOfAddressRecordMatchCaseWorkItemStatus = NationalChangeOfAddressRecordMatchCaseWorkItemStatus.StaffUpdating)

• A NationalChangeOfAddressRecordMatchCase is determined to be invalid and will be ignored (NationalChangeOfAddressRecordMatchCaseWorkItemStatus = NationalChangeOfAddressRecordMatchCaseWorkItemStatus.Ignored)

Logic Rules:

• Once the NationalChangeOfAddressRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateNationalChangeOfAddressRecordReceivedMessages

Purpose:

• To update the NationalChangeOfAddressRecordReceivedMessageStatus of NationalChangeOfAddressRecordReceived Messages, ensuring the Message was received and processed by the local county EMS.

Called When:

• The ChangeOfAddressInfo supplied in the Message could not applied to the voter’s record by the local county EMS (NationalChangeOfAddressRecordReceivedMessageStatus = NationalChangeOfAddressRecordReceivedMessageStatus.CannotApplyNationalChangeOfAddress)

Logic Rules:

• Once the NationalChangeOfAddressRecordReceivedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

• Updates to the NationalChangeOfAddressRecordReceivedMessageStatus of NationalChangeOfAddressRecordReceived Messages typically occur by supplying the MessageId as a reference in calls to UpdateStateVoter.. The UpdateNationaChangeOfAddressReceivedMessages method is still made available for cases when (for some reason) the National change of address could not be applied to the voter’s record in the local county EMS database.

UpdateNewVoterReceivedMessages

Purpose:

• To update the NewVoterReceivedMessageStatus of NewVoterReceived Messages, ensuring the message was received and processed by the local county EMS.

Called When:

• The NewVoter supplied in the Message could not added to the local county EMS (NewVoterReceivedMessageStatus = NewVoterReceivedMessageStatus.CannotApplyNewVoter)

Logic Rules:

• Once the NewVoterReceivedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

• Updates to the NewVoterReceivedMessageStatus of NewVoterReceived Messages typically occur by supplying the MessageId as a reference in calls to UpdateStateVoter. Since VoteCal does not have the information needed to apply a precint to a new voter, VoteCal must rely on the local County EMS for such information. The UpdateNewVoterReceivedMessages method is still made available for cases when (for some reason) the new voter could not be added to the local county EMS database.

UpdateStateVoter

Purpose:

• Communicating to VoteCal updates made to a voter’s record in the local county EMS

• Communicating to VoteCal new voter registrations received by the county and entered into the county EMS

Called When:

• An update is made to a voter’s record in the county EMS database

• A new voter (voter transfer) is registered in the county EMS database

• (Typically) A NewVoterRecieved Message is received by the county EMS from VoteCal

• (Typically) A DMVChangeOfAddressReceived Message is received by the county EMS from VoteCal

• (Typically) A NationalChangeOfAddressReceived Message is received by the county EMS from VoteCal

Logic Rules:

• If a voter being updated does not have a StateVoterId or StateVoterIdPrimaryKey, VoteCal will treat the voter as a new registration

• If a voter search result was returned from a call to SearchStateVoters during the data entry process for a new registration, the matching voter must be handled as either a transfer or an ignored potential duplicate . When handling a new registration as a transfer , a TransferOut Work Item will be generated for the county the voter is transferring from (for verification purposes). When ignoring a duplicate match case for the new registration a DuplicateMatchCase work item will still be generated for the county in which the duplicate voter exists (for verification purposes)

• To indicate a potential duplicate is to be ignored, set the ignoreDuplicateStateVoterIdKey property of the UpdateStateVoterProperties parameter to the StateVoterIdPrimaryKey of the potential duplicate voter to be ignored.

• To indicate a voter is to be handled as a transfer, set the transferStateVoterIdPrimaryKey property of the UpdateStateVoterProperties parameter to the StateVoterIdPrimaryKey of the voter to be transferred (typically returned as a match result from a call to the SearchStateVoters method during data entry for a new registration)

• VoteCal does not have the information needed place a new voter (or one who has changed their address) in a precinct. VoteCal must rely on the local county EMS systems for this information. As such, NewVoterReceived, DMVChangeOfAddressReceived, and NationalChangeOfAddressReceived messages ought result in a call to UpdateStateVoter so that VoteCal can be updated with the precinct information for the voter (and in the case of new registrations, the CountyVoterId and CountyVoterIdPrimaryKey).

• To indicate that a state voter update is in response to a NewVoterReceived message, set the refNewVoterReceivedMessageId property of the UpdateStateVoterProperties parameter to the MessageId of the NewVoterReceived Message

• To indicate that a state voter update is in response to a DMVChangeOfAddressReceived Message, set the refDMVChangeOfAddressReceivedMessageId property of the UpdateStateVoterProperties parameter to the MessageId of the DMVChangeOfAddressReceived Message

• To indicate that a state voter update is in response to a NationalChangeOfAddressReceived Message, set the refNationalChangeOfAddressReceivedMessageId property of the UpdateStateVoterProperties parameter to the MessageId of the NationalChangeOfAddressReceived Message

• There will be rare cases when NewVoterReceived, DMVChangeOfAddressReceived, and NationalChangeOfAddressReceived Messages cannot be properly processed by the county EMS due to some error or missing information – in these cases the update status method corresponding to the message type should be used to update the status of the message rather than referencing the Message in a call to UpdateStateVoter

• The properties of the Voter object parameter are subject to various data validation rules. The data validation rules for each property of the Voter object are detailed in the compiled help Web Service API Reference. If properties of the Voter object supplied in the call to UpdateStateVoter fail data validation, a DataValidationError Work Item will be generated to be acknowledged by the county elections staff.

- Data validation errors have two levels of severity: Deficiency and Fatal. Deficiency data validation errors do not prevent a voter from being added to or updated within VoteCal. Fatal errors do prevent a voter from being added to or updated within VoteCal.

- DataValidationErrorWorkItem objects contain an array of DataValidationError objects. If multiple properties of a Voter object fail validation, the DataValidationErrorWorkItem will contain multiple errors.

- If any property of a Voter object fails validation with a severity level of fatal (DataValidationError.DataValidationErrorSeverityType = DataValidationErrorSeverityType.Fatal) the Voter will not be added to or updated within VoteCal.

- When a DataValidationErrorWorkItem is generated in response to a call to UpdateStateVoter, the DataValidationWorkItem will be included in the VoterWorkItems property of the Voter object property of the UpdateStateVoterResponse object returned from the call. The ResponseStatus and ResponseStatusReason of the UpdateStateVoterResponse object will also be set to indicate whether or not a data validation error was encountered and whether or not one of the errors was fatal. In the case of new voter registrations, if any of the data validation errors were fatal, a StateVoterId and StateVoterIdPrimaryKey will not be assigned to a voter.

• While the DataValidationErrorWorkItem mechanism is capable of handling most types of voter data validation errors, a CountyVoterIdPrimaryKey is required as a bare-minimum for creation of the DataValidationErrorWorkItem (i.e. the work item must refer to some voter in the County EMS database). Should the Voter object supplied as a parameter not have the CountyVoterIdPrimaryKey property supplied, a general response error will be returned with a response error reason of MissingCountyVoterIdPrimaryKey.

UpdateStateVoterActivityCreatedMessages

Purpose:

• To update the StateVoterActivityCreatedMessageStatus of StateVoterActivityCreated Messages, ensuring the message was received and processed by the local county EMS.

Called When:

• The state voter activity specified by the Message has been added to the voter’s record in the local county EMS database (StateVoterActivityCreatedMessageStatus = StateVoterActivityCreatedMessageStatus .VoterActivityApplied)

• The state voter activity specified by the Messaage could not be applied by the local county EMS (StateVoterActivityCreatedMessageStatus = StateVoterActivityCreatedMessageStatus.CannotApplyVoterActivity)

Logic Rules:

• Once the StateVoterActivityCreatedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

UpdateStateVoterStatusUpdatedMessages

Purpose:

• To update the StateVoterStatusUpdatedMessageStatus of StateVoterStatusUpdated Messages, ensureing the message was received and processed by the local county EMS.

Called When:

• The VoterStatus and VoterStatusReasonCode specified by the Messaage has been applied to the voter’s record in the local county EMS database (StateVoterStatusUpdatedMessageStatus = StateVoterStatusUpdatedMessageStatus.VoterStatusUpdateApplied)

• The VoterStatus and VoterStatusReasonCode specified by the Messaage could not be applied by the local county EMS (StateVoterStatusUpdatedMessageStatus = StateVoterStatusUpdatedMessageStatus.CannotApplyVoterStatusUpdate)

Logic Rules:

• Once the StateVoterStatusUpdatedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

UpdateStateVoterUpdatedMessages

Purpose:

• To update the StateVoterUpdatedMessageStatus of StateVoterUpdated Messages, ensuring the message was received and processed by the local county EMS.

Called When:

• The updates in the Voter object supplied in the Message have been applied to the voter’s record in the local county EMS database (StateVoterUpdatedMessageStatus = StateVoterUpdatedMessageStatus.VoterUpdateApplied)

• The updates in the Voter object supplied in the Messaage could not be applied by the local county EMS (StateVoterUpdatedMessageStatus = StateVoterUpdatedMessageStatus.CannotApplyVoterUpdate)

Logic Rules:

• Once the StateVoterUpdatedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

UpdateStateVoterVoteByMailActivity

Purpose:

• Communicating to VoteCal Vote By Mail activity for a given voter

Called When:

• A voter requests a Vote By Mail ballot

• A voter requests to be permanently designated as a Vote by Mail Voter

• A Vote By Mail ballot is mailed to a voter

• A Vote By Mail ballot is received

• A Vote By Mail Ballot is counted

Logic Rules:

None

UpdateTransferOutWorkItems

Purpose:

• Updates the TransferOutWorkItemStatus of a TransferOutWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A TransferOut is accepted (TransferOutWorkItemStatus = TransferOutWorkItemStatus.Accepted)

• A TransferOut is rejected TransferOutWorkItemStatus = TransferOutWorkItemStatus.Rejected)

Logic Rules:

• Once the TransferOutWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

VerifyVoterIdentification

Purpose:

• Gives the county EMS the ability to verify the identification data for a voter during the data entry process for a new voter

Called When:

• A new voter registration is being entered into a county EMS.

Logic Rules:

• The SuggestedDriversLicense property of the response object will be populated only if the VoterIdentificationMatchType property of the response object equals AlternateDLSuggested

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


VoteCalEMSIntegrationWebService Constructor

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService Constructor
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoteCalEMSIntegrationWebService()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoteCalEMSIntegrationWebService()

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


VoteCalEMSIntegrationWebService Methods

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService Methods
VoteCalEMSIntegrationWebService Class See Also Send Feedback

The VoteCalEMSIntegrationWebService type exposes the following members.

Methods

Name Description
GetDataValidationErrorWorkItems

Purpose:

• Retrieves an array of DataValidationErrorWorkItem objects, each of which contain the DataValidationError information details needed to inform county elections staff of data validation issues with a voter’s record

Called When:

• County elections staff requests one or more DataValidationError Work Items

Logic Rules:

• Returns DataValidationError objects based on an array of WorkItemId Guide objects supplied as a parameter.

GetDeathRecordMatchCaseWorkItems

Purpose:

• Retrieves an array of DeathRecordMatchCaseWorkItem objects, each of which contain the DeathRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more DeathRecordMatchCase Work Items

Logic Rules:

• Retuns DeathRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetDMVChangeOfAddressRecordMatchCaseWorkItems

Purpose:

• Retrieves an array of DMVChangeOfAddressRecordMatchCaseWorkItem objects, each of which contain the DMVChangeOfAddressRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more DMVChangeOfAddressRecordMatchCase Work Items

Logic Rules:

• Retuns DMVChangeOfAddressRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetDuplicateVoterMatchCaseWorkItems

Purpose:

• Retrieves an array of DuplicateRecordMatchCaseWorkItem objects, each of which contain the DuplicateRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more DuplicateRecordMatchCase Work Items

Logic Rules:

• Retuns DuplicateRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetFelonRecordMatchCaseWorkItems

Purpose:

• Retrieves an array of FelonRecordMatchCaseWorkItem objects, each of which contain the FelonRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more FelonRecordMatchCase Work Items

Logic Rules:

• Retuns FelonRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetNationalChangeOfAddressRecordMatchCaseWorkItems

Purpose:

• Retrieves an array of NationalChangeOfAddressRecordMatchCaseWorkItem objects, each of which contain the NationalChangeOfAddressRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more NationalChangeOfAddressRecordMatchCase Work Items

Logic Rules:

• Retuns NationalChangeOfAddressRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

GetOpenMessages

Purpose:

• Retrieves all open VoteCal messages for a county

• Serves as a heartbeat informing VoteCal that the county EMS job processing service is running.

Called When:

• A county’s EMS job processing service is ready to receive new VoteCal messages (typically on a routine basis every 10 seconds - see: 2.2.7 Transaction Timing).

Logic Rules:

• Returns all messages with a MessageStatus of Open

• Messages will be returned continually by this method until they have a MessageStatus of Closed

GetOpenWorkItemCounts

Purpose:

• Returns the number of open Work Items by type

Called When:

• The number of open Work Items by type is needed, typically for the purpose of alerting elections staff

Logic Rules:

• Returns the number of Work Items by type with a WorkItemStatus of Open

GetOpenWorkItemList

Purpose:

• Retrieves a paged and filtered list of all open VoteCal Work Items for a county

Called When:

• A county EMS User requests a list of Work Items

Logic Rules:

• Returns all Work Items with a WorkItemStatus of Open

• Work Items will be returned continually by this method until they have a WorkItemStatus of Closed

• For the sake of efficiency, this method returns high-level Work Item objects. To retrieve the full and complete details of a Work Item, call the corresponding get method for the Work Item type.

GetStateVoters

Purpose:

• Retrieves the complete voter records from the VoteCal database, including (if specified) associated open and closed Messages, Work Items, and Documents.

Called When:

• County elections staff requests VoteCal Messages, Work Items, or Documents associated with a voter or voters

Logic Rules:

• To include Messages associated with voters in the returned StateVoters object, set the includeMessages parameter to true. The default for this parameter is false.

• To include Work Items associated with voters in the returned StateVoters object, set the includeWorkItems parameter to true. The default for this parameter is false.

• To include Documents associated with voters in the returned StateVoters object, set the includeDocuments parameter to true. The default for this parameter is false.

GetTransferOutWorkItems

Purpose:

• Retrieves an array of TransferOutWorkItem objects, each of which contain the TransferOut information details needed for county elections staff to make a determination on the transfer

Called When:

• County elections staff requests one or more TransferOut Work Items

Logic Rules:

• Retuns TransferOutWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

SearchStateVoters

Purpose:

• Gives the county EMS the ability to search the VoteCal database for voters to determine whether a new voter registration is a potential duplicate or transfer.

Called When:

• A new voter registration is being entered into a county EMS.

Logic Rules:

• Returns abbreviated voter records and corresponding search match confidence ratings for state voters which match the supplied search parameters to an extent which exceeds the search confidence threshold as determined by SOS.

UpdateDataValidationErrorWorkItems

Purpose:

• Updates the DataValidationErrorWorkItemStatus of a DataValidationErrorWorkItem to acknowledge that a county elections staff member has been made aware of the data validation issues with a voter’s record

Called When:

• A DataValidationError Work Item is acknowledged (DataValidtionErrorWorkItemStatus = DataValidationErrorWorkItemStatus.Acknowledged)

Logic Rules:

• Once the DataValidationErrorWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateDeathRecordMatchCaseWorkItems

Purpose:

• Updates the DeathRecordMatchCaseWorkItemStatus of a DeathRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A DeathRecordMatchCase is accepted (DeathRecordMatchCaseWorkItemStatus = DeathRecordMatchCaseWorkItemStatus.Accepted)

• A DeathRecordMatchCase is rejected (DeathRecordMatchCaseWorkItemStatus = DeathRecordMatchCaseWorkItemStatus.Rejected)

Logic Rules:

• Once the DeathRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateDMVChangeOfAddressRecordMatchCaseWorkItems

Purpose:

• Updates the DMVChangeOfAddressRecordMatchCaseWorkItemStatus of a DMVChangeOfAddressRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A DMVChangeOfAddressRecordMatchCase is determined to be valid but will require some manual intervention by elections staff (DMVChangeOfAddressRecordMatchCaseWorkItemStatus = DMVChangeOfAddressRecordMatchCaseWorkItemStatus.StaffUpdating)

• A DMVChangeOfAddressRecordMatchCase is determined to be invalid and will be ignored (DMVChangeOfAddressRecordMatchCaseWorkItemStatus = DMVChangeOfAddressRecordMatchCaseWorkItemStatus.Ignored)

Logic Rules:

• Once the DMVChangeOfAddressRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateDMVChangeOfAddressRecordReceivedMessages

Purpose:

• To update the DMVChangeOfAddressRecordReceivedMessageStatus of DMVChangeOfAddressRecordReceived Messages, ensuring the Message was received and processed by the local county EMS.

Called When:

• The ChangeOfAddressInfo supplied in the Message could not applied to the voter’s record by the local county EMS (DMVChangeOfAddressRecordReceivedMessageStatus = DMVChangeOfAddressRecordReceivedMessageStatus.CannotApplyDMVChangeOfAddress)

Logic Rules:

• Once the DMVChangeOfAddressRecordReceivedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

• Updates to the DMVChangeOfAddressRecordReceivedMessageStatus of DMVChangeOfAddressRecordReceived Messages typically occur by supplying the MessageId as a reference in calls to UpdateStateVoter.. The UpdateDMVChangeOfAddressReceivedMessages method is still made available for cases when (for some reason) the DMV change of address could not be applied to the voter’s record in the local county EMS database.

UpdateDuplicateVoterMatchCaseWorkItems

Purpose:

• Updates the DuplicateRecordMatchCaseWorkItemStatus of a DuplicateRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A DuplicateRecordMatchCase is accepted (DuplicateRecordMatchCaseWorkItemStatus = DuplicateRecordMatchCaseWorkItemStatus.Accepted)

• A DuplicateRecordMatchCase is rejected (DuplicateRecordMatchCaseWorkItemStatus = DuplicateRecordMatchCaseWorkItemStatus.Rejected)

Logic Rules:

• Once the DuplicateRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateFelonRecordMatchCaseWorkItems

Purpose:

• Updates the FelonRecordMatchCaseWorkItemStatus of a FelonRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A FelonRecordMatchCase is accepted (FelonRecordMatchCaseWorkItemStatus = FelonRecordMatchCaseWorkItemStatus.Accepted)

• A FelonRecordMatchCase is rejected (FelonRecordMatchCaseWorkItemStatus = FelonRecordMatchCaseWorkItemStatus.Rejected)

Logic Rules:

• Once the FelonRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateNationalChangeOfAddressRecordMatchCaseWorkItems

Purpose:

• Updates the NationalChangeOfAddressRecordMatchCaseWorkItemStatus of a DMVChangeOfAddressRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A NationalChangeOfAddressRecordMatchCase is determined to be valid but will require some manual intervention by elections staff (NationalChangeOfAddressRecordMatchCaseWorkItemStatus = NationalChangeOfAddressRecordMatchCaseWorkItemStatus.StaffUpdating)

• A NationalChangeOfAddressRecordMatchCase is determined to be invalid and will be ignored (NationalChangeOfAddressRecordMatchCaseWorkItemStatus = NationalChangeOfAddressRecordMatchCaseWorkItemStatus.Ignored)

Logic Rules:

• Once the NationalChangeOfAddressRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

UpdateNationalChangeOfAddressRecordReceivedMessages

Purpose:

• To update the NationalChangeOfAddressRecordReceivedMessageStatus of NationalChangeOfAddressRecordReceived Messages, ensuring the Message was received and processed by the local county EMS.

Called When:

• The ChangeOfAddressInfo supplied in the Message could not applied to the voter’s record by the local county EMS (NationalChangeOfAddressRecordReceivedMessageStatus = NationalChangeOfAddressRecordReceivedMessageStatus.CannotApplyNationalChangeOfAddress)

Logic Rules:

• Once the NationalChangeOfAddressRecordReceivedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

• Updates to the NationalChangeOfAddressRecordReceivedMessageStatus of NationalChangeOfAddressRecordReceived Messages typically occur by supplying the MessageId as a reference in calls to UpdateStateVoter.. The UpdateNationaChangeOfAddressReceivedMessages method is still made available for cases when (for some reason) the National change of address could not be applied to the voter’s record in the local county EMS database.

UpdateNewVoterReceivedMessages

Purpose:

• To update the NewVoterReceivedMessageStatus of NewVoterReceived Messages, ensuring the message was received and processed by the local county EMS.

Called When:

• The NewVoter supplied in the Message could not added to the local county EMS (NewVoterReceivedMessageStatus = NewVoterReceivedMessageStatus.CannotApplyNewVoter)

Logic Rules:

• Once the NewVoterReceivedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

• Updates to the NewVoterReceivedMessageStatus of NewVoterReceived Messages typically occur by supplying the MessageId as a reference in calls to UpdateStateVoter. Since VoteCal does not have the information needed to apply a precint to a new voter, VoteCal must rely on the local County EMS for such information. The UpdateNewVoterReceivedMessages method is still made available for cases when (for some reason) the new voter could not be added to the local county EMS database.

UpdateStateVoter

Purpose:

• Communicating to VoteCal updates made to a voter’s record in the local county EMS

• Communicating to VoteCal new voter registrations received by the county and entered into the county EMS

Called When:

• An update is made to a voter’s record in the county EMS database

• A new voter (voter transfer) is registered in the county EMS database

• (Typically) A NewVoterRecieved Message is received by the county EMS from VoteCal

• (Typically) A DMVChangeOfAddressReceived Message is received by the county EMS from VoteCal

• (Typically) A NationalChangeOfAddressReceived Message is received by the county EMS from VoteCal

Logic Rules:

• If a voter being updated does not have a StateVoterId or StateVoterIdPrimaryKey, VoteCal will treat the voter as a new registration

• If a voter search result was returned from a call to SearchStateVoters during the data entry process for a new registration, the matching voter must be handled as either a transfer or an ignored potential duplicate . When handling a new registration as a transfer , a TransferOut Work Item will be generated for the county the voter is transferring from (for verification purposes). When ignoring a duplicate match case for the new registration a DuplicateMatchCase work item will still be generated for the county in which the duplicate voter exists (for verification purposes)

• To indicate a potential duplicate is to be ignored, set the ignoreDuplicateStateVoterIdKey property of the UpdateStateVoterProperties parameter to the StateVoterIdPrimaryKey of the potential duplicate voter to be ignored.

• To indicate a voter is to be handled as a transfer, set the transferStateVoterIdPrimaryKey property of the UpdateStateVoterProperties parameter to the StateVoterIdPrimaryKey of the voter to be transferred (typically returned as a match result from a call to the SearchStateVoters method during data entry for a new registration)

• VoteCal does not have the information needed place a new voter (or one who has changed their address) in a precinct. VoteCal must rely on the local county EMS systems for this information. As such, NewVoterReceived, DMVChangeOfAddressReceived, and NationalChangeOfAddressReceived messages ought result in a call to UpdateStateVoter so that VoteCal can be updated with the precinct information for the voter (and in the case of new registrations, the CountyVoterId and CountyVoterIdPrimaryKey).

• To indicate that a state voter update is in response to a NewVoterReceived message, set the refNewVoterReceivedMessageId property of the UpdateStateVoterProperties parameter to the MessageId of the NewVoterReceived Message

• To indicate that a state voter update is in response to a DMVChangeOfAddressReceived Message, set the refDMVChangeOfAddressReceivedMessageId property of the UpdateStateVoterProperties parameter to the MessageId of the DMVChangeOfAddressReceived Message

• To indicate that a state voter update is in response to a NationalChangeOfAddressReceived Message, set the refNationalChangeOfAddressReceivedMessageId property of the UpdateStateVoterProperties parameter to the MessageId of the NationalChangeOfAddressReceived Message

• There will be rare cases when NewVoterReceived, DMVChangeOfAddressReceived, and NationalChangeOfAddressReceived Messages cannot be properly processed by the county EMS due to some error or missing information – in these cases the update status method corresponding to the message type should be used to update the status of the message rather than referencing the Message in a call to UpdateStateVoter

• The properties of the Voter object parameter are subject to various data validation rules. The data validation rules for each property of the Voter object are detailed in the compiled help Web Service API Reference. If properties of the Voter object supplied in the call to UpdateStateVoter fail data validation, a DataValidationError Work Item will be generated to be acknowledged by the county elections staff.

- Data validation errors have two levels of severity: Deficiency and Fatal. Deficiency data validation errors do not prevent a voter from being added to or updated within VoteCal. Fatal errors do prevent a voter from being added to or updated within VoteCal.

- DataValidationErrorWorkItem objects contain an array of DataValidationError objects. If multiple properties of a Voter object fail validation, the DataValidationErrorWorkItem will contain multiple errors.

- If any property of a Voter object fails validation with a severity level of fatal (DataValidationError.DataValidationErrorSeverityType = DataValidationErrorSeverityType.Fatal) the Voter will not be added to or updated within VoteCal.

- When a DataValidationErrorWorkItem is generated in response to a call to UpdateStateVoter, the DataValidationWorkItem will be included in the VoterWorkItems property of the Voter object property of the UpdateStateVoterResponse object returned from the call. The ResponseStatus and ResponseStatusReason of the UpdateStateVoterResponse object will also be set to indicate whether or not a data validation error was encountered and whether or not one of the errors was fatal. In the case of new voter registrations, if any of the data validation errors were fatal, a StateVoterId and StateVoterIdPrimaryKey will not be assigned to a voter.

• While the DataValidationErrorWorkItem mechanism is capable of handling most types of voter data validation errors, a CountyVoterIdPrimaryKey is required as a bare-minimum for creation of the DataValidationErrorWorkItem (i.e. the work item must refer to some voter in the County EMS database). Should the Voter object supplied as a parameter not have the CountyVoterIdPrimaryKey property supplied, a general response error will be returned with a response error reason of MissingCountyVoterIdPrimaryKey.

UpdateStateVoterActivityCreatedMessages

Purpose:

• To update the StateVoterActivityCreatedMessageStatus of StateVoterActivityCreated Messages, ensuring the message was received and processed by the local county EMS.

Called When:

• The state voter activity specified by the Message has been added to the voter’s record in the local county EMS database (StateVoterActivityCreatedMessageStatus = StateVoterActivityCreatedMessageStatus .VoterActivityApplied)

• The state voter activity specified by the Messaage could not be applied by the local county EMS (StateVoterActivityCreatedMessageStatus = StateVoterActivityCreatedMessageStatus.CannotApplyVoterActivity)

Logic Rules:

• Once the StateVoterActivityCreatedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

UpdateStateVoterStatusUpdatedMessages

Purpose:

• To update the StateVoterStatusUpdatedMessageStatus of StateVoterStatusUpdated Messages, ensureing the message was received and processed by the local county EMS.

Called When:

• The VoterStatus and VoterStatusReasonCode specified by the Messaage has been applied to the voter’s record in the local county EMS database (StateVoterStatusUpdatedMessageStatus = StateVoterStatusUpdatedMessageStatus.VoterStatusUpdateApplied)

• The VoterStatus and VoterStatusReasonCode specified by the Messaage could not be applied by the local county EMS (StateVoterStatusUpdatedMessageStatus = StateVoterStatusUpdatedMessageStatus.CannotApplyVoterStatusUpdate)

Logic Rules:

• Once the StateVoterStatusUpdatedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

UpdateStateVoterUpdatedMessages

Purpose:

• To update the StateVoterUpdatedMessageStatus of StateVoterUpdated Messages, ensuring the message was received and processed by the local county EMS.

Called When:

• The updates in the Voter object supplied in the Message have been applied to the voter’s record in the local county EMS database (StateVoterUpdatedMessageStatus = StateVoterUpdatedMessageStatus.VoterUpdateApplied)

• The updates in the Voter object supplied in the Messaage could not be applied by the local county EMS (StateVoterUpdatedMessageStatus = StateVoterUpdatedMessageStatus.CannotApplyVoterUpdate)

Logic Rules:

• Once the StateVoterUpdatedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

UpdateStateVoterVoteByMailActivity

Purpose:

• Communicating to VoteCal Vote By Mail activity for a given voter

Called When:

• A voter requests a Vote By Mail ballot

• A voter requests to be permanently designated as a Vote by Mail Voter

• A Vote By Mail ballot is mailed to a voter

• A Vote By Mail ballot is received

• A Vote By Mail Ballot is counted

Logic Rules:

None

UpdateTransferOutWorkItems

Purpose:

• Updates the TransferOutWorkItemStatus of a TransferOutWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A TransferOut is accepted (TransferOutWorkItemStatus = TransferOutWorkItemStatus.Accepted)

• A TransferOut is rejected TransferOutWorkItemStatus = TransferOutWorkItemStatus.Rejected)

Logic Rules:

• Once the TransferOutWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

VerifyVoterIdentification

Purpose:

• Gives the county EMS the ability to verify the identification data for a voter during the data entry process for a new voter

Called When:

• A new voter registration is being entered into a county EMS.

Logic Rules:

• The SuggestedDriversLicense property of the response object will be populated only if the VoterIdentificationMatchType property of the response object equals AlternateDLSuggested

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetDataValidationErrorWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetDataValidationErrorWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves an array of DataValidationErrorWorkItem objects, each of which contain the DataValidationError information details needed to inform county elections staff of data validation issues with a voter’s record

Called When:

• County elections staff requests one or more DataValidationError Work Items

Logic Rules:

• Returns DataValidationError objects based on an array of WorkItemId Guide objects supplied as a parameter.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDataValidationErrorWorkItemsResponse GetDataValidationErrorWorkItems(
    CountyEMSAuth countyEMSAuth,
    Guid[] workItemIds
)
Visual Basic (Declaration)
Public Function GetDataValidationErrorWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    workItemIds As Guid() _
) As GetDataValidationErrorWorkItemsResponse
Visual C++
public:
GetDataValidationErrorWorkItemsResponse^ GetDataValidationErrorWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<Guid>^ workItemIds
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
workItemIds
Type: array< System..::.Guid >[]()[]

Return Value

GetDataValidationErrorWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetDeathRecordMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetDeathRecordMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves an array of DeathRecordMatchCaseWorkItem objects, each of which contain the DeathRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more DeathRecordMatchCase Work Items

Logic Rules:

• Retuns DeathRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDeathRecordMatchCaseWorkItemsResponse GetDeathRecordMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    Guid[] workItemIds
)
Visual Basic (Declaration)
Public Function GetDeathRecordMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    workItemIds As Guid() _
) As GetDeathRecordMatchCaseWorkItemsResponse
Visual C++
public:
GetDeathRecordMatchCaseWorkItemsResponse^ GetDeathRecordMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<Guid>^ workItemIds
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
countyEMSAuth
workItemIds
Type: array< System..::.Guid >[]()[]
workItemIds

Return Value

GetDeathRecordMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetDMVChangeOfAddressRecordMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetDMVChangeOfAddressRecordMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves an array of DMVChangeOfAddressRecordMatchCaseWorkItem objects, each of which contain the DMVChangeOfAddressRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more DMVChangeOfAddressRecordMatchCase Work Items

Logic Rules:

• Retuns DMVChangeOfAddressRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse GetDMVChangeOfAddressRecordMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    Guid[] workItemIds
)
Visual Basic (Declaration)
Public Function GetDMVChangeOfAddressRecordMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    workItemIds As Guid() _
) As GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse
Visual C++
public:
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse^ GetDMVChangeOfAddressRecordMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<Guid>^ workItemIds
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
workItemIds
Type: array< System..::.Guid >[]()[]

Return Value

GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetDuplicateVoterMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetDuplicateVoterMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves an array of DuplicateRecordMatchCaseWorkItem objects, each of which contain the DuplicateRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more DuplicateRecordMatchCase Work Items

Logic Rules:

• Retuns DuplicateRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDuplicateVoterMatchCaseWorkItemsResponse GetDuplicateVoterMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    Guid[] workItemIds
)
Visual Basic (Declaration)
Public Function GetDuplicateVoterMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    workItemIds As Guid() _
) As GetDuplicateVoterMatchCaseWorkItemsResponse
Visual C++
public:
GetDuplicateVoterMatchCaseWorkItemsResponse^ GetDuplicateVoterMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<Guid>^ workItemIds
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
workItemIds
Type: array< System..::.Guid >[]()[]

Return Value

GetDuplicateVoterMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetFelonRecordMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetFelonRecordMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves an array of FelonRecordMatchCaseWorkItem objects, each of which contain the FelonRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more FelonRecordMatchCase Work Items

Logic Rules:

• Retuns FelonRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetFelonRecordMatchCaseWorkItemsResponse GetFelonRecordMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    Guid[] workItemIds
)
Visual Basic (Declaration)
Public Function GetFelonRecordMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    workItemIds As Guid() _
) As GetFelonRecordMatchCaseWorkItemsResponse
Visual C++
public:
GetFelonRecordMatchCaseWorkItemsResponse^ GetFelonRecordMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<Guid>^ workItemIds
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
workItemIds
Type: array< System..::.Guid >[]()[]

Return Value

GetFelonRecordMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetNationalChangeOfAddressRecordMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetNationalChangeOfAddressRecordMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves an array of NationalChangeOfAddressRecordMatchCaseWorkItem objects, each of which contain the NationalChangeOfAddressRecordMatchCase information details needed for county elections staff to make a determination on the match case

Called When:

• County elections staff requests one or more NationalChangeOfAddressRecordMatchCase Work Items

Logic Rules:

• Retuns NationalChangeOfAddressRecordMatchCaseWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse GetNationalChangeOfAddressRecordMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    Guid[] workItemIds
)
Visual Basic (Declaration)
Public Function GetNationalChangeOfAddressRecordMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    workItemIds As Guid() _
) As GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse
Visual C++
public:
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse^ GetNationalChangeOfAddressRecordMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<Guid>^ workItemIds
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
workItemIds
Type: array< System..::.Guid >[]()[]

Return Value

GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetOpenMessages Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetOpenMessages Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves all open VoteCal messages for a county

• Serves as a heartbeat informing VoteCal that the county EMS job processing service is running.

Called When:

• A county’s EMS job processing service is ready to receive new VoteCal messages (typically on a routine basis every 10 seconds - see: 2.2.7 Transaction Timing).

Logic Rules:

• Returns all messages with a MessageStatus of Open

• Messages will be returned continually by this method until they have a MessageStatus of Closed

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetOpenMessagesResponse GetOpenMessages(
    CountyEMSAuth countyEMSAuth
)
Visual Basic (Declaration)
Public Function GetOpenMessages ( _
    countyEMSAuth As CountyEMSAuth _
) As GetOpenMessagesResponse
Visual C++
public:
GetOpenMessagesResponse^ GetOpenMessages(
    CountyEMSAuth^ countyEMSAuth
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
The county EMS auth.

Return Value

GetOpenMessagesResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetOpenWorkItemCounts Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetOpenWorkItemCounts Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Returns the number of open Work Items by type

Called When:

• The number of open Work Items by type is needed, typically for the purpose of alerting elections staff

Logic Rules:

• Returns the number of Work Items by type with a WorkItemStatus of Open

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetOpenWorkItemCountsResponse GetOpenWorkItemCounts(
    CountyEMSAuth countyEMSAuth
)
Visual Basic (Declaration)
Public Function GetOpenWorkItemCounts ( _
    countyEMSAuth As CountyEMSAuth _
) As GetOpenWorkItemCountsResponse
Visual C++
public:
GetOpenWorkItemCountsResponse^ GetOpenWorkItemCounts(
    CountyEMSAuth^ countyEMSAuth
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth

Return Value

GetOpenWorkItemCountsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetOpenWorkItemList Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetOpenWorkItemList Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves a paged and filtered list of all open VoteCal Work Items for a county

Called When:

• A county EMS User requests a list of Work Items

Logic Rules:

• Returns all Work Items with a WorkItemStatus of Open

• Work Items will be returned continually by this method until they have a WorkItemStatus of Closed

• For the sake of efficiency, this method returns high-level Work Item objects. To retrieve the full and complete details of a Work Item, call the corresponding get method for the Work Item type.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetOpenWorkItemsListResponse GetOpenWorkItemList(
    CountyEMSAuth countyEMSAuth,
    WorkItemListFilter workItemListFilter
)
Visual Basic (Declaration)
Public Function GetOpenWorkItemList ( _
    countyEMSAuth As CountyEMSAuth, _
    workItemListFilter As WorkItemListFilter _
) As GetOpenWorkItemsListResponse
Visual C++
public:
GetOpenWorkItemsListResponse^ GetOpenWorkItemList(
    CountyEMSAuth^ countyEMSAuth,
    WorkItemListFilter^ workItemListFilter
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
workItemListFilter
Type: VoteCal.Management.Web.Services.Models..::.WorkItemListFilter

Return Value

GetOpenWorkItemsListResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetStateVoters Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetStateVoters Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves the complete voter records from the VoteCal database, including (if specified) associated open and closed Messages, Work Items, and Documents.

Called When:

• County elections staff requests VoteCal Messages, Work Items, or Documents associated with a voter or voters

Logic Rules:

• To include Messages associated with voters in the returned StateVoters object, set the includeMessages parameter to true. The default for this parameter is false.

• To include Work Items associated with voters in the returned StateVoters object, set the includeWorkItems parameter to true. The default for this parameter is false.

• To include Documents associated with voters in the returned StateVoters object, set the includeDocuments parameter to true. The default for this parameter is false.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetStateVotersResponse GetStateVoters(
    CountyEMSAuth countyEMSAuth,
    Guid[] StateVoterIds,
    bool includeMessages,
    bool includeWorkItems,
    bool includeDocuments
)
Visual Basic (Declaration)
Public Function GetStateVoters ( _
    countyEMSAuth As CountyEMSAuth, _
    StateVoterIds As Guid(), _
    includeMessages As Boolean, _
    includeWorkItems As Boolean, _
    includeDocuments As Boolean _
) As GetStateVotersResponse
Visual C++
public:
GetStateVotersResponse^ GetStateVoters(
    CountyEMSAuth^ countyEMSAuth,
    array<Guid>^ StateVoterIds,
    bool includeMessages,
    bool includeWorkItems,
    bool includeDocuments
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
StateVoterIds
Type: array< System..::.Guid >[]()[]
includeMessages
Type: System..::.Boolean
includeWorkItems
Type: System..::.Boolean
includeDocuments
Type: System..::.Boolean

Return Value

GetStateVotersResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


GetTransferOutWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.GetTransferOutWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Retrieves an array of TransferOutWorkItem objects, each of which contain the TransferOut information details needed for county elections staff to make a determination on the transfer

Called When:

• County elections staff requests one or more TransferOut Work Items

Logic Rules:

• Retuns TransferOutWorkItem objects based on an array of WorkItemId Guid objects supplied as a parameter.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetTransferOutWorkItemsResponse GetTransferOutWorkItems(
    CountyEMSAuth countyEMSAuth,
    Guid[] workItemIds
)
Visual Basic (Declaration)
Public Function GetTransferOutWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    workItemIds As Guid() _
) As GetTransferOutWorkItemsResponse
Visual C++
public:
GetTransferOutWorkItemsResponse^ GetTransferOutWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<Guid>^ workItemIds
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
workItemIds
Type: array< System..::.Guid >[]()[]

Return Value

GetTransferOutWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


SearchStateVoters Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.SearchStateVoters Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Gives the county EMS the ability to search the VoteCal database for voters to determine whether a new voter registration is a potential duplicate or transfer.

Called When:

• A new voter registration is being entered into a county EMS.

Logic Rules:

• Returns abbreviated voter records and corresponding search match confidence ratings for state voters which match the supplied search parameters to an extent which exceeds the search confidence threshold as determined by SOS.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchStateVotersResponse SearchStateVoters(
    CountyEMSAuth countyEMSAuth,
    Voter stateVoterSearchParameters
)
Visual Basic (Declaration)
Public Function SearchStateVoters ( _
    countyEMSAuth As CountyEMSAuth, _
    stateVoterSearchParameters As Voter _
) As SearchStateVotersResponse
Visual C++
public:
SearchStateVotersResponse^ SearchStateVoters(
    CountyEMSAuth^ countyEMSAuth,
    Voter^ stateVoterSearchParameters
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
stateVoterSearchParameters
Type: VoteCal.Management.Web.Services.Models..::.Voter

Return Value

SearchStateVotersResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateDataValidationErrorWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateDataValidationErrorWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Updates the DataValidationErrorWorkItemStatus of a DataValidationErrorWorkItem to acknowledge that a county elections staff member has been made aware of the data validation issues with a voter’s record

Called When:

• A DataValidationError Work Item is acknowledged (DataValidtionErrorWorkItemStatus = DataValidationErrorWorkItemStatus.Acknowledged)

Logic Rules:

• Once the DataValidationErrorWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDataValidationErrorWorkItemsResponse UpdateDataValidationErrorWorkItems(
    CountyEMSAuth countyEMSAuth,
    DataValidationErrorWorkItem[] dataValidationErrorWorkItemsToUpdate
)
Visual Basic (Declaration)
Public Function UpdateDataValidationErrorWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    dataValidationErrorWorkItemsToUpdate As DataValidationErrorWorkItem() _
) As UpdateDataValidationErrorWorkItemsResponse
Visual C++
public:
UpdateDataValidationErrorWorkItemsResponse^ UpdateDataValidationErrorWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<DataValidationErrorWorkItem^>^ dataValidationErrorWorkItemsToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
dataValidationErrorWorkItemsToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.DataValidationErrorWorkItem >[]()[]

Return Value

UpdateDataValidationErrorWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateDeathRecordMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateDeathRecordMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Updates the DeathRecordMatchCaseWorkItemStatus of a DeathRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A DeathRecordMatchCase is accepted (DeathRecordMatchCaseWorkItemStatus = DeathRecordMatchCaseWorkItemStatus.Accepted)

• A DeathRecordMatchCase is rejected (DeathRecordMatchCaseWorkItemStatus = DeathRecordMatchCaseWorkItemStatus.Rejected)

Logic Rules:

• Once the DeathRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDeathRecordMatchCaseWorkItemsResponse UpdateDeathRecordMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    DeathRecordMatchCaseWorkItem[] deathRecordMatchCaseWorkItemsToUpdate
)
Visual Basic (Declaration)
Public Function UpdateDeathRecordMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    deathRecordMatchCaseWorkItemsToUpdate As DeathRecordMatchCaseWorkItem() _
) As UpdateDeathRecordMatchCaseWorkItemsResponse
Visual C++
public:
UpdateDeathRecordMatchCaseWorkItemsResponse^ UpdateDeathRecordMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<DeathRecordMatchCaseWorkItem^>^ deathRecordMatchCaseWorkItemsToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
deathRecordMatchCaseWorkItemsToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.DeathRecordMatchCaseWorkItem >[]()[]

Return Value

UpdateDeathRecordMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateDMVChangeOfAddressRecordMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateDMVChangeOfAddressRecordMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Updates the DMVChangeOfAddressRecordMatchCaseWorkItemStatus of a DMVChangeOfAddressRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A DMVChangeOfAddressRecordMatchCase is determined to be valid but will require some manual intervention by elections staff (DMVChangeOfAddressRecordMatchCaseWorkItemStatus = DMVChangeOfAddressRecordMatchCaseWorkItemStatus.StaffUpdating)

• A DMVChangeOfAddressRecordMatchCase is determined to be invalid and will be ignored (DMVChangeOfAddressRecordMatchCaseWorkItemStatus = DMVChangeOfAddressRecordMatchCaseWorkItemStatus.Ignored)

Logic Rules:

• Once the DMVChangeOfAddressRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse UpdateDMVChangeOfAddressRecordMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    DMVChangeOfAddressRecordMatchCaseWorkItem[] dmvChangeOfAddressRecordMatchCaseWorkItemsToUpdate
)
Visual Basic (Declaration)
Public Function UpdateDMVChangeOfAddressRecordMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    dmvChangeOfAddressRecordMatchCaseWorkItemsToUpdate As DMVChangeOfAddressRecordMatchCaseWorkItem() _
) As UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse
Visual C++
public:
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse^ UpdateDMVChangeOfAddressRecordMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ dmvChangeOfAddressRecordMatchCaseWorkItemsToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
dmvChangeOfAddressRecordMatchCaseWorkItemsToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.DMVChangeOfAddressRecordMatchCaseWorkItem >[]()[]

Return Value

UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateDMVChangeOfAddressRecordReceivedMessages Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateDMVChangeOfAddressRecordReceivedMessages Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• To update the DMVChangeOfAddressRecordReceivedMessageStatus of DMVChangeOfAddressRecordReceived Messages, ensuring the Message was received and processed by the local county EMS.

Called When:

• The ChangeOfAddressInfo supplied in the Message could not applied to the voter’s record by the local county EMS (DMVChangeOfAddressRecordReceivedMessageStatus = DMVChangeOfAddressRecordReceivedMessageStatus.CannotApplyDMVChangeOfAddress)

Logic Rules:

• Once the DMVChangeOfAddressRecordReceivedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

• Updates to the DMVChangeOfAddressRecordReceivedMessageStatus of DMVChangeOfAddressRecordReceived Messages typically occur by supplying the MessageId as a reference in calls to UpdateStateVoter.. The UpdateDMVChangeOfAddressReceivedMessages method is still made available for cases when (for some reason) the DMV change of address could not be applied to the voter’s record in the local county EMS database.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDMVChangeOfAddressRecordReceivedMessagesResponse UpdateDMVChangeOfAddressRecordReceivedMessages(
    CountyEMSAuth countyEMSAuth,
    DMVChangeOfAddressRecordReceivedMessage[] dmvChangeOfAddressRecordReceivedMessagesToUpdate
)
Visual Basic (Declaration)
Public Function UpdateDMVChangeOfAddressRecordReceivedMessages ( _
    countyEMSAuth As CountyEMSAuth, _
    dmvChangeOfAddressRecordReceivedMessagesToUpdate As DMVChangeOfAddressRecordReceivedMessage() _
) As UpdateDMVChangeOfAddressRecordReceivedMessagesResponse
Visual C++
public:
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse^ UpdateDMVChangeOfAddressRecordReceivedMessages(
    CountyEMSAuth^ countyEMSAuth,
    array<DMVChangeOfAddressRecordReceivedMessage^>^ dmvChangeOfAddressRecordReceivedMessagesToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
dmvChangeOfAddressRecordReceivedMessagesToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.DMVChangeOfAddressRecordReceivedMessage >[]()[]

Return Value

UpdateDMVChangeOfAddressRecordReceivedMessagesResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateDuplicateVoterMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateDuplicateVoterMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Updates the DuplicateRecordMatchCaseWorkItemStatus of a DuplicateRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A DuplicateRecordMatchCase is accepted (DuplicateRecordMatchCaseWorkItemStatus = DuplicateRecordMatchCaseWorkItemStatus.Accepted)

• A DuplicateRecordMatchCase is rejected (DuplicateRecordMatchCaseWorkItemStatus = DuplicateRecordMatchCaseWorkItemStatus.Rejected)

Logic Rules:

• Once the DuplicateRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDuplicateVoterMatchCaseWorkItemsResponse UpdateDuplicateVoterMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    DuplicateVoterMatchCaseWorkItem[] duplicateVoterMatchCaseWorkItemsToUpdate
)
Visual Basic (Declaration)
Public Function UpdateDuplicateVoterMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    duplicateVoterMatchCaseWorkItemsToUpdate As DuplicateVoterMatchCaseWorkItem() _
) As UpdateDuplicateVoterMatchCaseWorkItemsResponse
Visual C++
public:
UpdateDuplicateVoterMatchCaseWorkItemsResponse^ UpdateDuplicateVoterMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<DuplicateVoterMatchCaseWorkItem^>^ duplicateVoterMatchCaseWorkItemsToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
duplicateVoterMatchCaseWorkItemsToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.DuplicateVoterMatchCaseWorkItem >[]()[]

Return Value

UpdateDuplicateVoterMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateFelonRecordMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateFelonRecordMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Updates the FelonRecordMatchCaseWorkItemStatus of a FelonRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A FelonRecordMatchCase is accepted (FelonRecordMatchCaseWorkItemStatus = FelonRecordMatchCaseWorkItemStatus.Accepted)

• A FelonRecordMatchCase is rejected (FelonRecordMatchCaseWorkItemStatus = FelonRecordMatchCaseWorkItemStatus.Rejected)

Logic Rules:

• Once the FelonRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateFelonRecordMatchCaseWorkItemsResponse UpdateFelonRecordMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    FelonRecordMatchCaseWorkItem felonRecordMatchCaseWorkItemsToUpdate
)
Visual Basic (Declaration)
Public Function UpdateFelonRecordMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    felonRecordMatchCaseWorkItemsToUpdate As FelonRecordMatchCaseWorkItem _
) As UpdateFelonRecordMatchCaseWorkItemsResponse
Visual C++
public:
UpdateFelonRecordMatchCaseWorkItemsResponse^ UpdateFelonRecordMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    FelonRecordMatchCaseWorkItem^ felonRecordMatchCaseWorkItemsToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
felonRecordMatchCaseWorkItemsToUpdate
Type: VoteCal.Management.Web.Services.Models..::.FelonRecordMatchCaseWorkItem

Return Value

UpdateFelonRecordMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateNationalChangeOfAddressRecordMatchCaseWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateNationalChangeOfAddressRecordMatchCaseWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Updates the NationalChangeOfAddressRecordMatchCaseWorkItemStatus of a DMVChangeOfAddressRecordMatchCaseWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A NationalChangeOfAddressRecordMatchCase is determined to be valid but will require some manual intervention by elections staff (NationalChangeOfAddressRecordMatchCaseWorkItemStatus = NationalChangeOfAddressRecordMatchCaseWorkItemStatus.StaffUpdating)

• A NationalChangeOfAddressRecordMatchCase is determined to be invalid and will be ignored (NationalChangeOfAddressRecordMatchCaseWorkItemStatus = NationalChangeOfAddressRecordMatchCaseWorkItemStatus.Ignored)

Logic Rules:

• Once the NationalChangeOfAddressRecordMatchCaseWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse UpdateNationalChangeOfAddressRecordMatchCaseWorkItems(
    CountyEMSAuth countyEMSAuth,
    NationalChangeOfAddressRecordMatchCaseWorkItem[] nationalChangeOfAddressRecordMatchCaseWorkItemsToUpdate
)
Visual Basic (Declaration)
Public Function UpdateNationalChangeOfAddressRecordMatchCaseWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    nationalChangeOfAddressRecordMatchCaseWorkItemsToUpdate As NationalChangeOfAddressRecordMatchCaseWorkItem() _
) As UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse
Visual C++
public:
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse^ UpdateNationalChangeOfAddressRecordMatchCaseWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ nationalChangeOfAddressRecordMatchCaseWorkItemsToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
nationalChangeOfAddressRecordMatchCaseWorkItemsToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.NationalChangeOfAddressRecordMatchCaseWorkItem >[]()[]

Return Value

UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateNationalChangeOfAddressRecordReceivedMessages Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateNationalChangeOfAddressRecordReceivedMessages Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• To update the NationalChangeOfAddressRecordReceivedMessageStatus of NationalChangeOfAddressRecordReceived Messages, ensuring the Message was received and processed by the local county EMS.

Called When:

• The ChangeOfAddressInfo supplied in the Message could not applied to the voter’s record by the local county EMS (NationalChangeOfAddressRecordReceivedMessageStatus = NationalChangeOfAddressRecordReceivedMessageStatus.CannotApplyNationalChangeOfAddress)

Logic Rules:

• Once the NationalChangeOfAddressRecordReceivedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

• Updates to the NationalChangeOfAddressRecordReceivedMessageStatus of NationalChangeOfAddressRecordReceived Messages typically occur by supplying the MessageId as a reference in calls to UpdateStateVoter.. The UpdateNationaChangeOfAddressReceivedMessages method is still made available for cases when (for some reason) the National change of address could not be applied to the voter’s record in the local county EMS database.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateNationalChangeOfAddressRecordReceivedMessagesResponse UpdateNationalChangeOfAddressRecordReceivedMessages(
    CountyEMSAuth countyEMSAuth,
    NationalChangeOfAddressRecordReceivedMessage[] nationalChangeOfAddressRecordReceivedMessagesToUpdate
)
Visual Basic (Declaration)
Public Function UpdateNationalChangeOfAddressRecordReceivedMessages ( _
    countyEMSAuth As CountyEMSAuth, _
    nationalChangeOfAddressRecordReceivedMessagesToUpdate As NationalChangeOfAddressRecordReceivedMessage() _
) As UpdateNationalChangeOfAddressRecordReceivedMessagesResponse
Visual C++
public:
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse^ UpdateNationalChangeOfAddressRecordReceivedMessages(
    CountyEMSAuth^ countyEMSAuth,
    array<NationalChangeOfAddressRecordReceivedMessage^>^ nationalChangeOfAddressRecordReceivedMessagesToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
nationalChangeOfAddressRecordReceivedMessagesToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.NationalChangeOfAddressRecordReceivedMessage >[]()[]

Return Value

UpdateNationalChangeOfAddressRecordReceivedMessagesResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateNewVoterReceivedMessages Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateNewVoterReceivedMessages Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• To update the NewVoterReceivedMessageStatus of NewVoterReceived Messages, ensuring the message was received and processed by the local county EMS.

Called When:

• The NewVoter supplied in the Message could not added to the local county EMS (NewVoterReceivedMessageStatus = NewVoterReceivedMessageStatus.CannotApplyNewVoter)

Logic Rules:

• Once the NewVoterReceivedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

• Updates to the NewVoterReceivedMessageStatus of NewVoterReceived Messages typically occur by supplying the MessageId as a reference in calls to UpdateStateVoter. Since VoteCal does not have the information needed to apply a precint to a new voter, VoteCal must rely on the local County EMS for such information. The UpdateNewVoterReceivedMessages method is still made available for cases when (for some reason) the new voter could not be added to the local county EMS database.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateNewVoterReceivedMessagesResponse UpdateNewVoterReceivedMessages(
    CountyEMSAuth countyEMSAuth,
    NewVoterReceivedMessage[] newVoterReceivedMessages
)
Visual Basic (Declaration)
Public Function UpdateNewVoterReceivedMessages ( _
    countyEMSAuth As CountyEMSAuth, _
    newVoterReceivedMessages As NewVoterReceivedMessage() _
) As UpdateNewVoterReceivedMessagesResponse
Visual C++
public:
UpdateNewVoterReceivedMessagesResponse^ UpdateNewVoterReceivedMessages(
    CountyEMSAuth^ countyEMSAuth,
    array<NewVoterReceivedMessage^>^ newVoterReceivedMessages
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
newVoterReceivedMessages
Type: array< VoteCal.Management.Web.Services.Models..::.NewVoterReceivedMessage >[]()[]

Return Value

UpdateNewVoterReceivedMessagesResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateStateVoter Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateStateVoter Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Communicating to VoteCal updates made to a voter’s record in the local county EMS

• Communicating to VoteCal new voter registrations received by the county and entered into the county EMS

Called When:

• An update is made to a voter’s record in the county EMS database

• A new voter (voter transfer) is registered in the county EMS database

• (Typically) A NewVoterRecieved Message is received by the county EMS from VoteCal

• (Typically) A DMVChangeOfAddressReceived Message is received by the county EMS from VoteCal

• (Typically) A NationalChangeOfAddressReceived Message is received by the county EMS from VoteCal

Logic Rules:

• If a voter being updated does not have a StateVoterId or StateVoterIdPrimaryKey, VoteCal will treat the voter as a new registration

• If a voter search result was returned from a call to SearchStateVoters during the data entry process for a new registration, the matching voter must be handled as either a transfer or an ignored potential duplicate . When handling a new registration as a transfer , a TransferOut Work Item will be generated for the county the voter is transferring from (for verification purposes). When ignoring a duplicate match case for the new registration a DuplicateMatchCase work item will still be generated for the county in which the duplicate voter exists (for verification purposes)

• To indicate a potential duplicate is to be ignored, set the ignoreDuplicateStateVoterIdKey property of the UpdateStateVoterProperties parameter to the StateVoterIdPrimaryKey of the potential duplicate voter to be ignored.

• To indicate a voter is to be handled as a transfer, set the transferStateVoterIdPrimaryKey property of the UpdateStateVoterProperties parameter to the StateVoterIdPrimaryKey of the voter to be transferred (typically returned as a match result from a call to the SearchStateVoters method during data entry for a new registration)

• VoteCal does not have the information needed place a new voter (or one who has changed their address) in a precinct. VoteCal must rely on the local county EMS systems for this information. As such, NewVoterReceived, DMVChangeOfAddressReceived, and NationalChangeOfAddressReceived messages ought result in a call to UpdateStateVoter so that VoteCal can be updated with the precinct information for the voter (and in the case of new registrations, the CountyVoterId and CountyVoterIdPrimaryKey).

• To indicate that a state voter update is in response to a NewVoterReceived message, set the refNewVoterReceivedMessageId property of the UpdateStateVoterProperties parameter to the MessageId of the NewVoterReceived Message

• To indicate that a state voter update is in response to a DMVChangeOfAddressReceived Message, set the refDMVChangeOfAddressReceivedMessageId property of the UpdateStateVoterProperties parameter to the MessageId of the DMVChangeOfAddressReceived Message

• To indicate that a state voter update is in response to a NationalChangeOfAddressReceived Message, set the refNationalChangeOfAddressReceivedMessageId property of the UpdateStateVoterProperties parameter to the MessageId of the NationalChangeOfAddressReceived Message

• There will be rare cases when NewVoterReceived, DMVChangeOfAddressReceived, and NationalChangeOfAddressReceived Messages cannot be properly processed by the county EMS due to some error or missing information – in these cases the update status method corresponding to the message type should be used to update the status of the message rather than referencing the Message in a call to UpdateStateVoter

• The properties of the Voter object parameter are subject to various data validation rules. The data validation rules for each property of the Voter object are detailed in the compiled help Web Service API Reference. If properties of the Voter object supplied in the call to UpdateStateVoter fail data validation, a DataValidationError Work Item will be generated to be acknowledged by the county elections staff.

- Data validation errors have two levels of severity: Deficiency and Fatal. Deficiency data validation errors do not prevent a voter from being added to or updated within VoteCal. Fatal errors do prevent a voter from being added to or updated within VoteCal.

- DataValidationErrorWorkItem objects contain an array of DataValidationError objects. If multiple properties of a Voter object fail validation, the DataValidationErrorWorkItem will contain multiple errors.

- If any property of a Voter object fails validation with a severity level of fatal (DataValidationError.DataValidationErrorSeverityType = DataValidationErrorSeverityType.Fatal) the Voter will not be added to or updated within VoteCal.

- When a DataValidationErrorWorkItem is generated in response to a call to UpdateStateVoter, the DataValidationWorkItem will be included in the VoterWorkItems property of the Voter object property of the UpdateStateVoterResponse object returned from the call. The ResponseStatus and ResponseStatusReason of the UpdateStateVoterResponse object will also be set to indicate whether or not a data validation error was encountered and whether or not one of the errors was fatal. In the case of new voter registrations, if any of the data validation errors were fatal, a StateVoterId and StateVoterIdPrimaryKey will not be assigned to a voter.

• While the DataValidationErrorWorkItem mechanism is capable of handling most types of voter data validation errors, a CountyVoterIdPrimaryKey is required as a bare-minimum for creation of the DataValidationErrorWorkItem (i.e. the work item must refer to some voter in the County EMS database). Should the Voter object supplied as a parameter not have the CountyVoterIdPrimaryKey property supplied, a general response error will be returned with a response error reason of MissingCountyVoterIdPrimaryKey.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterResponse UpdateStateVoter(
    CountyEMSAuth countyEMSAuth,
    Voter voter,
    UpdateStateVoterProperties updateStateVoterProperties
)
Visual Basic (Declaration)
Public Function UpdateStateVoter ( _
    countyEMSAuth As CountyEMSAuth, _
    voter As Voter, _
    updateStateVoterProperties As UpdateStateVoterProperties _
) As UpdateStateVoterResponse
Visual C++
public:
UpdateStateVoterResponse^ UpdateStateVoter(
    CountyEMSAuth^ countyEMSAuth,
    Voter^ voter,
    UpdateStateVoterProperties^ updateStateVoterProperties
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
voter
Type: VoteCal.Management.Web.Services.Models..::.Voter
updateStateVoterProperties
Type: VoteCal.Management.Web.Services.Models..::.UpdateStateVoterProperties

Return Value

UpdateStateVoterResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateStateVoterActivityCreatedMessages Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateStateVoterActivityCreatedMessages Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• To update the StateVoterActivityCreatedMessageStatus of StateVoterActivityCreated Messages, ensuring the message was received and processed by the local county EMS.

Called When:

• The state voter activity specified by the Message has been added to the voter’s record in the local county EMS database (StateVoterActivityCreatedMessageStatus = StateVoterActivityCreatedMessageStatus .VoterActivityApplied)

• The state voter activity specified by the Messaage could not be applied by the local county EMS (StateVoterActivityCreatedMessageStatus = StateVoterActivityCreatedMessageStatus.CannotApplyVoterActivity)

Logic Rules:

• Once the StateVoterActivityCreatedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterActivityCreatedMessagesResponse UpdateStateVoterActivityCreatedMessages(
    CountyEMSAuth countyEMSAuth,
    StateVoterActivityCreatedMessage[] stateVoterActivityCreatedMessagesToUpdate
)
Visual Basic (Declaration)
Public Function UpdateStateVoterActivityCreatedMessages ( _
    countyEMSAuth As CountyEMSAuth, _
    stateVoterActivityCreatedMessagesToUpdate As StateVoterActivityCreatedMessage() _
) As UpdateStateVoterActivityCreatedMessagesResponse
Visual C++
public:
UpdateStateVoterActivityCreatedMessagesResponse^ UpdateStateVoterActivityCreatedMessages(
    CountyEMSAuth^ countyEMSAuth,
    array<StateVoterActivityCreatedMessage^>^ stateVoterActivityCreatedMessagesToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
stateVoterActivityCreatedMessagesToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.StateVoterActivityCreatedMessage >[]()[]

Return Value

UpdateStateVoterActivityCreatedMessagesResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateStateVoterStatusUpdatedMessages Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateStateVoterStatusUpdatedMessages Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• To update the StateVoterStatusUpdatedMessageStatus of StateVoterStatusUpdated Messages, ensureing the message was received and processed by the local county EMS.

Called When:

• The VoterStatus and VoterStatusReasonCode specified by the Messaage has been applied to the voter’s record in the local county EMS database (StateVoterStatusUpdatedMessageStatus = StateVoterStatusUpdatedMessageStatus.VoterStatusUpdateApplied)

• The VoterStatus and VoterStatusReasonCode specified by the Messaage could not be applied by the local county EMS (StateVoterStatusUpdatedMessageStatus = StateVoterStatusUpdatedMessageStatus.CannotApplyVoterStatusUpdate)

Logic Rules:

• Once the StateVoterStatusUpdatedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterStatusUpdatedMessagesResponse UpdateStateVoterStatusUpdatedMessages(
    CountyEMSAuth countyEMSAuth,
    StateVoterStatusUpdatedMessage[] stateVoterStatusUpdatedMessagesToUpdate
)
Visual Basic (Declaration)
Public Function UpdateStateVoterStatusUpdatedMessages ( _
    countyEMSAuth As CountyEMSAuth, _
    stateVoterStatusUpdatedMessagesToUpdate As StateVoterStatusUpdatedMessage() _
) As UpdateStateVoterStatusUpdatedMessagesResponse
Visual C++
public:
UpdateStateVoterStatusUpdatedMessagesResponse^ UpdateStateVoterStatusUpdatedMessages(
    CountyEMSAuth^ countyEMSAuth,
    array<StateVoterStatusUpdatedMessage^>^ stateVoterStatusUpdatedMessagesToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
stateVoterStatusUpdatedMessagesToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.StateVoterStatusUpdatedMessage >[]()[]

Return Value

UpdateStateVoterStatusUpdatedMessagesResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateStateVoterUpdatedMessages Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateStateVoterUpdatedMessages Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• To update the StateVoterUpdatedMessageStatus of StateVoterUpdated Messages, ensuring the message was received and processed by the local county EMS.

Called When:

• The updates in the Voter object supplied in the Message have been applied to the voter’s record in the local county EMS database (StateVoterUpdatedMessageStatus = StateVoterUpdatedMessageStatus.VoterUpdateApplied)

• The updates in the Voter object supplied in the Messaage could not be applied by the local county EMS (StateVoterUpdatedMessageStatus = StateVoterUpdatedMessageStatus.CannotApplyVoterUpdate)

Logic Rules:

• Once the StateVoterUpdatedMessageStatus property of the Message has been updated to a status other than Unhandled, VoteCal will set the overall status of the Message (MessageStatus) to Closed and will no longer return the Message from calls to GetOpenMessages.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterUpdatedMessagesResponse UpdateStateVoterUpdatedMessages(
    CountyEMSAuth countyEMSAuth,
    StateVoterUpdatedMessage[] stateVoterUpdatedMessagesToUpdate
)
Visual Basic (Declaration)
Public Function UpdateStateVoterUpdatedMessages ( _
    countyEMSAuth As CountyEMSAuth, _
    stateVoterUpdatedMessagesToUpdate As StateVoterUpdatedMessage() _
) As UpdateStateVoterUpdatedMessagesResponse
Visual C++
public:
UpdateStateVoterUpdatedMessagesResponse^ UpdateStateVoterUpdatedMessages(
    CountyEMSAuth^ countyEMSAuth,
    array<StateVoterUpdatedMessage^>^ stateVoterUpdatedMessagesToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
stateVoterUpdatedMessagesToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.StateVoterUpdatedMessage >[]()[]

Return Value

UpdateStateVoterUpdatedMessagesResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateStateVoterVoteByMailActivity Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateStateVoterVoteByMailActivity Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Communicating to VoteCal Vote By Mail activity for a given voter

Called When:

• A voter requests a Vote By Mail ballot

• A voter requests to be permanently designated as a Vote by Mail Voter

• A Vote By Mail ballot is mailed to a voter

• A Vote By Mail ballot is received

• A Vote By Mail Ballot is counted

Logic Rules:

None

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterVoteByMailActivityResponse UpdateStateVoterVoteByMailActivity(
    CountyEMSAuth countyEMSAuth,
    StateVoterVoteByMailActivity stateVoterVoteByMailActivity
)
Visual Basic (Declaration)
Public Function UpdateStateVoterVoteByMailActivity ( _
    countyEMSAuth As CountyEMSAuth, _
    stateVoterVoteByMailActivity As StateVoterVoteByMailActivity _
) As UpdateStateVoterVoteByMailActivityResponse
Visual C++
public:
UpdateStateVoterVoteByMailActivityResponse^ UpdateStateVoterVoteByMailActivity(
    CountyEMSAuth^ countyEMSAuth,
    StateVoterVoteByMailActivity^ stateVoterVoteByMailActivity
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
stateVoterVoteByMailActivity
Type: VoteCal.Management.Web.Services.Models..::.StateVoterVoteByMailActivity

Return Value

UpdateStateVoterVoteByMailActivityResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


UpdateTransferOutWorkItems Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.UpdateTransferOutWorkItems Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Updates the TransferOutWorkItemStatus of a TransferOutWorkItem indicating the determination county elections staff have made on the match case

Called When:

• A TransferOut is accepted (TransferOutWorkItemStatus = TransferOutWorkItemStatus.Accepted)

• A TransferOut is rejected TransferOutWorkItemStatus = TransferOutWorkItemStatus.Rejected)

Logic Rules:

• Once the TransferOutWorkItemStatus property of Work Item has been updated to a status other than Unhandled, VoteCal will set the overall status of the Work Item (WorkItemStatus) to Closed and will no longer return the Work Item from calls to GetOpenWorkItemList.

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateTransferOutWorkItemsResponse UpdateTransferOutWorkItems(
    CountyEMSAuth countyEMSAuth,
    TransferOutWorkItem[] transferOutWorkItemsToUpdate
)
Visual Basic (Declaration)
Public Function UpdateTransferOutWorkItems ( _
    countyEMSAuth As CountyEMSAuth, _
    transferOutWorkItemsToUpdate As TransferOutWorkItem() _
) As UpdateTransferOutWorkItemsResponse
Visual C++
public:
UpdateTransferOutWorkItemsResponse^ UpdateTransferOutWorkItems(
    CountyEMSAuth^ countyEMSAuth,
    array<TransferOutWorkItem^>^ transferOutWorkItemsToUpdate
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
transferOutWorkItemsToUpdate
Type: array< VoteCal.Management.Web.Services.Models..::.TransferOutWorkItem >[]()[]

Return Value

UpdateTransferOutWorkItemsResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


VerifyVoterIdentification Method

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalEMSIntegrationWebService..::.VerifyVoterIdentification Method
VoteCalEMSIntegrationWebService Class See Also Send Feedback

Purpose:

• Gives the county EMS the ability to verify the identification data for a voter during the data entry process for a new voter

Called When:

• A new voter registration is being entered into a county EMS.

Logic Rules:

• The SuggestedDriversLicense property of the response object will be populated only if the VoterIdentificationMatchType property of the response object equals AlternateDLSuggested

Namespace: VoteCal.Management.Web.Services
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VerifyVoterIdentificationResponse VerifyVoterIdentification(
    CountyEMSAuth countyEMSAuth,
    VoterIdInfo voterIdInfo
)
Visual Basic (Declaration)
Public Function VerifyVoterIdentification ( _
    countyEMSAuth As CountyEMSAuth, _
    voterIdInfo As VoterIdInfo _
) As VerifyVoterIdentificationResponse
Visual C++
public:
VerifyVoterIdentificationResponse^ VerifyVoterIdentification(
    CountyEMSAuth^ countyEMSAuth,
    VoterIdInfo^ voterIdInfo
)

Parameters

countyEMSAuth
Type: VoteCal.Management.Web.Services.Models..::.CountyEMSAuth
voterIdInfo
Type: VoteCal.Management.Web.Services.Models..::.VoterIdInfo

Return Value

VerifyVoterIdentificationResponse

See Also

VoteCalEMSIntegrationWebService Class
VoteCal.Management.Web.Services Namespace


VoteCal.Management.Web.Services.Models Namespace

[image]

VoteCal EMS Vendor Integration API Reference
VoteCal.Management.Web.Services.Models Namespace
Send Feedback

Classes

Class | Description
AbbreviatedVoter |
ChangeOfAddressInfo |
CountyEMSAuth |
DataValidationError |
DataValidationErrorWorkItem |
DeathRecordInfo |
DeathRecordMatchCaseWorkItem |
DMVChangeOfAddressRecordMatchCaseWorkItem |
DMVChangeOfAddressRecordReceivedMessage |
DuplicateVoterMatchCaseWorkItem |
FelonRecordInfo |
FelonRecordMatchCaseWorkItem |
GetDataValidationErrorWorkItemsResponse |
GetDeathRecordMatchCaseWorkItemsResponse |
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse |
GetDuplicateVoterMatchCaseWorkItemsResponse |
GetEMSVoterUpdateWorkItemsResponse |
GetFelonRecordMatchCaseWorkItemsResponse |
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse |
GetNewRegistrationWorkItemsResponse |
GetOpenMessagesResponse |
GetOpenWorkItemCountsResponse |
GetOpenWorkItemsListResponse |
GetStateVotersResponse |
GetTransferOutWorkItemsResponse |
GetVoterStatusChangeWorkItemsResponse |
GetWorkItemsResponse |
Message |
NationalChangeOfAddressRecordMatchCaseWorkItem |
NationalChangeOfAddressRecordReceivedMessage |
NewVoterReceivedMessage |
SearchStateVotersResponse |
StateVoterActivityCreatedMessage |
StateVoterSearchResult |
StateVoterStatusUpdatedMessage |
StateVoterUpdatedMessage |
StateVoterVoteByMailActivity |
TransferOutWorkItem |
UpdateDataValidationErrorWorkItemsResponse |
UpdateDeathRecordMatchCaseWorkItemsResponse |
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse |
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse |
UpdateDuplicateVoterMatchCaseWorkItemsResponse |
UpdateFelonRecordMatchCaseWorkItemsResponse |
UpdateMessagesResponse |
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse |
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse |
UpdateNewVoterReceivedMessagesResponse |
UpdateStateVoterActivityCreatedMessagesResponse |
UpdateStateVoterProperties |
UpdateStateVoterResponse |
UpdateStateVoterStatusUpdatedMessagesResponse |
UpdateStateVoterUpdatedMessagesResponse |
UpdateStateVoterVoteByMailActivityResponse |
UpdateTransferOutWorkItemsResponse |
UpdateWorkItemsResponse |
VerifyVoterIdentificationResponse |
VoteCalWebServiceResponse |
Voter | Represents a VoteCal State Voter
VoterIdInfo |
VoterMessages |
VoterWorkItems |
WorkItem |
WorkItemListFilter |
WorkItemUpdate |

Enumerations

Enumeration | Description
DataValidationErrorReasonType |
DataValidationErrorSeverityType |
DataValidationErrorSourceType |
DataValidationErrorWorkItemStatus |
DeathRecordMatchCaseWorkItemStatus |
DMVChangeOfAddressRecordMatchCaseWorkItemStatus |
DMVChangeOfAddressRecordReceivedMessageStatus |
DuplicateVoterMatchCaseWorkItemStatus |
FelonRecordMatchCaseWorkItemStatus |
GetItemsResponseStatusReason |
GetOpenMessagesResponseStatusReason |
GetStateVotersResponseStatusReason |
GetWorkItemCountsResponseStatusReason |
MessageStatus |
MessageType |
NationalChangeOfAddressRecordMatchCaseWorkItemStatus |
NationalChangeOfAddressRecordReceivedMessageStatus |
NewVoterReceivedMessageStatus |
ResponseStatus |
SearchStateVotersResponseStatusReason |
StateVoterActivityCreatedMessageStatus |
StateVoterStatusUpdatedMessageStatus |
StateVoterUpdatedMessageStatus |
TransferOutWorkItemStatus |
UpdateStateVoterResponseStatusReason |
UpdateStateVoterVoteByMailActivityResponseStatusReason |
VerifyVoterIdentificationResponseStatusReason |
VoteByMailActivityType |
VoterIdentificationMatchType |
WorkItemsResponseStatusReason |
WorkItemStatus |
WorkItemType |


AbbreviatedVoter Class

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class AbbreviatedVoter
Visual Basic (Declaration)
Public Class AbbreviatedVoter
Visual C++
public ref class AbbreviatedVoter

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.AbbreviatedVoter

See Also

AbbreviatedVoter Members
VoteCal.Management.Web.Services.Models Namespace


AbbreviatedVoter Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter Members
AbbreviatedVoter Class Constructors Properties See Also Send Feedback

The AbbreviatedVoter type exposes the following members.

Constructors

Name | Description
AbbreviatedVoter |

Properties

Name | Description
CountyVoterPrimaryId | The County EMS database primary key for a voter
DateOfBirth |
FirstName |
JurisdictionId |
LastName |
LastVoterInitiatedChangeDate |
MiddleName |
Ssn4 |
StateVoterId | The State Voter Id for a voter as mandated by HAVA (not the database primary key)
StateVoterIdPrimaryKey | The State VoteCal database primary key for a voter

See Also

AbbreviatedVoter Class


AbbreviatedVoter Constructor

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter Constructor
AbbreviatedVoter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AbbreviatedVoter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AbbreviatedVoter()

See Also

AbbreviatedVoter Class


AbbreviatedVoter Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter Properties
AbbreviatedVoter Class See Also Send Feedback

The AbbreviatedVoter type exposes the following members.

Properties

Name | Description
CountyVoterPrimaryId | The County EMS database primary key for a voter
DateOfBirth |
FirstName |
JurisdictionId |
LastName |
LastVoterInitiatedChangeDate |
MiddleName |
Ssn4 |
StateVoterId | The State Voter Id for a voter as mandated by HAVA (not the database primary key)
StateVoterIdPrimaryKey | The State VoteCal database primary key for a voter

See Also

AbbreviatedVoter Class


CountyVoterPrimaryId Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.CountyVoterPrimaryId Property
AbbreviatedVoter Class See Also Send Feedback
The County EMS database primary key for a voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CountyVoterPrimaryId { get; set; }
Visual Basic (Declaration)
Public Property CountyVoterPrimaryId As String
Visual C++
public:
property String^ CountyVoterPrimaryId {
    String^ get ();
    void set (String^ value);
}

See Also

AbbreviatedVoter Class


DateOfBirth Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.DateOfBirth Property
AbbreviatedVoter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime DateOfBirth { get; set; }
Visual Basic (Declaration)
Public Property DateOfBirth As DateTime
Visual C++
public:
property DateTime DateOfBirth {
    DateTime get ();
    void set (DateTime value);
}

See Also

AbbreviatedVoter Class


FirstName Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.FirstName Property
AbbreviatedVoter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

AbbreviatedVoter Class


JurisdictionId Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.JurisdictionId Property
AbbreviatedVoter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int JurisdictionId { get; set; }
Visual Basic (Declaration)
Public Property JurisdictionId As Integer
Visual C++
public:
property int JurisdictionId {
    int get ();
    void set (int value);
}

See Also

AbbreviatedVoter Class


LastName Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.LastName Property
AbbreviatedVoter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

AbbreviatedVoter Class


LastVoterInitiatedChangeDate Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.LastVoterInitiatedChangeDate Property
AbbreviatedVoter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime LastVoterInitiatedChangeDate { get; set; }
Visual Basic (Declaration)
Public Property LastVoterInitiatedChangeDate As DateTime
Visual C++
public:
property DateTime LastVoterInitiatedChangeDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

AbbreviatedVoter Class


MiddleName Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.MiddleName Property
AbbreviatedVoter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MiddleName { get; set; }
Visual Basic (Declaration)
Public Property MiddleName As String
Visual C++
public:
property String^ MiddleName {
    String^ get ();
    void set (String^ value);
}

See Also

AbbreviatedVoter Class


Ssn4 Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.Ssn4 Property
AbbreviatedVoter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Ssn4 { get; set; }
Visual Basic (Declaration)
Public Property Ssn4 As String
Visual C++
public:
property String^ Ssn4 {
    String^ get ();
    void set (String^ value);
}

See Also

AbbreviatedVoter Class


StateVoterId Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.StateVoterId Property
AbbreviatedVoter Class See Also Send Feedback
The State Voter Id for a voter as mandated by HAVA (not the database primary key)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string StateVoterId { get; set; }
Visual Basic (Declaration)
Public Property StateVoterId As String
Visual C++
public:
property String^ StateVoterId {
    String^ get ();
    void set (String^ value);
}

See Also

AbbreviatedVoter Class


StateVoterIdPrimaryKey Property

[image]

VoteCal EMS Vendor Integration API Reference
AbbreviatedVoter..::.StateVoterIdPrimaryKey Property
AbbreviatedVoter Class See Also Send Feedback
The State VoteCal database primary key for a voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid StateVoterIdPrimaryKey { get; set; }
Visual Basic (Declaration)
Public Property StateVoterIdPrimaryKey As Guid
Visual C++
public:
property Guid StateVoterIdPrimaryKey {
    Guid get ();
    void set (Guid value);
}

See Also

AbbreviatedVoter Class


ChangeOfAddressInfo Class

[image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class ChangeOfAddressInfo
Visual Basic (Declaration)
Public Class ChangeOfAddressInfo
Visual C++
public ref class ChangeOfAddressInfo

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.ChangeOfAddressInfo

See Also

ChangeOfAddressInfo Members


ChangeOfAddressInfo Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo Members
ChangeOfAddressInfo Class Constructors Properties See Also Send Feedback

The ChangeOfAddressInfo type exposes the following members.

Constructors

Name | Description
ChangeOfAddressInfo |

Properties

Name | Description
_AddressLine1 |
_AddressLine2 |
City |
County |
State |
Zip4 |
ZipCode |

See Also

ChangeOfAddressInfo Class


ChangeOfAddressInfo Constructor

[image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo Constructor
ChangeOfAddressInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChangeOfAddressInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ChangeOfAddressInfo()

See Also

ChangeOfAddressInfo Class


ChangeOfAddressInfo Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo Properties
ChangeOfAddressInfo Class See Also Send Feedback

The ChangeOfAddressInfo type exposes the following members.

Properties

Name | Description
_AddressLine1 |
_AddressLine2 |
City |
County |
State |
Zip4 |
ZipCode |

See Also

ChangeOfAddressInfo Class


_AddressLine1 Property

[image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo..::._AddressLine1 Property
ChangeOfAddressInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string _AddressLine1 { get; set; }
Visual Basic (Declaration)
Public Property _AddressLine1 As String
Visual C++
public:
property String^ _AddressLine1 {
    String^ get ();
    void set (String^ value);
}

See Also

ChangeOfAddressInfo Class


_AddressLine2 Property

[image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo..::._AddressLine2 Property
ChangeOfAddressInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string _AddressLine2 { get; set; }
Visual Basic (Declaration)
Public Property _AddressLine2 As String
Visual C++
public:
property String^ _AddressLine2 {
    String^ get ();
    void set (String^ value);
}

See Also

ChangeOfAddressInfo Class


City Property

[image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo..::.City Property
ChangeOfAddressInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string City { get; set; }
Visual Basic (Declaration)
Public Property City As String
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

See Also

ChangeOfAddressInfo Class


County Property

[image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo..::.County Property
ChangeOfAddressInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string County { get; set; }
Visual Basic (Declaration)
Public Property County As String
Visual C++
public:
property String^ County {
    String^ get ();
    void set (String^ value);
}

See Also

ChangeOfAddressInfo Class


State Property

[image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo..::.State Property
ChangeOfAddressInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string State { get; set; }
Visual Basic (Declaration)
Public Property State As String
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

See Also

ChangeOfAddressInfo Class


Zip4 Property

[image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo..::.Zip4 Property
ChangeOfAddressInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Zip4 { get; set; }
Visual Basic (Declaration)
Public Property Zip4 As String
Visual C++
public:
property String^ Zip4 {
    String^ get ();
    void set (String^ value);
}

See Also

ChangeOfAddressInfo Class


ZipCode Property

[image]

VoteCal EMS Vendor Integration API Reference
ChangeOfAddressInfo..::.ZipCode Property
ChangeOfAddressInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ZipCode { get; set; }
Visual Basic (Declaration)
Public Property ZipCode As String
Visual C++
public:
property String^ ZipCode {
    String^ get ();
    void set (String^ value);
}

See Also

ChangeOfAddressInfo Class


CountyEMSAuth Class

[image]

VoteCal EMS Vendor Integration API Reference
CountyEMSAuth Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class CountyEMSAuth
Visual Basic (Declaration)
Public Class CountyEMSAuth
Visual C++
public ref class CountyEMSAuth

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.CountyEMSAuth

See Also

CountyEMSAuth Members


CountyEMSAuth Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
CountyEMSAuth Members
CountyEMSAuth Class Constructors Properties See Also Send Feedback

The CountyEMSAuth type exposes the following members.

Constructors

Name | Description
CountyEMSAuth |

Properties

Name | Description
Password | The Password assigned to your county by the SoS office
Username | The Username assigned to your county by the SoS office

See Also

CountyEMSAuth Class


CountyEMSAuth Constructor

[image]

VoteCal EMS Vendor Integration API Reference
CountyEMSAuth Constructor
CountyEMSAuth Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public CountyEMSAuth()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CountyEMSAuth()

See Also

CountyEMSAuth Class


CountyEMSAuth Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
CountyEMSAuth Properties
CountyEMSAuth Class See Also Send Feedback

The CountyEMSAuth type exposes the following members.

Properties

Name | Description
Password | The Password assigned to your county by the SoS office
Username | The Username assigned to your county by the SoS office

See Also

CountyEMSAuth Class


Password Property

[image]

VoteCal EMS Vendor Integration API Reference
CountyEMSAuth..::.Password Property
CountyEMSAuth Class See Also Send Feedback
The Password assigned to your county by the SoS office

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String
Visual C++
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

See Also

CountyEMSAuth Class


Username Property

[image]

VoteCal EMS Vendor Integration API Reference
CountyEMSAuth..::.Username Property
CountyEMSAuth Class See Also Send Feedback
The Username assigned to your county by the SoS office

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Username { get; set; }
Visual Basic (Declaration)
Public Property Username As String
Visual C++
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

See Also

CountyEMSAuth Class


DataValidationError Class

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationError Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DataValidationError
Visual Basic (Declaration)
Public Class DataValidationError
Visual C++
public ref class DataValidationError

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.DataValidationError

See Also

DataValidationError Members


DataValidationError Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
DataValidationError Members
DataValidationError Class Constructors Properties See Also Send Feedback

The DataValidationError type exposes the following members.

Constructors

Name | Description
DataValidationError |

Properties

Name | Description
CurrentDataFieldValue |
DataFieldName |
DataValidationErrorResaonDescription |
MustCorrectBy |

See Also

DataValidationError Class


DataValidationError Constructor

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationError Constructor
DataValidationError Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataValidationError()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataValidationError()

See Also

DataValidationError Class


DataValidationError Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
DataValidationError Properties
DataValidationError Class See Also Send Feedback

The DataValidationError type exposes the following members.

Properties

Name | Description
CurrentDataFieldValue |
DataFieldName |
DataValidationErrorResaonDescription |
MustCorrectBy |

See Also

DataValidationError Class


CurrentDataFieldValue Property

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationError..::.CurrentDataFieldValue Property
DataValidationError Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CurrentDataFieldValue { get; set; }
Visual Basic (Declaration)
Public Property CurrentDataFieldValue As String
Visual C++
public:
property String^ CurrentDataFieldValue {
    String^ get ();
    void set (String^ value);
}

See Also

DataValidationError Class


DataFieldName Property

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationError..::.DataFieldName Property
DataValidationError Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DataFieldName { get; set; }
Visual Basic (Declaration)
Public Property DataFieldName As String
Visual C++
public:
property String^ DataFieldName {
    String^ get ();
    void set (String^ value);
}

See Also

DataValidationError Class


DataValidationErrorResaonDescription Property

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationError..::.DataValidationErrorResaonDescription Property
DataValidationError Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DataValidationErrorResaonDescription { get; set; }
Visual Basic (Declaration)
Public Property DataValidationErrorResaonDescription As String
Visual C++
public:
property String^ DataValidationErrorResaonDescription {
    String^ get ();
    void set (String^ value);
}

See Also

DataValidationError Class


MustCorrectBy Property

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationError..::.MustCorrectBy Property
DataValidationError Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime MustCorrectBy { get; set; }
Visual Basic (Declaration)
Public Property MustCorrectBy As DateTime
Visual C++
public:
property DateTime MustCorrectBy {
    DateTime get ();
    void set (DateTime value);
}

See Also

DataValidationError Class


DataValidationErrorReasonType Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorReasonType Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DataValidationErrorReasonType
Visual Basic (Declaration)
Public Enumeration DataValidationErrorReasonType
Visual C++
public enum class DataValidationErrorReasonType

Members

Member name | Description
MissingValue |
InvalidValue |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


DataValidationErrorSeverityType Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorSeverityType Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DataValidationErrorSeverityType
Visual Basic (Declaration)
Public Enumeration DataValidationErrorSeverityType
Visual C++
public enum class DataValidationErrorSeverityType

Members

Member name | Description
Deficiency |
Fatal |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


DataValidationErrorSourceType Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorSourceType Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DataValidationErrorSourceType
Visual Basic (Declaration)
Public Enumeration DataValidationErrorSourceType
Visual C++
public enum class DataValidationErrorSourceType

Members

Member name | Description
Voter |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


DataValidationErrorWorkItem Class

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorWorkItem Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DataValidationErrorWorkItem : WorkItem
Visual Basic (Declaration)
Public Class DataValidationErrorWorkItem _
    Inherits WorkItem
Visual C++
public ref class DataValidationErrorWorkItem : public WorkItem

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItem
VoteCal.Management.Web.Services.Models..::.DataValidationErrorWorkItem

See Also

DataValidationErrorWorkItem Members


DataValidationErrorWorkItem Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorWorkItem Members
DataValidationErrorWorkItem Class Constructors Properties See Also Send Feedback

The DataValidationErrorWorkItem type exposes the following members.

Constructors

Name | Description
DataValidationErrorWorkItem |

Properties

Name | Description
ApplicableVoter |
DataValidationErrors |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

DataValidationErrorWorkItem Class


DataValidationErrorWorkItem Constructor

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorWorkItem Constructor
DataValidationErrorWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataValidationErrorWorkItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DataValidationErrorWorkItem()

See Also

DataValidationErrorWorkItem Class


DataValidationErrorWorkItem Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorWorkItem Properties
DataValidationErrorWorkItem Class See Also Send Feedback

The DataValidationErrorWorkItem type exposes the following members.

Properties

Name | Description
ApplicableVoter |
DataValidationErrors |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

DataValidationErrorWorkItem Class


ApplicableVoter Property

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorWorkItem..::.ApplicableVoter Property
DataValidationErrorWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Voter ApplicableVoter { get; set; }
Visual Basic (Declaration)
Public Property ApplicableVoter As Voter
Visual C++
public:
property Voter^ ApplicableVoter {
    Voter^ get ();
    void set (Voter^ value);
}

See Also

DataValidationErrorWorkItem Class


DataValidationErrors Property

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorWorkItem..::.DataValidationErrors Property
DataValidationErrorWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataValidationError[] DataValidationErrors { get; set; }
Visual Basic (Declaration)
Public Property DataValidationErrors As DataValidationError()
Visual C++
public:
property array<DataValidationError^>^ DataValidationErrors {
    array<DataValidationError^>^ get ();
    void set (array<DataValidationError^>^ value);
}

See Also

DataValidationErrorWorkItem Class


DataValidationErrorWorkItemStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
DataValidationErrorWorkItemStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DataValidationErrorWorkItemStatus
Visual Basic (Declaration)
Public Enumeration DataValidationErrorWorkItemStatus
Visual C++
public enum class DataValidationErrorWorkItemStatus

Members

Member name | Description
Unhandled |
Acknowledged |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


DeathRecordInfo Class

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordInfo Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DeathRecordInfo
Visual Basic (Declaration)
Public Class DeathRecordInfo
Visual C++
public ref class DeathRecordInfo

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.DeathRecordInfo

See Also

DeathRecordInfo Members


DeathRecordInfo Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
DeathRecordInfo Members
DeathRecordInfo Class Constructors Properties See Also Send Feedback

The DeathRecordInfo type exposes the following members.

Constructors

Name | Description
DeathRecordInfo |

Properties

Name | Description
BirthDate |
FirstName |
LastName |

See Also

DeathRecordInfo Class


DeathRecordInfo Constructor

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordInfo Constructor
DeathRecordInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DeathRecordInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DeathRecordInfo()

See Also

DeathRecordInfo Class


DeathRecordInfo Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
DeathRecordInfo Properties
DeathRecordInfo Class See Also Send Feedback

The DeathRecordInfo type exposes the following members.

Properties

Name | Description
BirthDate |
FirstName |
LastName |

See Also

DeathRecordInfo Class


BirthDate Property

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordInfo..::.BirthDate Property
DeathRecordInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime BirthDate { get; set; }
Visual Basic (Declaration)
Public Property BirthDate As DateTime
Visual C++
public:
property DateTime BirthDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

DeathRecordInfo Class


FirstName Property

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordInfo..::.FirstName Property
DeathRecordInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

DeathRecordInfo Class


LastName Property

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordInfo..::.LastName Property
DeathRecordInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

DeathRecordInfo Class


DeathRecordMatchCaseWorkItem Class

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordMatchCaseWorkItem Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DeathRecordMatchCaseWorkItem : WorkItem
Visual Basic (Declaration)
Public Class DeathRecordMatchCaseWorkItem _
    Inherits WorkItem
Visual C++
public ref class DeathRecordMatchCaseWorkItem : public WorkItem

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItem
VoteCal.Management.Web.Services.Models..::.DeathRecordMatchCaseWorkItem

See Also

DeathRecordMatchCaseWorkItem Members


DeathRecordMatchCaseWorkItem Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
DeathRecordMatchCaseWorkItem Members
DeathRecordMatchCaseWorkItem Class Constructors Properties See Also Send Feedback

The DeathRecordMatchCaseWorkItem type exposes the following members.

Constructors

Name | Description
DeathRecordMatchCaseWorkItem |

Properties

Name | Description
Confidence |
DeathRecordInfo |
DeathRecordMatchCaseWorkItemStatus |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

DeathRecordMatchCaseWorkItem Class


DeathRecordMatchCaseWorkItem Constructor

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordMatchCaseWorkItem Constructor
DeathRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DeathRecordMatchCaseWorkItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DeathRecordMatchCaseWorkItem()

See Also

DeathRecordMatchCaseWorkItem Class


DeathRecordMatchCaseWorkItem Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
DeathRecordMatchCaseWorkItem Properties
DeathRecordMatchCaseWorkItem Class See Also Send Feedback

The DeathRecordMatchCaseWorkItem type exposes the following members.

Properties

Name | Description
Confidence |
DeathRecordInfo |
DeathRecordMatchCaseWorkItemStatus |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

DeathRecordMatchCaseWorkItem Class


Confidence Property

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordMatchCaseWorkItem..::.Confidence Property
DeathRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public decimal Confidence { get; set; }
Visual Basic (Declaration)
Public Property Confidence As Decimal
Visual C++
public:
property Decimal Confidence {
    Decimal get ();
    void set (Decimal value);
}

See Also

DeathRecordMatchCaseWorkItem Class


DeathRecordInfo Property

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordMatchCaseWorkItem..::.DeathRecordInfo Property
DeathRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DeathRecordInfo DeathRecordInfo { get; set; }
Visual Basic (Declaration)
Public Property DeathRecordInfo As DeathRecordInfo
Visual C++
public:
property DeathRecordInfo^ DeathRecordInfo {
    DeathRecordInfo^ get ();
    void set (DeathRecordInfo^ value);
}

See Also

DeathRecordMatchCaseWorkItem Class


DeathRecordMatchCaseWorkItemStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordMatchCaseWorkItem..::.DeathRecordMatchCaseWorkItemStatus Property
DeathRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DeathRecordMatchCaseWorkItemStatus DeathRecordMatchCaseWorkItemStatus { get; set; }
Visual Basic (Declaration)
Public Property DeathRecordMatchCaseWorkItemStatus As DeathRecordMatchCaseWorkItemStatus
Visual C++
public:
property DeathRecordMatchCaseWorkItemStatus DeathRecordMatchCaseWorkItemStatus {
    DeathRecordMatchCaseWorkItemStatus get ();
    void set (DeathRecordMatchCaseWorkItemStatus value);
}

See Also

DeathRecordMatchCaseWorkItem Class


DeathRecordMatchCaseWorkItemStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
DeathRecordMatchCaseWorkItemStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DeathRecordMatchCaseWorkItemStatus
Visual Basic (Declaration)
Public Enumeration DeathRecordMatchCaseWorkItemStatus
Visual C++
public enum class DeathRecordMatchCaseWorkItemStatus

Members

Member name | Description
Unhandled |
Accepted |
Rejected |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


DMVChangeOfAddressRecordMatchCaseWorkItem Class

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordMatchCaseWorkItem Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DMVChangeOfAddressRecordMatchCaseWorkItem : WorkItem
Visual Basic (Declaration)
Public Class DMVChangeOfAddressRecordMatchCaseWorkItem _
    Inherits WorkItem
Visual C++
public ref class DMVChangeOfAddressRecordMatchCaseWorkItem : public WorkItem

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItem
VoteCal.Management.Web.Services.Models..::.DMVChangeOfAddressRecordMatchCaseWorkItem

See Also

DMVChangeOfAddressRecordMatchCaseWorkItem Members


DMVChangeOfAddressRecordMatchCaseWorkItem Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordMatchCaseWorkItem Members
DMVChangeOfAddressRecordMatchCaseWorkItem Class Constructors Properties See Also Send Feedback

The DMVChangeOfAddressRecordMatchCaseWorkItem type exposes the following members.

Constructors

Name | Description
DMVChangeOfAddressRecordMatchCaseWorkItem | Overloaded.

Properties

Name | Description
ChangeOfAddressInfo |
DMVChangeOfAddressRecordMatchCaseWorkItemStatus |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

DMVChangeOfAddressRecordMatchCaseWorkItem Class


DMVChangeOfAddressRecordMatchCaseWorkItem Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordMatchCaseWorkItem Constructor
DMVChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Overload List

Name | Description
DMVChangeOfAddressRecordMatchCaseWorkItem()()() |
DMVChangeOfAddressRecordMatchCaseWorkItem(ChangeOfAddressInfo, AbbreviatedVoter, WorkItemStatus, DMVChangeOfAddressRecordMatchCaseWorkItemStatus) |

See Also

DMVChangeOfAddressRecordMatchCaseWorkItem Class
DMVChangeOfAddressRecordMatchCaseWorkItem Members


DMVChangeOfAddressRecordMatchCaseWorkItem Constructor

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordMatchCaseWorkItem Constructor
DMVChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordMatchCaseWorkItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DMVChangeOfAddressRecordMatchCaseWorkItem()

See Also

DMVChangeOfAddressRecordMatchCaseWorkItem Class
DMVChangeOfAddressRecordMatchCaseWorkItem Overload


DMVChangeOfAddressRecordMatchCaseWorkItem Constructor (ChangeOfAddressInfo, AbbreviatedVoter, WorkItemStatus, DMVChangeOfAddressRecordMatchCaseWorkItemStatus)

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordMatchCaseWorkItem Constructor (ChangeOfAddressInfo, AbbreviatedVoter, WorkItemStatus, DMVChangeOfAddressRecordMatchCaseWorkItemStatus)
DMVChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordMatchCaseWorkItem(
    ChangeOfAddressInfo changeOfAddressInfo,
    AbbreviatedVoter voterSummary,
    WorkItemStatus workItemStatus,
    DMVChangeOfAddressRecordMatchCaseWorkItemStatus dmvChangeOfAddressStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    changeOfAddressInfo As ChangeOfAddressInfo, _
    voterSummary As AbbreviatedVoter, _
    workItemStatus As WorkItemStatus, _
    dmvChangeOfAddressStatus As DMVChangeOfAddressRecordMatchCaseWorkItemStatus _
)
Visual C++
public:
DMVChangeOfAddressRecordMatchCaseWorkItem(
    ChangeOfAddressInfo^ changeOfAddressInfo,
    AbbreviatedVoter^ voterSummary,
    WorkItemStatus workItemStatus,
    DMVChangeOfAddressRecordMatchCaseWorkItemStatus dmvChangeOfAddressStatus
)

Parameters

changeOfAddressInfo
Type: VoteCal.Management.Web.Services.Models..::.ChangeOfAddressInfo
voterSummary
Type: VoteCal.Management.Web.Services.Models..::.AbbreviatedVoter
workItemStatus
Type: VoteCal.Management.Web.Services.Models..::.WorkItemStatus
dmvChangeOfAddressStatus
Type: VoteCal.Management.Web.Services.Models..::.DMVChangeOfAddressRecordMatchCaseWorkItemStatus

See Also

DMVChangeOfAddressRecordMatchCaseWorkItem Class
DMVChangeOfAddressRecordMatchCaseWorkItem Overload


DMVChangeOfAddressRecordMatchCaseWorkItem Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordMatchCaseWorkItem Properties
DMVChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

The DMVChangeOfAddressRecordMatchCaseWorkItem type exposes the following members.

Properties

Name | Description
ChangeOfAddressInfo |
DMVChangeOfAddressRecordMatchCaseWorkItemStatus |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

DMVChangeOfAddressRecordMatchCaseWorkItem Class


ChangeOfAddressInfo Property

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordMatchCaseWorkItem..::.ChangeOfAddressInfo Property
DMVChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChangeOfAddressInfo ChangeOfAddressInfo { get; set; }
Visual Basic (Declaration)
Public Property ChangeOfAddressInfo As ChangeOfAddressInfo
Visual C++
public:
property ChangeOfAddressInfo^ ChangeOfAddressInfo {
    ChangeOfAddressInfo^ get ();
    void set (ChangeOfAddressInfo^ value);
}

See Also

DMVChangeOfAddressRecordMatchCaseWorkItem Class


DMVChangeOfAddressRecordMatchCaseWorkItemStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordMatchCaseWorkItem..::.DMVChangeOfAddressRecordMatchCaseWorkItemStatus Property
DMVChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordMatchCaseWorkItemStatus DMVChangeOfAddressRecordMatchCaseWorkItemStatus { get; set; }
Visual Basic (Declaration)
Public Property DMVChangeOfAddressRecordMatchCaseWorkItemStatus As DMVChangeOfAddressRecordMatchCaseWorkItemStatus
Visual C++
public:
property DMVChangeOfAddressRecordMatchCaseWorkItemStatus DMVChangeOfAddressRecordMatchCaseWorkItemStatus {
    DMVChangeOfAddressRecordMatchCaseWorkItemStatus get ();
    void set (DMVChangeOfAddressRecordMatchCaseWorkItemStatus value);
}

See Also

DMVChangeOfAddressRecordMatchCaseWorkItem Class


DMVChangeOfAddressRecordMatchCaseWorkItemStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordMatchCaseWorkItemStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DMVChangeOfAddressRecordMatchCaseWorkItemStatus
Visual Basic (Declaration)
Public Enumeration DMVChangeOfAddressRecordMatchCaseWorkItemStatus
Visual C++
public enum class DMVChangeOfAddressRecordMatchCaseWorkItemStatus

Members

Member name | Description
None |
StaffUpdating |
Ignored |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


DMVChangeOfAddressRecordReceivedMessage Class

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordReceivedMessage Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DMVChangeOfAddressRecordReceivedMessage : Message
Visual Basic (Declaration)
Public Class DMVChangeOfAddressRecordReceivedMessage _
    Inherits Message
Visual C++
public ref class DMVChangeOfAddressRecordReceivedMessage : public Message

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.Message
VoteCal.Management.Web.Services.Models..::.DMVChangeOfAddressRecordReceivedMessage

See Also

DMVChangeOfAddressRecordReceivedMessage Members


DMVChangeOfAddressRecordReceivedMessage Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordReceivedMessage Members
DMVChangeOfAddressRecordReceivedMessage Class Constructors Properties See Also Send Feedback

The DMVChangeOfAddressRecordReceivedMessage type exposes the following members.

Constructors

Name | Description
DMVChangeOfAddressRecordReceivedMessage | Overloaded.

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
ChangeOfAddressInfo |
DMVChangeOfAddressRecordReceivedMessageStatus |
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)

See Also

DMVChangeOfAddressRecordReceivedMessage Class


DMVChangeOfAddressRecordReceivedMessage Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordReceivedMessage Constructor
DMVChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Overload List

Name | Description
DMVChangeOfAddressRecordReceivedMessage()()() |
DMVChangeOfAddressRecordReceivedMessage(ChangeOfAddressInfo, MessageStatus, AbbreviatedVoter, DMVChangeOfAddressRecordReceivedMessageStatus) |

See Also

DMVChangeOfAddressRecordReceivedMessage Class
DMVChangeOfAddressRecordReceivedMessage Members


DMVChangeOfAddressRecordReceivedMessage Constructor

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordReceivedMessage Constructor
DMVChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordReceivedMessage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DMVChangeOfAddressRecordReceivedMessage()

See Also

DMVChangeOfAddressRecordReceivedMessage Class
DMVChangeOfAddressRecordReceivedMessage Overload


DMVChangeOfAddressRecordReceivedMessage Constructor (ChangeOfAddressInfo, MessageStatus, AbbreviatedVoter, DMVChangeOfAddressRecordReceivedMessageStatus)

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordReceivedMessage Constructor (ChangeOfAddressInfo, MessageStatus, AbbreviatedVoter, DMVChangeOfAddressRecordReceivedMessageStatus)
DMVChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordReceivedMessage(
    ChangeOfAddressInfo changeOfAddressInfo,
    MessageStatus messageStatus,
    AbbreviatedVoter abbreviatedVoter,
    DMVChangeOfAddressRecordReceivedMessageStatus dmvChangeOfAddressRecordReceivedMessageStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    changeOfAddressInfo As ChangeOfAddressInfo, _
    messageStatus As MessageStatus, _
    abbreviatedVoter As AbbreviatedVoter, _
    dmvChangeOfAddressRecordReceivedMessageStatus As DMVChangeOfAddressRecordReceivedMessageStatus _
)
Visual C++
public:
DMVChangeOfAddressRecordReceivedMessage(
    ChangeOfAddressInfo^ changeOfAddressInfo,
    MessageStatus messageStatus,
    AbbreviatedVoter^ abbreviatedVoter,
    DMVChangeOfAddressRecordReceivedMessageStatus dmvChangeOfAddressRecordReceivedMessageStatus
)

Parameters

changeOfAddressInfo
Type: VoteCal.Management.Web.Services.Models..::.ChangeOfAddressInfo
messageStatus
Type: VoteCal.Management.Web.Services.Models..::.MessageStatus
abbreviatedVoter
Type: VoteCal.Management.Web.Services.Models..::.AbbreviatedVoter
dmvChangeOfAddressRecordReceivedMessageStatus
Type: VoteCal.Management.Web.Services.Models..::.DMVChangeOfAddressRecordReceivedMessageStatus

See Also

DMVChangeOfAddressRecordReceivedMessage Class
DMVChangeOfAddressRecordReceivedMessage Overload


DMVChangeOfAddressRecordReceivedMessage Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordReceivedMessage Properties
DMVChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

The DMVChangeOfAddressRecordReceivedMessage type exposes the following members.

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
ChangeOfAddressInfo |
DMVChangeOfAddressRecordReceivedMessageStatus |
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)

See Also

DMVChangeOfAddressRecordReceivedMessage Class


ChangeOfAddressInfo Property

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordReceivedMessage..::.ChangeOfAddressInfo Property
DMVChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChangeOfAddressInfo ChangeOfAddressInfo { get; set; }
Visual Basic (Declaration)
Public Property ChangeOfAddressInfo As ChangeOfAddressInfo
Visual C++
public:
property ChangeOfAddressInfo^ ChangeOfAddressInfo {
    ChangeOfAddressInfo^ get ();
    void set (ChangeOfAddressInfo^ value);
}

See Also

DMVChangeOfAddressRecordReceivedMessage Class


DMVChangeOfAddressRecordReceivedMessageStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordReceivedMessage..::.DMVChangeOfAddressRecordReceivedMessageStatus Property
DMVChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordReceivedMessageStatus DMVChangeOfAddressRecordReceivedMessageStatus { get; set; }
Visual Basic (Declaration)
Public Property DMVChangeOfAddressRecordReceivedMessageStatus As DMVChangeOfAddressRecordReceivedMessageStatus
Visual C++
public:
property DMVChangeOfAddressRecordReceivedMessageStatus DMVChangeOfAddressRecordReceivedMessageStatus {
    DMVChangeOfAddressRecordReceivedMessageStatus get ();
    void set (DMVChangeOfAddressRecordReceivedMessageStatus value);
}

See Also

DMVChangeOfAddressRecordReceivedMessage Class


DMVChangeOfAddressRecordReceivedMessageStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
DMVChangeOfAddressRecordReceivedMessageStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DMVChangeOfAddressRecordReceivedMessageStatus
Visual Basic (Declaration)
Public Enumeration DMVChangeOfAddressRecordReceivedMessageStatus
Visual C++
public enum class DMVChangeOfAddressRecordReceivedMessageStatus

Members

Member name | Description
Unhandled |
DMVChangeOfAddressApplied |
CannotApplyDMVChangeOfAddress |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


DuplicateVoterMatchCaseWorkItem Class

[image]

VoteCal EMS Vendor Integration API Reference
DuplicateVoterMatchCaseWorkItem Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class DuplicateVoterMatchCaseWorkItem : WorkItem
Visual Basic (Declaration)
Public Class DuplicateVoterMatchCaseWorkItem _
    Inherits WorkItem
Visual C++
public ref class DuplicateVoterMatchCaseWorkItem : public WorkItem

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItem
VoteCal.Management.Web.Services.Models..::.DuplicateVoterMatchCaseWorkItem

See Also

DuplicateVoterMatchCaseWorkItem Members


DuplicateVoterMatchCaseWorkItem Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
DuplicateVoterMatchCaseWorkItem Members
DuplicateVoterMatchCaseWorkItem Class Constructors Properties See Also Send Feedback

The DuplicateVoterMatchCaseWorkItem type exposes the following members.

Constructors

Name | Description
DuplicateVoterMatchCaseWorkItem |

Properties

Name | Description
Confidence |
DuplicateVoterMatchCaseWorkItemStatus |
DuplicateVoters |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

DuplicateVoterMatchCaseWorkItem Class


DuplicateVoterMatchCaseWorkItem Constructor

[image]

VoteCal EMS Vendor Integration API Reference
DuplicateVoterMatchCaseWorkItem Constructor
DuplicateVoterMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DuplicateVoterMatchCaseWorkItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DuplicateVoterMatchCaseWorkItem()

See Also

DuplicateVoterMatchCaseWorkItem Class


DuplicateVoterMatchCaseWorkItem Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
DuplicateVoterMatchCaseWorkItem Properties
DuplicateVoterMatchCaseWorkItem Class See Also Send Feedback

The DuplicateVoterMatchCaseWorkItem type exposes the following members.

Properties

Name | Description
Confidence |
DuplicateVoterMatchCaseWorkItemStatus |
DuplicateVoters |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

DuplicateVoterMatchCaseWorkItem Class


Confidence Property

[image]

VoteCal EMS Vendor Integration API Reference
DuplicateVoterMatchCaseWorkItem..::.Confidence Property
DuplicateVoterMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public decimal Confidence { get; set; }
Visual Basic (Declaration)
Public Property Confidence As Decimal
Visual C++
public:
property Decimal Confidence {
    Decimal get ();
    void set (Decimal value);
}

See Also

DuplicateVoterMatchCaseWorkItem Class


DuplicateVoterMatchCaseWorkItemStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
DuplicateVoterMatchCaseWorkItem..::.DuplicateVoterMatchCaseWorkItemStatus Property
DuplicateVoterMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DuplicateVoterMatchCaseWorkItemStatus DuplicateVoterMatchCaseWorkItemStatus { get; set; }
Visual Basic (Declaration)
Public Property DuplicateVoterMatchCaseWorkItemStatus As DuplicateVoterMatchCaseWorkItemStatus
Visual C++
public:
property DuplicateVoterMatchCaseWorkItemStatus DuplicateVoterMatchCaseWorkItemStatus {
    DuplicateVoterMatchCaseWorkItemStatus get ();
    void set (DuplicateVoterMatchCaseWorkItemStatus value);
}

See Also

DuplicateVoterMatchCaseWorkItem Class


DuplicateVoters Property

[image]

VoteCal EMS Vendor Integration API Reference
DuplicateVoterMatchCaseWorkItem..::.DuplicateVoters Property
DuplicateVoterMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Voter[] DuplicateVoters { get; set; }
Visual Basic (Declaration)
Public Property DuplicateVoters As Voter()
Visual C++
public:
property array<Voter^>^ DuplicateVoters {
    array<Voter^>^ get ();
    void set (array<Voter^>^ value);
}

See Also

DuplicateVoterMatchCaseWorkItem Class


DuplicateVoterMatchCaseWorkItemStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
DuplicateVoterMatchCaseWorkItemStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum DuplicateVoterMatchCaseWorkItemStatus
Visual Basic (Declaration)
Public Enumeration DuplicateVoterMatchCaseWorkItemStatus
Visual C++
public enum class DuplicateVoterMatchCaseWorkItemStatus

Members

Member name | Description
Unhandled |
Accepted |
Rejected |
Pushed |
Reversed |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


FelonRecordInfo Class

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordInfo Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FelonRecordInfo
Visual Basic (Declaration)
Public Class FelonRecordInfo
Visual C++
public ref class FelonRecordInfo

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.FelonRecordInfo

See Also

FelonRecordInfo Members


FelonRecordInfo Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
FelonRecordInfo Members
FelonRecordInfo Class Constructors Properties See Also Send Feedback

The FelonRecordInfo type exposes the following members.

Constructors

Name | Description
FelonRecordInfo |

Properties

Name | Description
BirthDate |
FirstName |
LastName |

See Also

FelonRecordInfo Class


FelonRecordInfo Constructor

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordInfo Constructor
FelonRecordInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FelonRecordInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FelonRecordInfo()

See Also

FelonRecordInfo Class


FelonRecordInfo Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
FelonRecordInfo Properties
FelonRecordInfo Class See Also Send Feedback

The FelonRecordInfo type exposes the following members.

Properties

Name | Description
BirthDate |
FirstName |
LastName |

See Also

FelonRecordInfo Class


BirthDate Property

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordInfo..::.BirthDate Property
FelonRecordInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime BirthDate { get; set; }
Visual Basic (Declaration)
Public Property BirthDate As DateTime
Visual C++
public:
property DateTime BirthDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

FelonRecordInfo Class


FirstName Property

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordInfo..::.FirstName Property
FelonRecordInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

FelonRecordInfo Class


LastName Property

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordInfo..::.LastName Property
FelonRecordInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

FelonRecordInfo Class


FelonRecordMatchCaseWorkItem Class

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordMatchCaseWorkItem Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class FelonRecordMatchCaseWorkItem : WorkItem
Visual Basic (Declaration)
Public Class FelonRecordMatchCaseWorkItem _
    Inherits WorkItem
Visual C++
public ref class FelonRecordMatchCaseWorkItem : public WorkItem

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItem
VoteCal.Management.Web.Services.Models..::.FelonRecordMatchCaseWorkItem

See Also

FelonRecordMatchCaseWorkItem Members


FelonRecordMatchCaseWorkItem Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
FelonRecordMatchCaseWorkItem Members
FelonRecordMatchCaseWorkItem Class Constructors Properties See Also Send Feedback

The FelonRecordMatchCaseWorkItem type exposes the following members.

Constructors

Name | Description
FelonRecordMatchCaseWorkItem |

Properties

Name | Description
Confidence |
FelonRecordInfo |
FelonRecordMatchCaseWorkItemStatus |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

FelonRecordMatchCaseWorkItem Class


FelonRecordMatchCaseWorkItem Constructor

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordMatchCaseWorkItem Constructor
FelonRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FelonRecordMatchCaseWorkItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
FelonRecordMatchCaseWorkItem()

See Also

FelonRecordMatchCaseWorkItem Class


FelonRecordMatchCaseWorkItem Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
FelonRecordMatchCaseWorkItem Properties
FelonRecordMatchCaseWorkItem Class See Also Send Feedback

The FelonRecordMatchCaseWorkItem type exposes the following members.

Properties

Name | Description
Confidence |
FelonRecordInfo |
FelonRecordMatchCaseWorkItemStatus |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

FelonRecordMatchCaseWorkItem Class


Confidence Property

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordMatchCaseWorkItem..::.Confidence Property
FelonRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public decimal Confidence { get; set; }
Visual Basic (Declaration)
Public Property Confidence As Decimal
Visual C++
public:
property Decimal Confidence {
    Decimal get ();
    void set (Decimal value);
}

See Also

FelonRecordMatchCaseWorkItem Class


FelonRecordInfo Property

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordMatchCaseWorkItem..::.FelonRecordInfo Property
FelonRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FelonRecordInfo FelonRecordInfo { get; set; }
Visual Basic (Declaration)
Public Property FelonRecordInfo As FelonRecordInfo
Visual C++
public:
property FelonRecordInfo^ FelonRecordInfo {
    FelonRecordInfo^ get ();
    void set (FelonRecordInfo^ value);
}

See Also

FelonRecordMatchCaseWorkItem Class


FelonRecordMatchCaseWorkItemStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordMatchCaseWorkItem..::.FelonRecordMatchCaseWorkItemStatus Property
FelonRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FelonRecordMatchCaseWorkItemStatus FelonRecordMatchCaseWorkItemStatus { get; set; }
Visual Basic (Declaration)
Public Property FelonRecordMatchCaseWorkItemStatus As FelonRecordMatchCaseWorkItemStatus
Visual C++
public:
property FelonRecordMatchCaseWorkItemStatus FelonRecordMatchCaseWorkItemStatus {
    FelonRecordMatchCaseWorkItemStatus get ();
    void set (FelonRecordMatchCaseWorkItemStatus value);
}

See Also

FelonRecordMatchCaseWorkItem Class


FelonRecordMatchCaseWorkItemStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
FelonRecordMatchCaseWorkItemStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum FelonRecordMatchCaseWorkItemStatus
Visual Basic (Declaration)
Public Enumeration FelonRecordMatchCaseWorkItemStatus
Visual C++
public enum class FelonRecordMatchCaseWorkItemStatus

Members

Member name | Description
Unhandled |
Accept |
Reject |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


GetDataValidationErrorWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetDataValidationErrorWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetDataValidationErrorWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetDataValidationErrorWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetDataValidationErrorWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetDataValidationErrorWorkItemsResponse

See Also

GetDataValidationErrorWorkItemsResponse Members


GetDataValidationErrorWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDataValidationErrorWorkItemsResponse Members
GetDataValidationErrorWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetDataValidationErrorWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetDataValidationErrorWorkItemsResponse |

Properties

Name | Description
DataValidationErrorWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetDataValidationErrorWorkItemsResponse Class


GetDataValidationErrorWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetDataValidationErrorWorkItemsResponse Constructor
GetDataValidationErrorWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDataValidationErrorWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetDataValidationErrorWorkItemsResponse()

See Also

GetDataValidationErrorWorkItemsResponse Class


GetDataValidationErrorWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDataValidationErrorWorkItemsResponse Properties
GetDataValidationErrorWorkItemsResponse Class See Also Send Feedback

The GetDataValidationErrorWorkItemsResponse type exposes the following members.

Properties

Name | Description
DataValidationErrorWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetDataValidationErrorWorkItemsResponse Class


DataValidationErrorWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
GetDataValidationErrorWorkItemsResponse..::.DataValidationErrorWorkItems Property
GetDataValidationErrorWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataValidationErrorWorkItem[] DataValidationErrorWorkItems { get; set; }
Visual Basic (Declaration)
Public Property DataValidationErrorWorkItems As DataValidationErrorWorkItem()
Visual C++
public:
property array<DataValidationErrorWorkItem^>^ DataValidationErrorWorkItems {
    array<DataValidationErrorWorkItem^>^ get ();
    void set (array<DataValidationErrorWorkItem^>^ value);
}

See Also

GetDataValidationErrorWorkItemsResponse Class


GetDeathRecordMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetDeathRecordMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetDeathRecordMatchCaseWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetDeathRecordMatchCaseWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetDeathRecordMatchCaseWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetDeathRecordMatchCaseWorkItemsResponse

See Also

GetDeathRecordMatchCaseWorkItemsResponse Members


GetDeathRecordMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDeathRecordMatchCaseWorkItemsResponse Members
GetDeathRecordMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetDeathRecordMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetDeathRecordMatchCaseWorkItemsResponse | Overloaded.

Properties

Name | Description
DeathRecordMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetDeathRecordMatchCaseWorkItemsResponse Class


GetDeathRecordMatchCaseWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDeathRecordMatchCaseWorkItemsResponse Constructor
GetDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
GetDeathRecordMatchCaseWorkItemsResponse()()() |
GetDeathRecordMatchCaseWorkItemsResponse(ResponseStatus) |

See Also

GetDeathRecordMatchCaseWorkItemsResponse Class
GetDeathRecordMatchCaseWorkItemsResponse Members


GetDeathRecordMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetDeathRecordMatchCaseWorkItemsResponse Constructor
GetDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDeathRecordMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetDeathRecordMatchCaseWorkItemsResponse()

See Also

GetDeathRecordMatchCaseWorkItemsResponse Class
GetDeathRecordMatchCaseWorkItemsResponse Overload


GetDeathRecordMatchCaseWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
GetDeathRecordMatchCaseWorkItemsResponse Constructor (ResponseStatus)
GetDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDeathRecordMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
GetDeathRecordMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

GetDeathRecordMatchCaseWorkItemsResponse Class
GetDeathRecordMatchCaseWorkItemsResponse Overload


GetDeathRecordMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDeathRecordMatchCaseWorkItemsResponse Properties
GetDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

The GetDeathRecordMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
DeathRecordMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetDeathRecordMatchCaseWorkItemsResponse Class


DeathRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
GetDeathRecordMatchCaseWorkItemsResponse..::.DeathRecordMatchCaseWorkItems Property
GetDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DeathRecordMatchCaseWorkItem[] DeathRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property DeathRecordMatchCaseWorkItems As DeathRecordMatchCaseWorkItem()
Visual C++
public:
property array<DeathRecordMatchCaseWorkItem^>^ DeathRecordMatchCaseWorkItems {
    array<DeathRecordMatchCaseWorkItem^>^ get ();
    void set (array<DeathRecordMatchCaseWorkItem^>^ value);
}

See Also

GetDeathRecordMatchCaseWorkItemsResponse Class


GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse

See Also

GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Members


GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Members
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse |

Properties

Name | Description
DMVChangeOfAddressRecordMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class


GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Constructor
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse()

See Also

GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class


GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Properties
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

The GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
DMVChangeOfAddressRecordMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class


DMVChangeOfAddressRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse..::.DMVChangeOfAddressRecordMatchCaseWorkItems Property
GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordMatchCaseWorkItem[] DMVChangeOfAddressRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property DMVChangeOfAddressRecordMatchCaseWorkItems As DMVChangeOfAddressRecordMatchCaseWorkItem()
Visual C++
public:
property array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ DMVChangeOfAddressRecordMatchCaseWorkItems {
    array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ get ();
    void set (array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ value);
}

See Also

GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class


GetDuplicateVoterMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetDuplicateVoterMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetDuplicateVoterMatchCaseWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetDuplicateVoterMatchCaseWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetDuplicateVoterMatchCaseWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetDuplicateVoterMatchCaseWorkItemsResponse

See Also

GetDuplicateVoterMatchCaseWorkItemsResponse Members


GetDuplicateVoterMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDuplicateVoterMatchCaseWorkItemsResponse Members
GetDuplicateVoterMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetDuplicateVoterMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetDuplicateVoterMatchCaseWorkItemsResponse | Overloaded.

Properties

Name | Description
DuplicateVoterMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetDuplicateVoterMatchCaseWorkItemsResponse Class


GetDuplicateVoterMatchCaseWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDuplicateVoterMatchCaseWorkItemsResponse Constructor
GetDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
GetDuplicateVoterMatchCaseWorkItemsResponse()()() |
GetDuplicateVoterMatchCaseWorkItemsResponse(ResponseStatus) |

See Also

GetDuplicateVoterMatchCaseWorkItemsResponse Class
GetDuplicateVoterMatchCaseWorkItemsResponse Members


GetDuplicateVoterMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetDuplicateVoterMatchCaseWorkItemsResponse Constructor
GetDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDuplicateVoterMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetDuplicateVoterMatchCaseWorkItemsResponse()

See Also

GetDuplicateVoterMatchCaseWorkItemsResponse Class
GetDuplicateVoterMatchCaseWorkItemsResponse Overload


GetDuplicateVoterMatchCaseWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
GetDuplicateVoterMatchCaseWorkItemsResponse Constructor (ResponseStatus)
GetDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetDuplicateVoterMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
GetDuplicateVoterMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

GetDuplicateVoterMatchCaseWorkItemsResponse Class
GetDuplicateVoterMatchCaseWorkItemsResponse Overload


GetDuplicateVoterMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetDuplicateVoterMatchCaseWorkItemsResponse Properties
GetDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

The GetDuplicateVoterMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
DuplicateVoterMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetDuplicateVoterMatchCaseWorkItemsResponse Class


DuplicateVoterMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
GetDuplicateVoterMatchCaseWorkItemsResponse..::.DuplicateVoterMatchCaseWorkItems Property
GetDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DuplicateVoterMatchCaseWorkItem[] DuplicateVoterMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property DuplicateVoterMatchCaseWorkItems As DuplicateVoterMatchCaseWorkItem()
Visual C++
public:
property array<DuplicateVoterMatchCaseWorkItem^>^ DuplicateVoterMatchCaseWorkItems {
    array<DuplicateVoterMatchCaseWorkItem^>^ get ();
    void set (array<DuplicateVoterMatchCaseWorkItem^>^ value);
}

See Also

GetDuplicateVoterMatchCaseWorkItemsResponse Class


GetEMSVoterUpdateWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetEMSVoterUpdateWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetEMSVoterUpdateWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetEMSVoterUpdateWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetEMSVoterUpdateWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetEMSVoterUpdateWorkItemsResponse

See Also

GetEMSVoterUpdateWorkItemsResponse Members


GetEMSVoterUpdateWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetEMSVoterUpdateWorkItemsResponse Members
GetEMSVoterUpdateWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetEMSVoterUpdateWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetEMSVoterUpdateWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetEMSVoterUpdateWorkItemsResponse Class


GetEMSVoterUpdateWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetEMSVoterUpdateWorkItemsResponse Constructor
GetEMSVoterUpdateWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
GetEMSVoterUpdateWorkItemsResponse()()() |
GetEMSVoterUpdateWorkItemsResponse(ResponseStatus) |

See Also

GetEMSVoterUpdateWorkItemsResponse Class
GetEMSVoterUpdateWorkItemsResponse Members


GetEMSVoterUpdateWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetEMSVoterUpdateWorkItemsResponse Constructor
GetEMSVoterUpdateWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetEMSVoterUpdateWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetEMSVoterUpdateWorkItemsResponse()

See Also

GetEMSVoterUpdateWorkItemsResponse Class
GetEMSVoterUpdateWorkItemsResponse Overload


GetEMSVoterUpdateWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
GetEMSVoterUpdateWorkItemsResponse Constructor (ResponseStatus)
GetEMSVoterUpdateWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetEMSVoterUpdateWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
GetEMSVoterUpdateWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

GetEMSVoterUpdateWorkItemsResponse Class
GetEMSVoterUpdateWorkItemsResponse Overload


GetEMSVoterUpdateWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetEMSVoterUpdateWorkItemsResponse Properties
GetEMSVoterUpdateWorkItemsResponse Class See Also Send Feedback

The GetEMSVoterUpdateWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetEMSVoterUpdateWorkItemsResponse Class


GetFelonRecordMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetFelonRecordMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetFelonRecordMatchCaseWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetFelonRecordMatchCaseWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetFelonRecordMatchCaseWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetFelonRecordMatchCaseWorkItemsResponse

See Also

GetFelonRecordMatchCaseWorkItemsResponse Members


GetFelonRecordMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetFelonRecordMatchCaseWorkItemsResponse Members
GetFelonRecordMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetFelonRecordMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetFelonRecordMatchCaseWorkItemsResponse | Overloaded.

Properties

Name | Description
FelonRecordMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetFelonRecordMatchCaseWorkItemsResponse Class


GetFelonRecordMatchCaseWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetFelonRecordMatchCaseWorkItemsResponse Constructor
GetFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
GetFelonRecordMatchCaseWorkItemsResponse()()() |
GetFelonRecordMatchCaseWorkItemsResponse(ResponseStatus) |

See Also

GetFelonRecordMatchCaseWorkItemsResponse Class
GetFelonRecordMatchCaseWorkItemsResponse Members


GetFelonRecordMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetFelonRecordMatchCaseWorkItemsResponse Constructor
GetFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetFelonRecordMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetFelonRecordMatchCaseWorkItemsResponse()

See Also

GetFelonRecordMatchCaseWorkItemsResponse Class
GetFelonRecordMatchCaseWorkItemsResponse Overload


GetFelonRecordMatchCaseWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
GetFelonRecordMatchCaseWorkItemsResponse Constructor (ResponseStatus)
GetFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetFelonRecordMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
GetFelonRecordMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

GetFelonRecordMatchCaseWorkItemsResponse Class
GetFelonRecordMatchCaseWorkItemsResponse Overload


GetFelonRecordMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetFelonRecordMatchCaseWorkItemsResponse Properties
GetFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

The GetFelonRecordMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
FelonRecordMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetFelonRecordMatchCaseWorkItemsResponse Class


FelonRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
GetFelonRecordMatchCaseWorkItemsResponse..::.FelonRecordMatchCaseWorkItems Property
GetFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FelonRecordMatchCaseWorkItem[] FelonRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property FelonRecordMatchCaseWorkItems As FelonRecordMatchCaseWorkItem()
Visual C++
public:
property array<FelonRecordMatchCaseWorkItem^>^ FelonRecordMatchCaseWorkItems {
    array<FelonRecordMatchCaseWorkItem^>^ get ();
    void set (array<FelonRecordMatchCaseWorkItem^>^ value);
}

See Also

GetFelonRecordMatchCaseWorkItemsResponse Class


GetItemsResponseStatusReason Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
GetItemsResponseStatusReason Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum GetItemsResponseStatusReason
Visual Basic (Declaration)
Public Enumeration GetItemsResponseStatusReason
Visual C++
public enum class GetItemsResponseStatusReason

Members

Member name | Description
None |
InvalidWorkItemIdsDetected |
InvalidCredentials |
Unknown |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse

See Also

GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Members


GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Members
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse |

Properties

Name | Description
NationalChangeOfAddressRecordMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class


GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Constructor
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse()

See Also

GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class


GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Properties
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

The GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
NationalChangeOfAddressRecordMatchCaseWorkItems |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class


NationalChangeOfAddressRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse..::.NationalChangeOfAddressRecordMatchCaseWorkItems Property
GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordMatchCaseWorkItem[] NationalChangeOfAddressRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property NationalChangeOfAddressRecordMatchCaseWorkItems As NationalChangeOfAddressRecordMatchCaseWorkItem()
Visual C++
public:
property array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ NationalChangeOfAddressRecordMatchCaseWorkItems {
    array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ get ();
    void set (array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ value);
}

See Also

GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class


GetNewRegistrationWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetNewRegistrationWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetNewRegistrationWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetNewRegistrationWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetNewRegistrationWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetNewRegistrationWorkItemsResponse

See Also

GetNewRegistrationWorkItemsResponse Members


GetNewRegistrationWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetNewRegistrationWorkItemsResponse Members
GetNewRegistrationWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetNewRegistrationWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetNewRegistrationWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetNewRegistrationWorkItemsResponse Class


GetNewRegistrationWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetNewRegistrationWorkItemsResponse Constructor
GetNewRegistrationWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
GetNewRegistrationWorkItemsResponse()()() |
GetNewRegistrationWorkItemsResponse(ResponseStatus) |

See Also

GetNewRegistrationWorkItemsResponse Class
GetNewRegistrationWorkItemsResponse Members


GetNewRegistrationWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetNewRegistrationWorkItemsResponse Constructor
GetNewRegistrationWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetNewRegistrationWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetNewRegistrationWorkItemsResponse()

See Also

GetNewRegistrationWorkItemsResponse Class
GetNewRegistrationWorkItemsResponse Overload


GetNewRegistrationWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
GetNewRegistrationWorkItemsResponse Constructor (ResponseStatus)
GetNewRegistrationWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetNewRegistrationWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
GetNewRegistrationWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

GetNewRegistrationWorkItemsResponse Class
GetNewRegistrationWorkItemsResponse Overload


GetNewRegistrationWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetNewRegistrationWorkItemsResponse Properties
GetNewRegistrationWorkItemsResponse Class See Also Send Feedback

The GetNewRegistrationWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetNewRegistrationWorkItemsResponse Class


GetOpenMessagesResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetOpenMessagesResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class GetOpenMessagesResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class GetOpenMessagesResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetOpenMessagesResponse

See Also

GetOpenMessagesResponse Members


GetOpenMessagesResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse Members
GetOpenMessagesResponse Class Constructors Properties See Also Send Feedback

The GetOpenMessagesResponse type exposes the following members.

Constructors

Name | Description
GetOpenMessagesResponse |

Properties

Name | Description
DMVChangeOfAddressRecordReceivedMessages | An array of DMVChangeOfAddressRecordReceivedMessage objects
NationalChangeOfAddressRecordReceivedMessages | An array of NationalChangeOfAddressRecordReceivedMessage objects
NewVoterReceivedMessages | An array of NewVoterReceivedMessage objects
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
StateVoterActivityCreatedMessages | An array of StateVoterActivityCreatedMessage objects
StateVoterStatusUpdatedMessages | An array of StateVoterStatusUpdatedMessage objects
StateVoterUpdatedMessages | An array of StateVoterUpdatedMessage objects

See Also

GetOpenMessagesResponse Class


GetOpenMessagesResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse Constructor
GetOpenMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetOpenMessagesResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetOpenMessagesResponse()

See Also

GetOpenMessagesResponse Class


GetOpenMessagesResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse Properties
GetOpenMessagesResponse Class See Also Send Feedback

The GetOpenMessagesResponse type exposes the following members.

Properties

Name | Description
DMVChangeOfAddressRecordReceivedMessages | An array of DMVChangeOfAddressRecordReceivedMessage objects
NationalChangeOfAddressRecordReceivedMessages | An array of NationalChangeOfAddressRecordReceivedMessage objects
NewVoterReceivedMessages | An array of NewVoterReceivedMessage objects
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
StateVoterActivityCreatedMessages | An array of StateVoterActivityCreatedMessage objects
StateVoterStatusUpdatedMessages | An array of StateVoterStatusUpdatedMessage objects
StateVoterUpdatedMessages | An array of StateVoterUpdatedMessage objects

See Also

GetOpenMessagesResponse Class


DMVChangeOfAddressRecordReceivedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse..::.DMVChangeOfAddressRecordReceivedMessages Property
GetOpenMessagesResponse Class See Also Send Feedback
An array of DMVChangeOfAddressRecordReceivedMessage objects

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordReceivedMessage[] DMVChangeOfAddressRecordReceivedMessages { get; set; }
Visual Basic (Declaration)
Public Property DMVChangeOfAddressRecordReceivedMessages As DMVChangeOfAddressRecordReceivedMessage()
Visual C++
public:
property array<DMVChangeOfAddressRecordReceivedMessage^>^ DMVChangeOfAddressRecordReceivedMessages {
    array<DMVChangeOfAddressRecordReceivedMessage^>^ get ();
    void set (array<DMVChangeOfAddressRecordReceivedMessage^>^ value);
}

See Also

GetOpenMessagesResponse Class


NationalChangeOfAddressRecordReceivedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse..::.NationalChangeOfAddressRecordReceivedMessages Property
GetOpenMessagesResponse Class See Also Send Feedback
An array of NationalChangeOfAddressRecordReceivedMessage objects

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordReceivedMessage[] NationalChangeOfAddressRecordReceivedMessages { get; set; }
Visual Basic (Declaration)
Public Property NationalChangeOfAddressRecordReceivedMessages As NationalChangeOfAddressRecordReceivedMessage()
Visual C++
public:
property array<NationalChangeOfAddressRecordReceivedMessage^>^ NationalChangeOfAddressRecordReceivedMessages {
    array<NationalChangeOfAddressRecordReceivedMessage^>^ get ();
    void set (array<NationalChangeOfAddressRecordReceivedMessage^>^ value);
}

See Also

GetOpenMessagesResponse Class


NewVoterReceivedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse..::.NewVoterReceivedMessages Property
GetOpenMessagesResponse Class See Also Send Feedback
An array of NewVoterReceivedMessage objects

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NewVoterReceivedMessage[] NewVoterReceivedMessages { get; set; }
Visual Basic (Declaration)
Public Property NewVoterReceivedMessages As NewVoterReceivedMessage()
Visual C++
public:
property array<NewVoterReceivedMessage^>^ NewVoterReceivedMessages {
    array<NewVoterReceivedMessage^>^ get ();
    void set (array<NewVoterReceivedMessage^>^ value);
}

See Also

GetOpenMessagesResponse Class


ResponseStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse..::.ResponseStatusReason Property
GetOpenMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetOpenMessagesResponseStatusReason ResponseStatusReason { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatusReason As GetOpenMessagesResponseStatusReason
Visual C++
public:
property GetOpenMessagesResponseStatusReason ResponseStatusReason {
    GetOpenMessagesResponseStatusReason get ();
    void set (GetOpenMessagesResponseStatusReason value);
}

See Also

GetOpenMessagesResponse Class


StateVoterActivityCreatedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse..::.StateVoterActivityCreatedMessages Property
GetOpenMessagesResponse Class See Also Send Feedback
An array of StateVoterActivityCreatedMessage objects

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterActivityCreatedMessage[] StateVoterActivityCreatedMessages { get; set; }
Visual Basic (Declaration)
Public Property StateVoterActivityCreatedMessages As StateVoterActivityCreatedMessage()
Visual C++
public:
property array<StateVoterActivityCreatedMessage^>^ StateVoterActivityCreatedMessages {
    array<StateVoterActivityCreatedMessage^>^ get ();
    void set (array<StateVoterActivityCreatedMessage^>^ value);
}

See Also

GetOpenMessagesResponse Class


StateVoterStatusUpdatedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse..::.StateVoterStatusUpdatedMessages Property
GetOpenMessagesResponse Class See Also Send Feedback
An array of StateVoterStatusUpdatedMessage objects

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterStatusUpdatedMessage[] StateVoterStatusUpdatedMessages { get; set; }
Visual Basic (Declaration)
Public Property StateVoterStatusUpdatedMessages As StateVoterStatusUpdatedMessage()
Visual C++
public:
property array<StateVoterStatusUpdatedMessage^>^ StateVoterStatusUpdatedMessages {
    array<StateVoterStatusUpdatedMessage^>^ get ();
    void set (array<StateVoterStatusUpdatedMessage^>^ value);
}

See Also

GetOpenMessagesResponse Class


StateVoterUpdatedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponse..::.StateVoterUpdatedMessages Property
GetOpenMessagesResponse Class See Also Send Feedback
An array of StateVoterUpdatedMessage objects

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterUpdatedMessage[] StateVoterUpdatedMessages { get; set; }
Visual Basic (Declaration)
Public Property StateVoterUpdatedMessages As StateVoterUpdatedMessage()
Visual C++
public:
property array<StateVoterUpdatedMessage^>^ StateVoterUpdatedMessages {
    array<StateVoterUpdatedMessage^>^ get ();
    void set (array<StateVoterUpdatedMessage^>^ value);
}

See Also

GetOpenMessagesResponse Class


GetOpenMessagesResponseStatusReason Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenMessagesResponseStatusReason Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum GetOpenMessagesResponseStatusReason
Visual Basic (Declaration)
Public Enumeration GetOpenMessagesResponseStatusReason
Visual C++
public enum class GetOpenMessagesResponseStatusReason

Members

Member name | Description
None |
InvalidCredentials |
Unknown |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


GetOpenWorkItemCountsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetOpenWorkItemCountsResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class GetOpenWorkItemCountsResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class GetOpenWorkItemCountsResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetOpenWorkItemCountsResponse

See Also

GetOpenWorkItemCountsResponse Members


GetOpenWorkItemCountsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse Members
GetOpenWorkItemCountsResponse Class Constructors Properties See Also Send Feedback

The GetOpenWorkItemCountsResponse type exposes the following members.

Constructors

Name | Description
GetOpenWorkItemCountsResponse |

Properties

Name | Description
OpenDeathRecordMatchCaseWorkItemsCount |
OpenDMVChangeOfAddressRecordMatchCaseWorkItemsCount |
OpenDuplicateVoterMatchCaseWorkItemsCount |
OpenFelonRecordMatchCaseWorkItemsCount |
OpenNationalChangeOfAddressRecordMatchCaseWorkItemsCount |
OpenTransferOutWorkItemsCount |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |

See Also

GetOpenWorkItemCountsResponse Class


GetOpenWorkItemCountsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse Constructor
GetOpenWorkItemCountsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetOpenWorkItemCountsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetOpenWorkItemCountsResponse()

See Also

GetOpenWorkItemCountsResponse Class


GetOpenWorkItemCountsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse Properties
GetOpenWorkItemCountsResponse Class See Also Send Feedback

The GetOpenWorkItemCountsResponse type exposes the following members.

Properties

Name | Description
OpenDeathRecordMatchCaseWorkItemsCount |
OpenDMVChangeOfAddressRecordMatchCaseWorkItemsCount |
OpenDuplicateVoterMatchCaseWorkItemsCount |
OpenFelonRecordMatchCaseWorkItemsCount |
OpenNationalChangeOfAddressRecordMatchCaseWorkItemsCount |
OpenTransferOutWorkItemsCount |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |

See Also

GetOpenWorkItemCountsResponse Class


OpenDeathRecordMatchCaseWorkItemsCount Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse..::.OpenDeathRecordMatchCaseWorkItemsCount Property
GetOpenWorkItemCountsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int OpenDeathRecordMatchCaseWorkItemsCount { get; set; }
Visual Basic (Declaration)
Public Property OpenDeathRecordMatchCaseWorkItemsCount As Integer
Visual C++
public:
property int OpenDeathRecordMatchCaseWorkItemsCount {
    int get ();
    void set (int value);
}

See Also

GetOpenWorkItemCountsResponse Class


OpenDMVChangeOfAddressRecordMatchCaseWorkItemsCount Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse..::.OpenDMVChangeOfAddressRecordMatchCaseWorkItemsCount Property
GetOpenWorkItemCountsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int OpenDMVChangeOfAddressRecordMatchCaseWorkItemsCount { get; set; }
Visual Basic (Declaration)
Public Property OpenDMVChangeOfAddressRecordMatchCaseWorkItemsCount As Integer
Visual C++
public:
property int OpenDMVChangeOfAddressRecordMatchCaseWorkItemsCount {
    int get ();
    void set (int value);
}

See Also

GetOpenWorkItemCountsResponse Class


OpenDuplicateVoterMatchCaseWorkItemsCount Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse..::.OpenDuplicateVoterMatchCaseWorkItemsCount Property
GetOpenWorkItemCountsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int OpenDuplicateVoterMatchCaseWorkItemsCount { get; set; }
Visual Basic (Declaration)
Public Property OpenDuplicateVoterMatchCaseWorkItemsCount As Integer
Visual C++
public:
property int OpenDuplicateVoterMatchCaseWorkItemsCount {
    int get ();
    void set (int value);
}

See Also

GetOpenWorkItemCountsResponse Class


OpenFelonRecordMatchCaseWorkItemsCount Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse..::.OpenFelonRecordMatchCaseWorkItemsCount Property
GetOpenWorkItemCountsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int OpenFelonRecordMatchCaseWorkItemsCount { get; set; }
Visual Basic (Declaration)
Public Property OpenFelonRecordMatchCaseWorkItemsCount As Integer
Visual C++
public:
property int OpenFelonRecordMatchCaseWorkItemsCount {
    int get ();
    void set (int value);
}

See Also

GetOpenWorkItemCountsResponse Class


OpenNationalChangeOfAddressRecordMatchCaseWorkItemsCount Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse..::.OpenNationalChangeOfAddressRecordMatchCaseWorkItemsCount Property
GetOpenWorkItemCountsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int OpenNationalChangeOfAddressRecordMatchCaseWorkItemsCount { get; set; }
Visual Basic (Declaration)
Public Property OpenNationalChangeOfAddressRecordMatchCaseWorkItemsCount As Integer
Visual C++
public:
property int OpenNationalChangeOfAddressRecordMatchCaseWorkItemsCount {
    int get ();
    void set (int value);
}

See Also

GetOpenWorkItemCountsResponse Class


OpenTransferOutWorkItemsCount Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse..::.OpenTransferOutWorkItemsCount Property
GetOpenWorkItemCountsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int OpenTransferOutWorkItemsCount { get; set; }
Visual Basic (Declaration)
Public Property OpenTransferOutWorkItemsCount As Integer
Visual C++
public:
property int OpenTransferOutWorkItemsCount {
    int get ();
    void set (int value);
}

See Also

GetOpenWorkItemCountsResponse Class


ResponseStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemCountsResponse..::.ResponseStatusReason Property
GetOpenWorkItemCountsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetWorkItemCountsResponseStatusReason ResponseStatusReason { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatusReason As GetWorkItemCountsResponseStatusReason
Visual C++
public:
property GetWorkItemCountsResponseStatusReason ResponseStatusReason {
    GetWorkItemCountsResponseStatusReason get ();
    void set (GetWorkItemCountsResponseStatusReason value);
}

See Also

GetOpenWorkItemCountsResponse Class


GetOpenWorkItemsListResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemsListResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetOpenWorkItemsListResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class GetOpenWorkItemsListResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class GetOpenWorkItemsListResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetOpenWorkItemsListResponse

See Also

GetOpenWorkItemsListResponse Members


GetOpenWorkItemsListResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemsListResponse Members
GetOpenWorkItemsListResponse Class Constructors Properties See Also Send Feedback

The GetOpenWorkItemsListResponse type exposes the following members.

Constructors

Name | Description
GetOpenWorkItemsListResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
WorkItems |

See Also

GetOpenWorkItemsListResponse Class


GetOpenWorkItemsListResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemsListResponse Constructor
GetOpenWorkItemsListResponse Class See Also Send Feedback

Overload List

Name | Description
GetOpenWorkItemsListResponse()()() |
GetOpenWorkItemsListResponse(array<WorkItem>[]()[], ResponseStatus) |

See Also

GetOpenWorkItemsListResponse Class
GetOpenWorkItemsListResponse Members


GetOpenWorkItemsListResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemsListResponse Constructor
GetOpenWorkItemsListResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetOpenWorkItemsListResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetOpenWorkItemsListResponse()

See Also

GetOpenWorkItemsListResponse Class
GetOpenWorkItemsListResponse Overload


GetOpenWorkItemsListResponse Constructor (WorkItem[], ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemsListResponse Constructor (array<WorkItem>[]()[], ResponseStatus)
GetOpenWorkItemsListResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetOpenWorkItemsListResponse(
    WorkItem[] workItems,
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    workItems As WorkItem(), _
    responseStatus As ResponseStatus _
)
Visual C++
public:
GetOpenWorkItemsListResponse(
    array<WorkItem^>^ workItems,
    ResponseStatus responseStatus
)

Parameters

workItems
Type: array< VoteCal.Management.Web.Services.Models..::.WorkItem >[]()[]
responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

GetOpenWorkItemsListResponse Class
GetOpenWorkItemsListResponse Overload


GetOpenWorkItemsListResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemsListResponse Properties
GetOpenWorkItemsListResponse Class See Also Send Feedback

The GetOpenWorkItemsListResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
WorkItems |

See Also

GetOpenWorkItemsListResponse Class


WorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
GetOpenWorkItemsListResponse..::.WorkItems Property
GetOpenWorkItemsListResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WorkItem[] WorkItems { get; set; }
Visual Basic (Declaration)
Public Property WorkItems As WorkItem()
Visual C++
public:
property array<WorkItem^>^ WorkItems {
    array<WorkItem^>^ get ();
    void set (array<WorkItem^>^ value);
}

See Also

GetOpenWorkItemsListResponse Class


GetStateVotersResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetStateVotersResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetStateVotersResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class GetStateVotersResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class GetStateVotersResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetStateVotersResponse

See Also

GetStateVotersResponse Members


GetStateVotersResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetStateVotersResponse Members
GetStateVotersResponse Class Constructors Properties See Also Send Feedback

The GetStateVotersResponse type exposes the following members.

Constructors

Name | Description
GetStateVotersResponse |

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
StateVoters |

See Also

GetStateVotersResponse Class


GetStateVotersResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetStateVotersResponse Constructor
GetStateVotersResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetStateVotersResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetStateVotersResponse()

See Also

GetStateVotersResponse Class


GetStateVotersResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetStateVotersResponse Properties
GetStateVotersResponse Class See Also Send Feedback

The GetStateVotersResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
StateVoters |

See Also

GetStateVotersResponse Class


ResponseStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
GetStateVotersResponse..::.ResponseStatusReason Property
GetStateVotersResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetStateVotersResponseStatusReason ResponseStatusReason { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatusReason As GetStateVotersResponseStatusReason
Visual C++
public:
property GetStateVotersResponseStatusReason ResponseStatusReason {
    GetStateVotersResponseStatusReason get ();
    void set (GetStateVotersResponseStatusReason value);
}

See Also

GetStateVotersResponse Class


StateVoters Property

[image]

VoteCal EMS Vendor Integration API Reference
GetStateVotersResponse..::.StateVoters Property
GetStateVotersResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Voter[] StateVoters { get; set; }
Visual Basic (Declaration)
Public Property StateVoters As Voter()
Visual C++
public:
property array<Voter^>^ StateVoters {
    array<Voter^>^ get ();
    void set (array<Voter^>^ value);
}

See Also

GetStateVotersResponse Class


GetStateVotersResponseStatusReason Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
GetStateVotersResponseStatusReason Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum GetStateVotersResponseStatusReason
Visual Basic (Declaration)
Public Enumeration GetStateVotersResponseStatusReason
Visual C++
public enum class GetStateVotersResponseStatusReason

Members

Member name | Description
None |
InvalidCredentials |
Unknown |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


GetTransferOutWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetTransferOutWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetTransferOutWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetTransferOutWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetTransferOutWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetTransferOutWorkItemsResponse

See Also

GetTransferOutWorkItemsResponse Members


GetTransferOutWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetTransferOutWorkItemsResponse Members
GetTransferOutWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetTransferOutWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetTransferOutWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)
TransferOutWorkItems |

See Also

GetTransferOutWorkItemsResponse Class


GetTransferOutWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetTransferOutWorkItemsResponse Constructor
GetTransferOutWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
GetTransferOutWorkItemsResponse()()() |
GetTransferOutWorkItemsResponse(ResponseStatus) |

See Also

GetTransferOutWorkItemsResponse Class
GetTransferOutWorkItemsResponse Members


GetTransferOutWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetTransferOutWorkItemsResponse Constructor
GetTransferOutWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetTransferOutWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetTransferOutWorkItemsResponse()

See Also

GetTransferOutWorkItemsResponse Class
GetTransferOutWorkItemsResponse Overload


GetTransferOutWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
GetTransferOutWorkItemsResponse Constructor (ResponseStatus)
GetTransferOutWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetTransferOutWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
GetTransferOutWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

GetTransferOutWorkItemsResponse Class
GetTransferOutWorkItemsResponse Overload


GetTransferOutWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetTransferOutWorkItemsResponse Properties
GetTransferOutWorkItemsResponse Class See Also Send Feedback

The GetTransferOutWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)
TransferOutWorkItems |

See Also

GetTransferOutWorkItemsResponse Class


TransferOutWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
GetTransferOutWorkItemsResponse..::.TransferOutWorkItems Property
GetTransferOutWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TransferOutWorkItem[] TransferOutWorkItems { get; set; }
Visual Basic (Declaration)
Public Property TransferOutWorkItems As TransferOutWorkItem()
Visual C++
public:
property array<TransferOutWorkItem^>^ TransferOutWorkItems {
    array<TransferOutWorkItem^>^ get ();
    void set (array<TransferOutWorkItem^>^ value);
}

See Also

GetTransferOutWorkItemsResponse Class


GetVoterStatusChangeWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetVoterStatusChangeWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetVoterStatusChangeWorkItemsResponse : GetWorkItemsResponse
Visual Basic (Declaration)
Public Class GetVoterStatusChangeWorkItemsResponse _
    Inherits GetWorkItemsResponse
Visual C++
public ref class GetVoterStatusChangeWorkItemsResponse : public GetWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetVoterStatusChangeWorkItemsResponse

See Also

GetVoterStatusChangeWorkItemsResponse Members


GetVoterStatusChangeWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetVoterStatusChangeWorkItemsResponse Members
GetVoterStatusChangeWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetVoterStatusChangeWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetVoterStatusChangeWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetVoterStatusChangeWorkItemsResponse Class


GetVoterStatusChangeWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetVoterStatusChangeWorkItemsResponse Constructor
GetVoterStatusChangeWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
GetVoterStatusChangeWorkItemsResponse()()() |
GetVoterStatusChangeWorkItemsResponse(ResponseStatus) |

See Also

GetVoterStatusChangeWorkItemsResponse Class
GetVoterStatusChangeWorkItemsResponse Members


GetVoterStatusChangeWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetVoterStatusChangeWorkItemsResponse Constructor
GetVoterStatusChangeWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetVoterStatusChangeWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetVoterStatusChangeWorkItemsResponse()

See Also

GetVoterStatusChangeWorkItemsResponse Class
GetVoterStatusChangeWorkItemsResponse Overload


GetVoterStatusChangeWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
GetVoterStatusChangeWorkItemsResponse Constructor (ResponseStatus)
GetVoterStatusChangeWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetVoterStatusChangeWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
GetVoterStatusChangeWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

GetVoterStatusChangeWorkItemsResponse Class
GetVoterStatusChangeWorkItemsResponse Overload


GetVoterStatusChangeWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetVoterStatusChangeWorkItemsResponse Properties
GetVoterStatusChangeWorkItemsResponse Class See Also Send Feedback

The GetVoterStatusChangeWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from GetWorkItemsResponse.)

See Also

GetVoterStatusChangeWorkItemsResponse Class


GetWorkItemCountsResponseStatusReason Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
GetWorkItemCountsResponseStatusReason Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum GetWorkItemCountsResponseStatusReason
Visual Basic (Declaration)
Public Enumeration GetWorkItemCountsResponseStatusReason
Visual C++
public enum class GetWorkItemCountsResponseStatusReason

Members

Member name | Description
None |
InvalidCredentials |
Unknown |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


GetWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
GetWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class GetWorkItemsResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class GetWorkItemsResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class GetWorkItemsResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetDataValidationErrorWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetDeathRecordMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetDMVChangeOfAddressRecordMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetDuplicateVoterMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetEMSVoterUpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetFelonRecordMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetNationalChangeOfAddressRecordMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetNewRegistrationWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetTransferOutWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.GetVoterStatusChangeWorkItemsResponse

See Also

GetWorkItemsResponse Members


GetWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetWorkItemsResponse Members
GetWorkItemsResponse Class Constructors Properties See Also Send Feedback

The GetWorkItemsResponse type exposes the following members.

Constructors

Name | Description
GetWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |

See Also

GetWorkItemsResponse Class


GetWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetWorkItemsResponse Constructor
GetWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
GetWorkItemsResponse()()() |
GetWorkItemsResponse(ResponseStatus) |

See Also

GetWorkItemsResponse Class
GetWorkItemsResponse Members


GetWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
GetWorkItemsResponse Constructor
GetWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
GetWorkItemsResponse()

See Also

GetWorkItemsResponse Class
GetWorkItemsResponse Overload


GetWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
GetWorkItemsResponse Constructor (ResponseStatus)
GetWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
GetWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

GetWorkItemsResponse Class
GetWorkItemsResponse Overload


GetWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
GetWorkItemsResponse Properties
GetWorkItemsResponse Class See Also Send Feedback

The GetWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |

See Also

GetWorkItemsResponse Class


ResponseStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
GetWorkItemsResponse..::.ResponseStatusReason Property
GetWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public GetItemsResponseStatusReason ResponseStatusReason { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatusReason As GetItemsResponseStatusReason
Visual C++
public:
property GetItemsResponseStatusReason ResponseStatusReason {
    GetItemsResponseStatusReason get ();
    void set (GetItemsResponseStatusReason value);
}

See Also

GetWorkItemsResponse Class


Message Class

[image]

VoteCal EMS Vendor Integration API Reference
Message Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Message
Visual Basic (Declaration)
Public Class Message
Visual C++
public ref class Message

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.Message
VoteCal.Management.Web.Services.Models..::.DMVChangeOfAddressRecordReceivedMessage
VoteCal.Management.Web.Services.Models..::.NationalChangeOfAddressRecordReceivedMessage
VoteCal.Management.Web.Services.Models..::.NewVoterReceivedMessage
VoteCal.Management.Web.Services.Models..::.StateVoterActivityCreatedMessage
VoteCal.Management.Web.Services.Models..::.StateVoterStatusUpdatedMessage
VoteCal.Management.Web.Services.Models..::.StateVoterUpdatedMessage

See Also

Message Members


Message Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
Message Members
Message Class Constructors Properties See Also Send Feedback

The Message type exposes the following members.

Constructors

Name | Description
Message |

Properties

Name | Description
AbbreviatedVoter |
MessageStatus |
MessageType |

See Also

Message Class


Message Constructor

[image]

VoteCal EMS Vendor Integration API Reference
Message Constructor
Message Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Message()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Message()

See Also

Message Class


Message Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
Message Properties
Message Class See Also Send Feedback

The Message type exposes the following members.

Properties

Name | Description
AbbreviatedVoter |
MessageStatus |
MessageType |

See Also

Message Class


AbbreviatedVoter Property

[image]

VoteCal EMS Vendor Integration API Reference
Message..::.AbbreviatedVoter Property
Message Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AbbreviatedVoter AbbreviatedVoter { get; set; }
Visual Basic (Declaration)
Public Property AbbreviatedVoter As AbbreviatedVoter
Visual C++
public:
property AbbreviatedVoter^ AbbreviatedVoter {
    AbbreviatedVoter^ get ();
    void set (AbbreviatedVoter^ value);
}

See Also

Message Class


MessageStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
Message..::.MessageStatus Property
Message Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MessageStatus MessageStatus { get; set; }
Visual Basic (Declaration)
Public Property MessageStatus As MessageStatus
Visual C++
public:
property MessageStatus MessageStatus {
    MessageStatus get ();
    void set (MessageStatus value);
}

See Also

Message Class


MessageType Property

[image]

VoteCal EMS Vendor Integration API Reference
Message..::.MessageType Property
Message Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public MessageType MessageType { get; set; }
Visual Basic (Declaration)
Public Property MessageType As MessageType
Visual C++
public:
property MessageType MessageType {
    MessageType get ();
    void set (MessageType value);
}

See Also

Message Class


MessageStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
MessageStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum MessageStatus
Visual Basic (Declaration)
Public Enumeration MessageStatus
Visual C++
public enum class MessageStatus

Members

Member name | Description
Open |
Closed |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


MessageType Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
MessageType Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum MessageType
Visual Basic (Declaration)
Public Enumeration MessageType
Visual C++
public enum class MessageType

Members

Member name | Description
StateActivityAdded |
DMVChangeOfAddressReceived |
NationalChangeOfAddressReceived |
StateVoterUpdated |
NewRegistrationReceived |
VoterStatusUpdated |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


NationalChangeOfAddressRecordMatchCaseWorkItem Class

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItem Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NationalChangeOfAddressRecordMatchCaseWorkItem : WorkItem
Visual Basic (Declaration)
Public Class NationalChangeOfAddressRecordMatchCaseWorkItem _
    Inherits WorkItem
Visual C++
public ref class NationalChangeOfAddressRecordMatchCaseWorkItem : public WorkItem

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItem
VoteCal.Management.Web.Services.Models..::.NationalChangeOfAddressRecordMatchCaseWorkItem

See Also

NationalChangeOfAddressRecordMatchCaseWorkItem Members


NationalChangeOfAddressRecordMatchCaseWorkItem Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItem Members
NationalChangeOfAddressRecordMatchCaseWorkItem Class Constructors Properties See Also Send Feedback

The NationalChangeOfAddressRecordMatchCaseWorkItem type exposes the following members.

Constructors

Name | Description
NationalChangeOfAddressRecordMatchCaseWorkItem | Overloaded.

Properties

Name | Description
ChangeOfAddressInfo |
NationalChangeOfAddressRecordMatchCaseWorkItemStatus |
VoterSummary |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

NationalChangeOfAddressRecordMatchCaseWorkItem Class


NationalChangeOfAddressRecordMatchCaseWorkItem Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItem Constructor
NationalChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Overload List

Name | Description
NationalChangeOfAddressRecordMatchCaseWorkItem()()() |
NationalChangeOfAddressRecordMatchCaseWorkItem(ChangeOfAddressInfo, AbbreviatedVoter, WorkItemStatus, NationalChangeOfAddressRecordMatchCaseWorkItemStatus) |

See Also

NationalChangeOfAddressRecordMatchCaseWorkItem Class
NationalChangeOfAddressRecordMatchCaseWorkItem Members


NationalChangeOfAddressRecordMatchCaseWorkItem Constructor

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItem Constructor
NationalChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordMatchCaseWorkItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NationalChangeOfAddressRecordMatchCaseWorkItem()

See Also

NationalChangeOfAddressRecordMatchCaseWorkItem Class
NationalChangeOfAddressRecordMatchCaseWorkItem Overload


NationalChangeOfAddressRecordMatchCaseWorkItem Constructor (ChangeOfAddressInfo, AbbreviatedVoter, WorkItemStatus, NationalChangeOfAddressRecordMatchCaseWorkItemStatus)

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItem Constructor (ChangeOfAddressInfo, AbbreviatedVoter, WorkItemStatus, NationalChangeOfAddressRecordMatchCaseWorkItemStatus)
NationalChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordMatchCaseWorkItem(
    ChangeOfAddressInfo changeOfAddressInfo,
    AbbreviatedVoter voterSummary,
    WorkItemStatus workItemStatus,
    NationalChangeOfAddressRecordMatchCaseWorkItemStatus nationalChangeOfAddressRecordMatchCaseWorkItemStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    changeOfAddressInfo As ChangeOfAddressInfo, _
    voterSummary As AbbreviatedVoter, _
    workItemStatus As WorkItemStatus, _
    nationalChangeOfAddressRecordMatchCaseWorkItemStatus As NationalChangeOfAddressRecordMatchCaseWorkItemStatus _
)
Visual C++
public:
NationalChangeOfAddressRecordMatchCaseWorkItem(
    ChangeOfAddressInfo^ changeOfAddressInfo,
    AbbreviatedVoter^ voterSummary,
    WorkItemStatus workItemStatus,
    NationalChangeOfAddressRecordMatchCaseWorkItemStatus nationalChangeOfAddressRecordMatchCaseWorkItemStatus
)

Parameters

changeOfAddressInfo
Type: VoteCal.Management.Web.Services.Models..::.ChangeOfAddressInfo
voterSummary
Type: VoteCal.Management.Web.Services.Models..::.AbbreviatedVoter
workItemStatus
Type: VoteCal.Management.Web.Services.Models..::.WorkItemStatus
nationalChangeOfAddressRecordMatchCaseWorkItemStatus
Type: VoteCal.Management.Web.Services.Models..::.NationalChangeOfAddressRecordMatchCaseWorkItemStatus

See Also

NationalChangeOfAddressRecordMatchCaseWorkItem Class
NationalChangeOfAddressRecordMatchCaseWorkItem Overload


NationalChangeOfAddressRecordMatchCaseWorkItem Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItem Properties
NationalChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

The NationalChangeOfAddressRecordMatchCaseWorkItem type exposes the following members.

Properties

Name | Description
ChangeOfAddressInfo |
NationalChangeOfAddressRecordMatchCaseWorkItemStatus |
VoterSummary |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

NationalChangeOfAddressRecordMatchCaseWorkItem Class


ChangeOfAddressInfo Property

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItem..::.ChangeOfAddressInfo Property
NationalChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChangeOfAddressInfo ChangeOfAddressInfo { get; set; }
Visual Basic (Declaration)
Public Property ChangeOfAddressInfo As ChangeOfAddressInfo
Visual C++
public:
property ChangeOfAddressInfo^ ChangeOfAddressInfo {
    ChangeOfAddressInfo^ get ();
    void set (ChangeOfAddressInfo^ value);
}

See Also

NationalChangeOfAddressRecordMatchCaseWorkItem Class


NationalChangeOfAddressRecordMatchCaseWorkItemStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItem..::.NationalChangeOfAddressRecordMatchCaseWorkItemStatus Property
NationalChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordMatchCaseWorkItemStatus NationalChangeOfAddressRecordMatchCaseWorkItemStatus { get; set; }
Visual Basic (Declaration)
Public Property NationalChangeOfAddressRecordMatchCaseWorkItemStatus As NationalChangeOfAddressRecordMatchCaseWorkItemStatus
Visual C++
public:
property NationalChangeOfAddressRecordMatchCaseWorkItemStatus NationalChangeOfAddressRecordMatchCaseWorkItemStatus {
    NationalChangeOfAddressRecordMatchCaseWorkItemStatus get ();
    void set (NationalChangeOfAddressRecordMatchCaseWorkItemStatus value);
}

See Also

NationalChangeOfAddressRecordMatchCaseWorkItem Class


VoterSummary Property

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItem..::.VoterSummary Property
NationalChangeOfAddressRecordMatchCaseWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AbbreviatedVoter VoterSummary { get; set; }
Visual Basic (Declaration)
Public Property VoterSummary As AbbreviatedVoter
Visual C++
public:
property AbbreviatedVoter^ VoterSummary {
    AbbreviatedVoter^ get ();
    void set (AbbreviatedVoter^ value);
}

See Also

NationalChangeOfAddressRecordMatchCaseWorkItem Class


NationalChangeOfAddressRecordMatchCaseWorkItemStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordMatchCaseWorkItemStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum NationalChangeOfAddressRecordMatchCaseWorkItemStatus
Visual Basic (Declaration)
Public Enumeration NationalChangeOfAddressRecordMatchCaseWorkItemStatus
Visual C++
public enum class NationalChangeOfAddressRecordMatchCaseWorkItemStatus

Members

Member name | Description
Unhandled |
StaffUpdating |
Ignored |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


NationalChangeOfAddressRecordReceivedMessage Class

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordReceivedMessage Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NationalChangeOfAddressRecordReceivedMessage : Message
Visual Basic (Declaration)
Public Class NationalChangeOfAddressRecordReceivedMessage _
    Inherits Message
Visual C++
public ref class NationalChangeOfAddressRecordReceivedMessage : public Message

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.Message
VoteCal.Management.Web.Services.Models..::.NationalChangeOfAddressRecordReceivedMessage

See Also

NationalChangeOfAddressRecordReceivedMessage Members


NationalChangeOfAddressRecordReceivedMessage Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordReceivedMessage Members
NationalChangeOfAddressRecordReceivedMessage Class Constructors Properties See Also Send Feedback

The NationalChangeOfAddressRecordReceivedMessage type exposes the following members.

Constructors

Name | Description
NationalChangeOfAddressRecordReceivedMessage | Overloaded.

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
ChangeOfAddressInfo |
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
NationalChangeOfAddressRecordReceivedMessageStatus |

See Also

NationalChangeOfAddressRecordReceivedMessage Class


NationalChangeOfAddressRecordReceivedMessage Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordReceivedMessage Constructor
NationalChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Overload List

Name | Description
NationalChangeOfAddressRecordReceivedMessage()()() |
NationalChangeOfAddressRecordReceivedMessage(ChangeOfAddressInfo, MessageStatus, AbbreviatedVoter, NationalChangeOfAddressRecordReceivedMessageStatus) |

See Also

NationalChangeOfAddressRecordReceivedMessage Class
NationalChangeOfAddressRecordReceivedMessage Members


NationalChangeOfAddressRecordReceivedMessage Constructor

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordReceivedMessage Constructor
NationalChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordReceivedMessage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NationalChangeOfAddressRecordReceivedMessage()

See Also

NationalChangeOfAddressRecordReceivedMessage Class
NationalChangeOfAddressRecordReceivedMessage Overload


NationalChangeOfAddressRecordReceivedMessage Constructor (ChangeOfAddressInfo, MessageStatus, AbbreviatedVoter, NationalChangeOfAddressRecordReceivedMessageStatus)

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordReceivedMessage Constructor (ChangeOfAddressInfo, MessageStatus, AbbreviatedVoter, NationalChangeOfAddressRecordReceivedMessageStatus)
NationalChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordReceivedMessage(
    ChangeOfAddressInfo changeOfAddressInfo,
    MessageStatus messageStatus,
    AbbreviatedVoter abbreviatedVoter,
    NationalChangeOfAddressRecordReceivedMessageStatus nationalChangeOfAddressRecordReceivedMessageStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    changeOfAddressInfo As ChangeOfAddressInfo, _
    messageStatus As MessageStatus, _
    abbreviatedVoter As AbbreviatedVoter, _
    nationalChangeOfAddressRecordReceivedMessageStatus As NationalChangeOfAddressRecordReceivedMessageStatus _
)
Visual C++
public:
NationalChangeOfAddressRecordReceivedMessage(
    ChangeOfAddressInfo^ changeOfAddressInfo,
    MessageStatus messageStatus,
    AbbreviatedVoter^ abbreviatedVoter,
    NationalChangeOfAddressRecordReceivedMessageStatus nationalChangeOfAddressRecordReceivedMessageStatus
)

Parameters

changeOfAddressInfo
Type: VoteCal.Management.Web.Services.Models..::.ChangeOfAddressInfo
messageStatus
Type: VoteCal.Management.Web.Services.Models..::.MessageStatus
abbreviatedVoter
Type: VoteCal.Management.Web.Services.Models..::.AbbreviatedVoter
nationalChangeOfAddressRecordReceivedMessageStatus
Type: VoteCal.Management.Web.Services.Models..::.NationalChangeOfAddressRecordReceivedMessageStatus

See Also

NationalChangeOfAddressRecordReceivedMessage Class
NationalChangeOfAddressRecordReceivedMessage Overload


NationalChangeOfAddressRecordReceivedMessage Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordReceivedMessage Properties
NationalChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

The NationalChangeOfAddressRecordReceivedMessage type exposes the following members.

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
ChangeOfAddressInfo |
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
NationalChangeOfAddressRecordReceivedMessageStatus |

See Also

NationalChangeOfAddressRecordReceivedMessage Class


ChangeOfAddressInfo Property

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordReceivedMessage..::.ChangeOfAddressInfo Property
NationalChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ChangeOfAddressInfo ChangeOfAddressInfo { get; set; }
Visual Basic (Declaration)
Public Property ChangeOfAddressInfo As ChangeOfAddressInfo
Visual C++
public:
property ChangeOfAddressInfo^ ChangeOfAddressInfo {
    ChangeOfAddressInfo^ get ();
    void set (ChangeOfAddressInfo^ value);
}

See Also

NationalChangeOfAddressRecordReceivedMessage Class


NationalChangeOfAddressRecordReceivedMessageStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordReceivedMessage..::.NationalChangeOfAddressRecordReceivedMessageStatus Property
NationalChangeOfAddressRecordReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordReceivedMessageStatus NationalChangeOfAddressRecordReceivedMessageStatus { get; set; }
Visual Basic (Declaration)
Public Property NationalChangeOfAddressRecordReceivedMessageStatus As NationalChangeOfAddressRecordReceivedMessageStatus
Visual C++
public:
property NationalChangeOfAddressRecordReceivedMessageStatus NationalChangeOfAddressRecordReceivedMessageStatus {
    NationalChangeOfAddressRecordReceivedMessageStatus get ();
    void set (NationalChangeOfAddressRecordReceivedMessageStatus value);
}

See Also

NationalChangeOfAddressRecordReceivedMessage Class


NationalChangeOfAddressRecordReceivedMessageStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
NationalChangeOfAddressRecordReceivedMessageStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum NationalChangeOfAddressRecordReceivedMessageStatus
Visual Basic (Declaration)
Public Enumeration NationalChangeOfAddressRecordReceivedMessageStatus
Visual C++
public enum class NationalChangeOfAddressRecordReceivedMessageStatus

Members

Member name | Description
Unhandled |
NationalChangeOfAddressApplied |
CannotApplyNationalChangeOfAddress |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


NewVoterReceivedMessage Class

[image]

VoteCal EMS Vendor Integration API Reference
NewVoterReceivedMessage Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class NewVoterReceivedMessage : Message
Visual Basic (Declaration)
Public Class NewVoterReceivedMessage _
    Inherits Message
Visual C++
public ref class NewVoterReceivedMessage : public Message

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.Message
VoteCal.Management.Web.Services.Models..::.NewVoterReceivedMessage

See Also

NewVoterReceivedMessage Members


NewVoterReceivedMessage Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
NewVoterReceivedMessage Members
NewVoterReceivedMessage Class Constructors Properties See Also Send Feedback

The NewVoterReceivedMessage type exposes the following members.

Constructors

Name | Description
NewVoterReceivedMessage |

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
NewVoter |
NewVoterReceivedMessageStatus |

See Also

NewVoterReceivedMessage Class


NewVoterReceivedMessage Constructor

[image]

VoteCal EMS Vendor Integration API Reference
NewVoterReceivedMessage Constructor
NewVoterReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NewVoterReceivedMessage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NewVoterReceivedMessage()

See Also

NewVoterReceivedMessage Class


NewVoterReceivedMessage Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
NewVoterReceivedMessage Properties
NewVoterReceivedMessage Class See Also Send Feedback

The NewVoterReceivedMessage type exposes the following members.

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
NewVoter |
NewVoterReceivedMessageStatus |

See Also

NewVoterReceivedMessage Class


NewVoter Property

[image]

VoteCal EMS Vendor Integration API Reference
NewVoterReceivedMessage..::.NewVoter Property
NewVoterReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Voter NewVoter { get; set; }
Visual Basic (Declaration)
Public Property NewVoter As Voter
Visual C++
public:
property Voter^ NewVoter {
    Voter^ get ();
    void set (Voter^ value);
}

See Also

NewVoterReceivedMessage Class


NewVoterReceivedMessageStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
NewVoterReceivedMessage..::.NewVoterReceivedMessageStatus Property
NewVoterReceivedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NewVoterReceivedMessageStatus NewVoterReceivedMessageStatus { get; set; }
Visual Basic (Declaration)
Public Property NewVoterReceivedMessageStatus As NewVoterReceivedMessageStatus
Visual C++
public:
property NewVoterReceivedMessageStatus NewVoterReceivedMessageStatus {
    NewVoterReceivedMessageStatus get ();
    void set (NewVoterReceivedMessageStatus value);
}

See Also

NewVoterReceivedMessage Class


NewVoterReceivedMessageStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
NewVoterReceivedMessageStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum NewVoterReceivedMessageStatus
Visual Basic (Declaration)
Public Enumeration NewVoterReceivedMessageStatus
Visual C++
public enum class NewVoterReceivedMessageStatus

Members

Member name | Description
Unhandled |
NewVoterApplied |
CannotApplyNewVoter |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


ResponseStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
ResponseStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum ResponseStatus
Visual Basic (Declaration)
Public Enumeration ResponseStatus
Visual C++
public enum class ResponseStatus

Members

Member name | Description
Success |
Error |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


SearchStateVotersResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
SearchStateVotersResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class SearchStateVotersResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class SearchStateVotersResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class SearchStateVotersResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.SearchStateVotersResponse

See Also

SearchStateVotersResponse Members


SearchStateVotersResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
SearchStateVotersResponse Members
SearchStateVotersResponse Class Constructors Properties See Also Send Feedback

The SearchStateVotersResponse type exposes the following members.

Constructors

Name | Description
SearchStateVotersResponse |

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
StateVoterSearchResults |

See Also

SearchStateVotersResponse Class


SearchStateVotersResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
SearchStateVotersResponse Constructor
SearchStateVotersResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchStateVotersResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SearchStateVotersResponse()

See Also

SearchStateVotersResponse Class


SearchStateVotersResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
SearchStateVotersResponse Properties
SearchStateVotersResponse Class See Also Send Feedback

The SearchStateVotersResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
StateVoterSearchResults |

See Also

SearchStateVotersResponse Class


ResponseStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
SearchStateVotersResponse..::.ResponseStatusReason Property
SearchStateVotersResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public SearchStateVotersResponseStatusReason ResponseStatusReason { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatusReason As SearchStateVotersResponseStatusReason
Visual C++
public:
property SearchStateVotersResponseStatusReason ResponseStatusReason {
    SearchStateVotersResponseStatusReason get ();
    void set (SearchStateVotersResponseStatusReason value);
}

See Also

SearchStateVotersResponse Class


StateVoterSearchResults Property

[image]

VoteCal EMS Vendor Integration API Reference
SearchStateVotersResponse..::.StateVoterSearchResults Property
SearchStateVotersResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterSearchResult[] StateVoterSearchResults { get; set; }
Visual Basic (Declaration)
Public Property StateVoterSearchResults As StateVoterSearchResult()
Visual C++
public:
property array<StateVoterSearchResult^>^ StateVoterSearchResults {
    array<StateVoterSearchResult^>^ get ();
    void set (array<StateVoterSearchResult^>^ value);
}

See Also

SearchStateVotersResponse Class


SearchStateVotersResponseStatusReason Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
SearchStateVotersResponseStatusReason Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum SearchStateVotersResponseStatusReason
Visual Basic (Declaration)
Public Enumeration SearchStateVotersResponseStatusReason
Visual C++
public enum class SearchStateVotersResponseStatusReason

Members

Member name | Description
None |
InvalidCredentials |
Unknown |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


StateVoterActivityCreatedMessage Class

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterActivityCreatedMessage Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StateVoterActivityCreatedMessage : Message
Visual Basic (Declaration)
Public Class StateVoterActivityCreatedMessage _
    Inherits Message
Visual C++
public ref class StateVoterActivityCreatedMessage : public Message

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.Message
VoteCal.Management.Web.Services.Models..::.StateVoterActivityCreatedMessage

See Also

StateVoterActivityCreatedMessage Members


StateVoterActivityCreatedMessage Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterActivityCreatedMessage Members
StateVoterActivityCreatedMessage Class Constructors Properties See Also Send Feedback

The StateVoterActivityCreatedMessage type exposes the following members.

Constructors

Name | Description
StateVoterActivityCreatedMessage |

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
StateActivityDescription |
StateVoterStatusUpdatedMessageStatus |

See Also

StateVoterActivityCreatedMessage Class


StateVoterActivityCreatedMessage Constructor

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterActivityCreatedMessage Constructor
StateVoterActivityCreatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterActivityCreatedMessage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StateVoterActivityCreatedMessage()

See Also

StateVoterActivityCreatedMessage Class


StateVoterActivityCreatedMessage Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterActivityCreatedMessage Properties
StateVoterActivityCreatedMessage Class See Also Send Feedback

The StateVoterActivityCreatedMessage type exposes the following members.

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
StateActivityDescription |
StateVoterStatusUpdatedMessageStatus |

See Also

StateVoterActivityCreatedMessage Class


StateActivityDescription Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterActivityCreatedMessage..::.StateActivityDescription Property
StateVoterActivityCreatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string StateActivityDescription { get; set; }
Visual Basic (Declaration)
Public Property StateActivityDescription As String
Visual C++
public:
property String^ StateActivityDescription {
    String^ get ();
    void set (String^ value);
}

See Also

StateVoterActivityCreatedMessage Class


StateVoterStatusUpdatedMessageStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterActivityCreatedMessage..::.StateVoterStatusUpdatedMessageStatus Property
StateVoterActivityCreatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterActivityCreatedMessageStatus StateVoterStatusUpdatedMessageStatus { get; set; }
Visual Basic (Declaration)
Public Property StateVoterStatusUpdatedMessageStatus As StateVoterActivityCreatedMessageStatus
Visual C++
public:
property StateVoterActivityCreatedMessageStatus StateVoterStatusUpdatedMessageStatus {
    StateVoterActivityCreatedMessageStatus get ();
    void set (StateVoterActivityCreatedMessageStatus value);
}

See Also

StateVoterActivityCreatedMessage Class


StateVoterActivityCreatedMessageStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterActivityCreatedMessageStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum StateVoterActivityCreatedMessageStatus
Visual Basic (Declaration)
Public Enumeration StateVoterActivityCreatedMessageStatus
Visual C++
public enum class StateVoterActivityCreatedMessageStatus

Members

Member name | Description
Unhandled |
VoterActivityApplied |
CannotApplyVoterActivity |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


StateVoterSearchResult Class

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterSearchResult Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StateVoterSearchResult
Visual Basic (Declaration)
Public Class StateVoterSearchResult
Visual C++
public ref class StateVoterSearchResult

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.StateVoterSearchResult

See Also

StateVoterSearchResult Members


StateVoterSearchResult Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterSearchResult Members
StateVoterSearchResult Class Constructors Properties See Also Send Feedback

The StateVoterSearchResult type exposes the following members.

Constructors

Name | Description
StateVoterSearchResult |

Properties

Name | Description
Confidence |
VoterMatch |

See Also

StateVoterSearchResult Class


StateVoterSearchResult Constructor

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterSearchResult Constructor
StateVoterSearchResult Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterSearchResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StateVoterSearchResult()

See Also

StateVoterSearchResult Class


StateVoterSearchResult Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterSearchResult Properties
StateVoterSearchResult Class See Also Send Feedback

The StateVoterSearchResult type exposes the following members.

Properties

Name | Description
Confidence |
VoterMatch |

See Also

StateVoterSearchResult Class


Confidence Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterSearchResult..::.Confidence Property
StateVoterSearchResult Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public decimal Confidence { get; set; }
Visual Basic (Declaration)
Public Property Confidence As Decimal
Visual C++
public:
property Decimal Confidence {
    Decimal get ();
    void set (Decimal value);
}

See Also

StateVoterSearchResult Class


VoterMatch Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterSearchResult..::.VoterMatch Property
StateVoterSearchResult Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AbbreviatedVoter VoterMatch { get; set; }
Visual Basic (Declaration)
Public Property VoterMatch As AbbreviatedVoter
Visual C++
public:
property AbbreviatedVoter^ VoterMatch {
    AbbreviatedVoter^ get ();
    void set (AbbreviatedVoter^ value);
}

See Also

StateVoterSearchResult Class


StateVoterStatusUpdatedMessage Class

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterStatusUpdatedMessage Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StateVoterStatusUpdatedMessage : Message
Visual Basic (Declaration)
Public Class StateVoterStatusUpdatedMessage _
    Inherits Message
Visual C++
public ref class StateVoterStatusUpdatedMessage : public Message

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.Message
VoteCal.Management.Web.Services.Models..::.StateVoterStatusUpdatedMessage

See Also

StateVoterStatusUpdatedMessage Members


StateVoterStatusUpdatedMessage Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterStatusUpdatedMessage Members
StateVoterStatusUpdatedMessage Class Constructors Properties See Also Send Feedback

The StateVoterStatusUpdatedMessage type exposes the following members.

Constructors

Name | Description
StateVoterStatusUpdatedMessage |

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
NewVoterStatus |
NewVoterStatusReason |
StateVoterStatusUpdatedMessageStatus |

See Also

StateVoterStatusUpdatedMessage Class


StateVoterStatusUpdatedMessage Constructor

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterStatusUpdatedMessage Constructor
StateVoterStatusUpdatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterStatusUpdatedMessage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StateVoterStatusUpdatedMessage()

See Also

StateVoterStatusUpdatedMessage Class


StateVoterStatusUpdatedMessage Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterStatusUpdatedMessage Properties
StateVoterStatusUpdatedMessage Class See Also Send Feedback

The StateVoterStatusUpdatedMessage type exposes the following members.

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
NewVoterStatus |
NewVoterStatusReason |
StateVoterStatusUpdatedMessageStatus |

See Also

StateVoterStatusUpdatedMessage Class


NewVoterStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterStatusUpdatedMessage..::.NewVoterStatus Property
StateVoterStatusUpdatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string NewVoterStatus { get; set; }
Visual Basic (Declaration)
Public Property NewVoterStatus As String
Visual C++
public:
property String^ NewVoterStatus {
    String^ get ();
    void set (String^ value);
}

See Also

StateVoterStatusUpdatedMessage Class


NewVoterStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterStatusUpdatedMessage..::.NewVoterStatusReason Property
StateVoterStatusUpdatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string NewVoterStatusReason { get; set; }
Visual Basic (Declaration)
Public Property NewVoterStatusReason As String
Visual C++
public:
property String^ NewVoterStatusReason {
    String^ get ();
    void set (String^ value);
}

See Also

StateVoterStatusUpdatedMessage Class


StateVoterStatusUpdatedMessageStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterStatusUpdatedMessage..::.StateVoterStatusUpdatedMessageStatus Property
StateVoterStatusUpdatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterStatusUpdatedMessageStatus StateVoterStatusUpdatedMessageStatus { get; set; }
Visual Basic (Declaration)
Public Property StateVoterStatusUpdatedMessageStatus As StateVoterStatusUpdatedMessageStatus
Visual C++
public:
property StateVoterStatusUpdatedMessageStatus StateVoterStatusUpdatedMessageStatus {
    StateVoterStatusUpdatedMessageStatus get ();
    void set (StateVoterStatusUpdatedMessageStatus value);
}

See Also

StateVoterStatusUpdatedMessage Class


StateVoterStatusUpdatedMessageStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterStatusUpdatedMessageStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum StateVoterStatusUpdatedMessageStatus
Visual Basic (Declaration)
Public Enumeration StateVoterStatusUpdatedMessageStatus
Visual C++
public enum class StateVoterStatusUpdatedMessageStatus

Members

Member name | Description
Unhandled |
VoterStatusUpdateApplied |
CannotApplyVoterStatusUpdate |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


StateVoterUpdatedMessage Class

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterUpdatedMessage Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StateVoterUpdatedMessage : Message
Visual Basic (Declaration)
Public Class StateVoterUpdatedMessage _
    Inherits Message
Visual C++
public ref class StateVoterUpdatedMessage : public Message

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.Message
VoteCal.Management.Web.Services.Models..::.StateVoterUpdatedMessage

See Also

StateVoterUpdatedMessage Members


StateVoterUpdatedMessage Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterUpdatedMessage Members
StateVoterUpdatedMessage Class Constructors Properties See Also Send Feedback

The StateVoterUpdatedMessage type exposes the following members.

Constructors

Name | Description
StateVoterUpdatedMessage |

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
StateVoterUpdatedMessageStatus |
UpdatedVoter |

See Also

StateVoterUpdatedMessage Class


StateVoterUpdatedMessage Constructor

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterUpdatedMessage Constructor
StateVoterUpdatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterUpdatedMessage()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StateVoterUpdatedMessage()

See Also

StateVoterUpdatedMessage Class


StateVoterUpdatedMessage Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterUpdatedMessage Properties
StateVoterUpdatedMessage Class See Also Send Feedback

The StateVoterUpdatedMessage type exposes the following members.

Properties

Name | Description
AbbreviatedVoter | (Inherited from Message.)
MessageStatus | (Inherited from Message.)
MessageType | (Inherited from Message.)
StateVoterUpdatedMessageStatus |
UpdatedVoter |

See Also

StateVoterUpdatedMessage Class


StateVoterUpdatedMessageStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterUpdatedMessage..::.StateVoterUpdatedMessageStatus Property
StateVoterUpdatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterUpdatedMessageStatus StateVoterUpdatedMessageStatus { get; set; }
Visual Basic (Declaration)
Public Property StateVoterUpdatedMessageStatus As StateVoterUpdatedMessageStatus
Visual C++
public:
property StateVoterUpdatedMessageStatus StateVoterUpdatedMessageStatus {
    StateVoterUpdatedMessageStatus get ();
    void set (StateVoterUpdatedMessageStatus value);
}

See Also

StateVoterUpdatedMessage Class


UpdatedVoter Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterUpdatedMessage..::.UpdatedVoter Property
StateVoterUpdatedMessage Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Voter UpdatedVoter { get; set; }
Visual Basic (Declaration)
Public Property UpdatedVoter As Voter
Visual C++
public:
property Voter^ UpdatedVoter {
    Voter^ get ();
    void set (Voter^ value);
}

See Also

StateVoterUpdatedMessage Class


StateVoterUpdatedMessageStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterUpdatedMessageStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum StateVoterUpdatedMessageStatus
Visual Basic (Declaration)
Public Enumeration StateVoterUpdatedMessageStatus
Visual C++
public enum class StateVoterUpdatedMessageStatus

Members

Member name | Description
Unhandled |
VoterUpdateApplied |
CannotApplyVoterUpdate |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


StateVoterVoteByMailActivity Class

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class StateVoterVoteByMailActivity
Visual Basic (Declaration)
Public Class StateVoterVoteByMailActivity
Visual C++
public ref class StateVoterVoteByMailActivity

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.StateVoterVoteByMailActivity

See Also

StateVoterVoteByMailActivity Members


StateVoterVoteByMailActivity Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity Members
StateVoterVoteByMailActivity Class Constructors Properties See Also Send Feedback

The StateVoterVoteByMailActivity type exposes the following members.

Constructors

Name | Description
StateVoterVoteByMailActivity |

Properties

Name | Description
CountyVoterId | The County EMS Voter Id for a voter (not necessarily the database primary key)
CountyVoterPrimaryId | The County EMS database primary key for a voter
ElectionId |
StateVoterId | The State Voter Id for a voter as mandated by HAVA (not the database primary key)
StateVoterIdPrimaryKey | The State VoteCal database primary key for a voter
VoteByMailActivityType |

See Also

StateVoterVoteByMailActivity Class


StateVoterVoteByMailActivity Constructor

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity Constructor
StateVoterVoteByMailActivity Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterVoteByMailActivity()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
StateVoterVoteByMailActivity()

See Also

StateVoterVoteByMailActivity Class


StateVoterVoteByMailActivity Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity Properties
StateVoterVoteByMailActivity Class See Also Send Feedback

The StateVoterVoteByMailActivity type exposes the following members.

Properties

Name | Description
CountyVoterId | The County EMS Voter Id for a voter (not necessarily the database primary key)
CountyVoterPrimaryId | The County EMS database primary key for a voter
ElectionId |
StateVoterId | The State Voter Id for a voter as mandated by HAVA (not the database primary key)
StateVoterIdPrimaryKey | The State VoteCal database primary key for a voter
VoteByMailActivityType |

See Also

StateVoterVoteByMailActivity Class


CountyVoterId Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity..::.CountyVoterId Property
StateVoterVoteByMailActivity Class See Also Send Feedback
The County EMS Voter Id for a voter (not necessarily the database primary key)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CountyVoterId { get; set; }
Visual Basic (Declaration)
Public Property CountyVoterId As String
Visual C++
public:
property String^ CountyVoterId {
    String^ get ();
    void set (String^ value);
}

See Also

StateVoterVoteByMailActivity Class


CountyVoterPrimaryId Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity..::.CountyVoterPrimaryId Property
StateVoterVoteByMailActivity Class See Also Send Feedback
The County EMS database primary key for a voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CountyVoterPrimaryId { get; set; }
Visual Basic (Declaration)
Public Property CountyVoterPrimaryId As String
Visual C++
public:
property String^ CountyVoterPrimaryId {
    String^ get ();
    void set (String^ value);
}

See Also

StateVoterVoteByMailActivity Class


ElectionId Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity..::.ElectionId Property
StateVoterVoteByMailActivity Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ElectionId { get; set; }
Visual Basic (Declaration)
Public Property ElectionId As String
Visual C++
public:
property String^ ElectionId {
    String^ get ();
    void set (String^ value);
}

See Also

StateVoterVoteByMailActivity Class


StateVoterId Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity..::.StateVoterId Property
StateVoterVoteByMailActivity Class See Also Send Feedback
The State Voter Id for a voter as mandated by HAVA (not the database primary key)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string StateVoterId { get; set; }
Visual Basic (Declaration)
Public Property StateVoterId As String
Visual C++
public:
property String^ StateVoterId {
    String^ get ();
    void set (String^ value);
}

See Also

StateVoterVoteByMailActivity Class


StateVoterIdPrimaryKey Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity..::.StateVoterIdPrimaryKey Property
StateVoterVoteByMailActivity Class See Also Send Feedback
The State VoteCal database primary key for a voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid StateVoterIdPrimaryKey { get; set; }
Visual Basic (Declaration)
Public Property StateVoterIdPrimaryKey As Guid
Visual C++
public:
property Guid StateVoterIdPrimaryKey {
    Guid get ();
    void set (Guid value);
}

See Also

StateVoterVoteByMailActivity Class


VoteByMailActivityType Property

[image]

VoteCal EMS Vendor Integration API Reference
StateVoterVoteByMailActivity..::.VoteByMailActivityType Property
StateVoterVoteByMailActivity Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoteByMailActivityType VoteByMailActivityType { get; set; }
Visual Basic (Declaration)
Public Property VoteByMailActivityType As VoteByMailActivityType
Visual C++
public:
property VoteByMailActivityType VoteByMailActivityType {
    VoteByMailActivityType get ();
    void set (VoteByMailActivityType value);
}

See Also

StateVoterVoteByMailActivity Class


TransferOutWorkItem Class

[image]

VoteCal EMS Vendor Integration API Reference
TransferOutWorkItem Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class TransferOutWorkItem : WorkItem
Visual Basic (Declaration)
Public Class TransferOutWorkItem _
    Inherits WorkItem
Visual C++
public ref class TransferOutWorkItem : public WorkItem

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItem
VoteCal.Management.Web.Services.Models..::.TransferOutWorkItem

See Also

TransferOutWorkItem Members


TransferOutWorkItem Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
TransferOutWorkItem Members
TransferOutWorkItem Class Constructors Properties See Also Send Feedback

The TransferOutWorkItem type exposes the following members.

Constructors

Name | Description
TransferOutWorkItem |

Properties

Name | Description
FromVoter |
ToVoter |
TransferOutWorkItemStatus |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

TransferOutWorkItem Class


TransferOutWorkItem Constructor

[image]

VoteCal EMS Vendor Integration API Reference
TransferOutWorkItem Constructor
TransferOutWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TransferOutWorkItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TransferOutWorkItem()

See Also

TransferOutWorkItem Class


TransferOutWorkItem Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
TransferOutWorkItem Properties
TransferOutWorkItem Class See Also Send Feedback

The TransferOutWorkItem type exposes the following members.

Properties

Name | Description
FromVoter |
ToVoter |
TransferOutWorkItemStatus |
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item. (Inherited from WorkItem.)
WorkItemId | (Inherited from WorkItem.)
WorkItemStatus | (Inherited from WorkItem.)
WorkItemType | (Inherited from WorkItem.)

See Also

TransferOutWorkItem Class


FromVoter Property

[image]

VoteCal EMS Vendor Integration API Reference
TransferOutWorkItem..::.FromVoter Property
TransferOutWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Voter FromVoter { get; set; }
Visual Basic (Declaration)
Public Property FromVoter As Voter
Visual C++
public:
property Voter^ FromVoter {
    Voter^ get ();
    void set (Voter^ value);
}

See Also

TransferOutWorkItem Class


ToVoter Property

[image]

VoteCal EMS Vendor Integration API Reference
TransferOutWorkItem..::.ToVoter Property
TransferOutWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Voter ToVoter { get; set; }
Visual Basic (Declaration)
Public Property ToVoter As Voter
Visual C++
public:
property Voter^ ToVoter {
    Voter^ get ();
    void set (Voter^ value);
}

See Also

TransferOutWorkItem Class


TransferOutWorkItemStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
TransferOutWorkItem..::.TransferOutWorkItemStatus Property
TransferOutWorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TransferOutWorkItemStatus TransferOutWorkItemStatus { get; set; }
Visual Basic (Declaration)
Public Property TransferOutWorkItemStatus As TransferOutWorkItemStatus
Visual C++
public:
property TransferOutWorkItemStatus TransferOutWorkItemStatus {
    TransferOutWorkItemStatus get ();
    void set (TransferOutWorkItemStatus value);
}

See Also

TransferOutWorkItem Class


TransferOutWorkItemStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
TransferOutWorkItemStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum TransferOutWorkItemStatus
Visual Basic (Declaration)
Public Enumeration TransferOutWorkItemStatus
Visual C++
public enum class TransferOutWorkItemStatus

Members

Member name | Description
Unhandled |
Accepted |
Rejected |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


UpdateDataValidationErrorWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDataValidationErrorWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateDataValidationErrorWorkItemsResponse : UpdateWorkItemsResponse
Visual Basic (Declaration)
Public Class UpdateDataValidationErrorWorkItemsResponse _
    Inherits UpdateWorkItemsResponse
Visual C++
public ref class UpdateDataValidationErrorWorkItemsResponse : public UpdateWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateDataValidationErrorWorkItemsResponse

See Also

UpdateDataValidationErrorWorkItemsResponse Members


UpdateDataValidationErrorWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDataValidationErrorWorkItemsResponse Members
UpdateDataValidationErrorWorkItemsResponse Class Constructors Properties See Also Send Feedback

The UpdateDataValidationErrorWorkItemsResponse type exposes the following members.

Constructors

Name | Description
UpdateDataValidationErrorWorkItemsResponse |

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedDataValidationErrorWorkItems |

See Also

UpdateDataValidationErrorWorkItemsResponse Class


UpdateDataValidationErrorWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDataValidationErrorWorkItemsResponse Constructor
UpdateDataValidationErrorWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDataValidationErrorWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateDataValidationErrorWorkItemsResponse()

See Also

UpdateDataValidationErrorWorkItemsResponse Class


UpdateDataValidationErrorWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDataValidationErrorWorkItemsResponse Properties
UpdateDataValidationErrorWorkItemsResponse Class See Also Send Feedback

The UpdateDataValidationErrorWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedDataValidationErrorWorkItems |

See Also

UpdateDataValidationErrorWorkItemsResponse Class


UpdatedDataValidationErrorWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDataValidationErrorWorkItemsResponse..::.UpdatedDataValidationErrorWorkItems Property
UpdateDataValidationErrorWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DataValidationErrorWorkItem[] UpdatedDataValidationErrorWorkItems { get; set; }
Visual Basic (Declaration)
Public Property UpdatedDataValidationErrorWorkItems As DataValidationErrorWorkItem()
Visual C++
public:
property array<DataValidationErrorWorkItem^>^ UpdatedDataValidationErrorWorkItems {
    array<DataValidationErrorWorkItem^>^ get ();
    void set (array<DataValidationErrorWorkItem^>^ value);
}

See Also

UpdateDataValidationErrorWorkItemsResponse Class


UpdateDeathRecordMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDeathRecordMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateDeathRecordMatchCaseWorkItemsResponse : UpdateWorkItemsResponse
Visual Basic (Declaration)
Public Class UpdateDeathRecordMatchCaseWorkItemsResponse _
    Inherits UpdateWorkItemsResponse
Visual C++
public ref class UpdateDeathRecordMatchCaseWorkItemsResponse : public UpdateWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateDeathRecordMatchCaseWorkItemsResponse

See Also

UpdateDeathRecordMatchCaseWorkItemsResponse Members


UpdateDeathRecordMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDeathRecordMatchCaseWorkItemsResponse Members
UpdateDeathRecordMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The UpdateDeathRecordMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
UpdateDeathRecordMatchCaseWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedDeathRecordMatchCaseWorkItems |

See Also

UpdateDeathRecordMatchCaseWorkItemsResponse Class


UpdateDeathRecordMatchCaseWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDeathRecordMatchCaseWorkItemsResponse Constructor
UpdateDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateDeathRecordMatchCaseWorkItemsResponse()()() |
UpdateDeathRecordMatchCaseWorkItemsResponse(ResponseStatus) |

See Also

UpdateDeathRecordMatchCaseWorkItemsResponse Class
UpdateDeathRecordMatchCaseWorkItemsResponse Members


UpdateDeathRecordMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDeathRecordMatchCaseWorkItemsResponse Constructor
UpdateDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDeathRecordMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateDeathRecordMatchCaseWorkItemsResponse()

See Also

UpdateDeathRecordMatchCaseWorkItemsResponse Class
UpdateDeathRecordMatchCaseWorkItemsResponse Overload


UpdateDeathRecordMatchCaseWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDeathRecordMatchCaseWorkItemsResponse Constructor (ResponseStatus)
UpdateDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDeathRecordMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateDeathRecordMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateDeathRecordMatchCaseWorkItemsResponse Class
UpdateDeathRecordMatchCaseWorkItemsResponse Overload


UpdateDeathRecordMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDeathRecordMatchCaseWorkItemsResponse Properties
UpdateDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

The UpdateDeathRecordMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedDeathRecordMatchCaseWorkItems |

See Also

UpdateDeathRecordMatchCaseWorkItemsResponse Class


UpdatedDeathRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDeathRecordMatchCaseWorkItemsResponse..::.UpdatedDeathRecordMatchCaseWorkItems Property
UpdateDeathRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DeathRecordMatchCaseWorkItem[] UpdatedDeathRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property UpdatedDeathRecordMatchCaseWorkItems As DeathRecordMatchCaseWorkItem()
Visual C++
public:
property array<DeathRecordMatchCaseWorkItem^>^ UpdatedDeathRecordMatchCaseWorkItems {
    array<DeathRecordMatchCaseWorkItem^>^ get ();
    void set (array<DeathRecordMatchCaseWorkItem^>^ value);
}

See Also

UpdateDeathRecordMatchCaseWorkItemsResponse Class


UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse : UpdateWorkItemsResponse
Visual Basic (Declaration)
Public Class UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse _
    Inherits UpdateWorkItemsResponse
Visual C++
public ref class UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse : public UpdateWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse

See Also

UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Members


UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Members
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse |

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedDMVChangeOfAddressRecordMatchCaseWorkItems |

See Also

UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class


UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Constructor
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse()

See Also

UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class


UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Properties
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

The UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedDMVChangeOfAddressRecordMatchCaseWorkItems |

See Also

UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class


UpdatedDMVChangeOfAddressRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse..::.UpdatedDMVChangeOfAddressRecordMatchCaseWorkItems Property
UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordMatchCaseWorkItem[] UpdatedDMVChangeOfAddressRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property UpdatedDMVChangeOfAddressRecordMatchCaseWorkItems As DMVChangeOfAddressRecordMatchCaseWorkItem()
Visual C++
public:
property array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ UpdatedDMVChangeOfAddressRecordMatchCaseWorkItems {
    array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ get ();
    void set (array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ value);
}

See Also

UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse Class


UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateDMVChangeOfAddressRecordReceivedMessagesResponse : UpdateMessagesResponse
Visual Basic (Declaration)
Public Class UpdateDMVChangeOfAddressRecordReceivedMessagesResponse _
    Inherits UpdateMessagesResponse
Visual C++
public ref class UpdateDMVChangeOfAddressRecordReceivedMessagesResponse : public UpdateMessagesResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateDMVChangeOfAddressRecordReceivedMessagesResponse

See Also

UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Members


UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Members
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class Constructors Properties See Also Send Feedback

The UpdateDMVChangeOfAddressRecordReceivedMessagesResponse type exposes the following members.

Constructors

Name | Description
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse |

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
UpdatedDMVChangeOfAddressRecordReceivedMessages |

See Also

UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class


UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Constructor
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDMVChangeOfAddressRecordReceivedMessagesResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse()

See Also

UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class


UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Properties
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class See Also Send Feedback

The UpdateDMVChangeOfAddressRecordReceivedMessagesResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
UpdatedDMVChangeOfAddressRecordReceivedMessages |

See Also

UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class


UpdatedDMVChangeOfAddressRecordReceivedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse..::.UpdatedDMVChangeOfAddressRecordReceivedMessages Property
UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordReceivedMessage[] UpdatedDMVChangeOfAddressRecordReceivedMessages { get; set; }
Visual Basic (Declaration)
Public Property UpdatedDMVChangeOfAddressRecordReceivedMessages As DMVChangeOfAddressRecordReceivedMessage()
Visual C++
public:
property array<DMVChangeOfAddressRecordReceivedMessage^>^ UpdatedDMVChangeOfAddressRecordReceivedMessages {
    array<DMVChangeOfAddressRecordReceivedMessage^>^ get ();
    void set (array<DMVChangeOfAddressRecordReceivedMessage^>^ value);
}

See Also

UpdateDMVChangeOfAddressRecordReceivedMessagesResponse Class


UpdateDuplicateVoterMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDuplicateVoterMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateDuplicateVoterMatchCaseWorkItemsResponse : UpdateWorkItemsResponse
Visual Basic (Declaration)
Public Class UpdateDuplicateVoterMatchCaseWorkItemsResponse _
    Inherits UpdateWorkItemsResponse
Visual C++
public ref class UpdateDuplicateVoterMatchCaseWorkItemsResponse : public UpdateWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateDuplicateVoterMatchCaseWorkItemsResponse

See Also

UpdateDuplicateVoterMatchCaseWorkItemsResponse Members


UpdateDuplicateVoterMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDuplicateVoterMatchCaseWorkItemsResponse Members
UpdateDuplicateVoterMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The UpdateDuplicateVoterMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
UpdateDuplicateVoterMatchCaseWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedDuplicateVoterMatchCaseWorkItems |

See Also

UpdateDuplicateVoterMatchCaseWorkItemsResponse Class


UpdateDuplicateVoterMatchCaseWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDuplicateVoterMatchCaseWorkItemsResponse Constructor
UpdateDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateDuplicateVoterMatchCaseWorkItemsResponse()()() |
UpdateDuplicateVoterMatchCaseWorkItemsResponse(ResponseStatus) |

See Also

UpdateDuplicateVoterMatchCaseWorkItemsResponse Class
UpdateDuplicateVoterMatchCaseWorkItemsResponse Members


UpdateDuplicateVoterMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDuplicateVoterMatchCaseWorkItemsResponse Constructor
UpdateDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDuplicateVoterMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateDuplicateVoterMatchCaseWorkItemsResponse()

See Also

UpdateDuplicateVoterMatchCaseWorkItemsResponse Class
UpdateDuplicateVoterMatchCaseWorkItemsResponse Overload


UpdateDuplicateVoterMatchCaseWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDuplicateVoterMatchCaseWorkItemsResponse Constructor (ResponseStatus)
UpdateDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateDuplicateVoterMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateDuplicateVoterMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateDuplicateVoterMatchCaseWorkItemsResponse Class
UpdateDuplicateVoterMatchCaseWorkItemsResponse Overload


UpdateDuplicateVoterMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateDuplicateVoterMatchCaseWorkItemsResponse Properties
UpdateDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

The UpdateDuplicateVoterMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedDuplicateVoterMatchCaseWorkItems |

See Also

UpdateDuplicateVoterMatchCaseWorkItemsResponse Class


UpdatedDuplicateVoterMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateDuplicateVoterMatchCaseWorkItemsResponse..::.UpdatedDuplicateVoterMatchCaseWorkItems Property
UpdateDuplicateVoterMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DuplicateVoterMatchCaseWorkItem[] UpdatedDuplicateVoterMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property UpdatedDuplicateVoterMatchCaseWorkItems As DuplicateVoterMatchCaseWorkItem()
Visual C++
public:
property array<DuplicateVoterMatchCaseWorkItem^>^ UpdatedDuplicateVoterMatchCaseWorkItems {
    array<DuplicateVoterMatchCaseWorkItem^>^ get ();
    void set (array<DuplicateVoterMatchCaseWorkItem^>^ value);
}

See Also

UpdateDuplicateVoterMatchCaseWorkItemsResponse Class


UpdateFelonRecordMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateFelonRecordMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateFelonRecordMatchCaseWorkItemsResponse : UpdateWorkItemsResponse
Visual Basic (Declaration)
Public Class UpdateFelonRecordMatchCaseWorkItemsResponse _
    Inherits UpdateWorkItemsResponse
Visual C++
public ref class UpdateFelonRecordMatchCaseWorkItemsResponse : public UpdateWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateFelonRecordMatchCaseWorkItemsResponse

See Also

UpdateFelonRecordMatchCaseWorkItemsResponse Members


UpdateFelonRecordMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateFelonRecordMatchCaseWorkItemsResponse Members
UpdateFelonRecordMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The UpdateFelonRecordMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
UpdateFelonRecordMatchCaseWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedFelonRecordMatchCaseWorkItems |

See Also

UpdateFelonRecordMatchCaseWorkItemsResponse Class


UpdateFelonRecordMatchCaseWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateFelonRecordMatchCaseWorkItemsResponse Constructor
UpdateFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateFelonRecordMatchCaseWorkItemsResponse()()() |
UpdateFelonRecordMatchCaseWorkItemsResponse(ResponseStatus) |

See Also

UpdateFelonRecordMatchCaseWorkItemsResponse Class
UpdateFelonRecordMatchCaseWorkItemsResponse Members


UpdateFelonRecordMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateFelonRecordMatchCaseWorkItemsResponse Constructor
UpdateFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateFelonRecordMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateFelonRecordMatchCaseWorkItemsResponse()

See Also

UpdateFelonRecordMatchCaseWorkItemsResponse Class
UpdateFelonRecordMatchCaseWorkItemsResponse Overload


UpdateFelonRecordMatchCaseWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateFelonRecordMatchCaseWorkItemsResponse Constructor (ResponseStatus)
UpdateFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateFelonRecordMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateFelonRecordMatchCaseWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateFelonRecordMatchCaseWorkItemsResponse Class
UpdateFelonRecordMatchCaseWorkItemsResponse Overload


UpdateFelonRecordMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateFelonRecordMatchCaseWorkItemsResponse Properties
UpdateFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

The UpdateFelonRecordMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedFelonRecordMatchCaseWorkItems |

See Also

UpdateFelonRecordMatchCaseWorkItemsResponse Class


UpdatedFelonRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateFelonRecordMatchCaseWorkItemsResponse..::.UpdatedFelonRecordMatchCaseWorkItems Property
UpdateFelonRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FelonRecordMatchCaseWorkItem[] UpdatedFelonRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property UpdatedFelonRecordMatchCaseWorkItems As FelonRecordMatchCaseWorkItem()
Visual C++
public:
property array<FelonRecordMatchCaseWorkItem^>^ UpdatedFelonRecordMatchCaseWorkItems {
    array<FelonRecordMatchCaseWorkItem^>^ get ();
    void set (array<FelonRecordMatchCaseWorkItem^>^ value);
}

See Also

UpdateFelonRecordMatchCaseWorkItemsResponse Class


UpdateMessagesResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateMessagesResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateMessagesResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class UpdateMessagesResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class UpdateMessagesResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateDMVChangeOfAddressRecordReceivedMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateNationalChangeOfAddressRecordReceivedMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterStatusUpdatedMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterUpdatedMessagesResponse

See Also

UpdateMessagesResponse Members


UpdateMessagesResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateMessagesResponse Members
UpdateMessagesResponse Class Constructors Properties See Also Send Feedback

The UpdateMessagesResponse type exposes the following members.

Constructors

Name | Description
UpdateMessagesResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)

See Also

UpdateMessagesResponse Class


UpdateMessagesResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateMessagesResponse Constructor
UpdateMessagesResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateMessagesResponse()()() |
UpdateMessagesResponse(ResponseStatus) |

See Also

UpdateMessagesResponse Class
UpdateMessagesResponse Members


UpdateMessagesResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateMessagesResponse Constructor
UpdateMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateMessagesResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateMessagesResponse()

See Also

UpdateMessagesResponse Class
UpdateMessagesResponse Overload


UpdateMessagesResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateMessagesResponse Constructor (ResponseStatus)
UpdateMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateMessagesResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateMessagesResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateMessagesResponse Class
UpdateMessagesResponse Overload


UpdateMessagesResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateMessagesResponse Properties
UpdateMessagesResponse Class See Also Send Feedback

The UpdateMessagesResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)

See Also

UpdateMessagesResponse Class


UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse : UpdateWorkItemsResponse
Visual Basic (Declaration)
Public Class UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse _
    Inherits UpdateWorkItemsResponse
Visual C++
public ref class UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse : public UpdateWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse

See Also

UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Members


UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Members
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class Constructors Properties See Also Send Feedback

The UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse type exposes the following members.

Constructors

Name | Description
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse |

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedNationalChangeOfAddressRecordMatchCaseWorkItems |

See Also

UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class


UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Constructor
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse()

See Also

UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class


UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Properties
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

The UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedNationalChangeOfAddressRecordMatchCaseWorkItems |

See Also

UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class


UpdatedNationalChangeOfAddressRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse..::.UpdatedNationalChangeOfAddressRecordMatchCaseWorkItems Property
UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordMatchCaseWorkItem[] UpdatedNationalChangeOfAddressRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property UpdatedNationalChangeOfAddressRecordMatchCaseWorkItems As NationalChangeOfAddressRecordMatchCaseWorkItem()
Visual C++
public:
property array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ UpdatedNationalChangeOfAddressRecordMatchCaseWorkItems {
    array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ get ();
    void set (array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ value);
}

See Also

UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse Class


UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateNationalChangeOfAddressRecordReceivedMessagesResponse : UpdateMessagesResponse
Visual Basic (Declaration)
Public Class UpdateNationalChangeOfAddressRecordReceivedMessagesResponse _
    Inherits UpdateMessagesResponse
Visual C++
public ref class UpdateNationalChangeOfAddressRecordReceivedMessagesResponse : public UpdateMessagesResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateNationalChangeOfAddressRecordReceivedMessagesResponse

See Also

UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Members


UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Members
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class Constructors Properties See Also Send Feedback

The UpdateNationalChangeOfAddressRecordReceivedMessagesResponse type exposes the following members.

Constructors

Name | Description
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse |

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
UpdatedNationalChangeOfAddressRecordReceivedMessages |

See Also

UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class


UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Constructor
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateNationalChangeOfAddressRecordReceivedMessagesResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse()

See Also

UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class


UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Properties
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class See Also Send Feedback

The UpdateNationalChangeOfAddressRecordReceivedMessagesResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
UpdatedNationalChangeOfAddressRecordReceivedMessages |

See Also

UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class


UpdatedNationalChangeOfAddressRecordReceivedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse..::.UpdatedNationalChangeOfAddressRecordReceivedMessages Property
UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordReceivedMessage[] UpdatedNationalChangeOfAddressRecordReceivedMessages { get; set; }
Visual Basic (Declaration)
Public Property UpdatedNationalChangeOfAddressRecordReceivedMessages As NationalChangeOfAddressRecordReceivedMessage()
Visual C++
public:
property array<NationalChangeOfAddressRecordReceivedMessage^>^ UpdatedNationalChangeOfAddressRecordReceivedMessages {
    array<NationalChangeOfAddressRecordReceivedMessage^>^ get ();
    void set (array<NationalChangeOfAddressRecordReceivedMessage^>^ value);
}

See Also

UpdateNationalChangeOfAddressRecordReceivedMessagesResponse Class


UpdateNewVoterReceivedMessagesResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNewVoterReceivedMessagesResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateNewVoterReceivedMessagesResponse : UpdateWorkItemsResponse
Visual Basic (Declaration)
Public Class UpdateNewVoterReceivedMessagesResponse _
    Inherits UpdateWorkItemsResponse
Visual C++
public ref class UpdateNewVoterReceivedMessagesResponse : public UpdateWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateNewVoterReceivedMessagesResponse

See Also

UpdateNewVoterReceivedMessagesResponse Members


UpdateNewVoterReceivedMessagesResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateNewVoterReceivedMessagesResponse Members
UpdateNewVoterReceivedMessagesResponse Class Constructors Properties See Also Send Feedback

The UpdateNewVoterReceivedMessagesResponse type exposes the following members.

Constructors

Name | Description
UpdateNewVoterReceivedMessagesResponse | Overloaded.

Properties

Name | Description
NewRegistrationMessages |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)

See Also

UpdateNewVoterReceivedMessagesResponse Class


UpdateNewVoterReceivedMessagesResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateNewVoterReceivedMessagesResponse Constructor
UpdateNewVoterReceivedMessagesResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateNewVoterReceivedMessagesResponse()()() |
UpdateNewVoterReceivedMessagesResponse(ResponseStatus) |

See Also

UpdateNewVoterReceivedMessagesResponse Class
UpdateNewVoterReceivedMessagesResponse Members


UpdateNewVoterReceivedMessagesResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNewVoterReceivedMessagesResponse Constructor
UpdateNewVoterReceivedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateNewVoterReceivedMessagesResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateNewVoterReceivedMessagesResponse()

See Also

UpdateNewVoterReceivedMessagesResponse Class
UpdateNewVoterReceivedMessagesResponse Overload


UpdateNewVoterReceivedMessagesResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNewVoterReceivedMessagesResponse Constructor (ResponseStatus)
UpdateNewVoterReceivedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateNewVoterReceivedMessagesResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateNewVoterReceivedMessagesResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateNewVoterReceivedMessagesResponse Class
UpdateNewVoterReceivedMessagesResponse Overload


UpdateNewVoterReceivedMessagesResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateNewVoterReceivedMessagesResponse Properties
UpdateNewVoterReceivedMessagesResponse Class See Also Send Feedback

The UpdateNewVoterReceivedMessagesResponse type exposes the following members.

Properties

Name | Description
NewRegistrationMessages |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)

See Also

UpdateNewVoterReceivedMessagesResponse Class


NewRegistrationMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateNewVoterReceivedMessagesResponse..::.NewRegistrationMessages Property
UpdateNewVoterReceivedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NewVoterReceivedMessage[] NewRegistrationMessages { get; set; }
Visual Basic (Declaration)
Public Property NewRegistrationMessages As NewVoterReceivedMessage()
Visual C++
public:
property array<NewVoterReceivedMessage^>^ NewRegistrationMessages {
    array<NewVoterReceivedMessage^>^ get ();
    void set (array<NewVoterReceivedMessage^>^ value);
}

See Also

UpdateNewVoterReceivedMessagesResponse Class


UpdateStateVoterActivityCreatedMessagesResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterActivityCreatedMessagesResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateStateVoterActivityCreatedMessagesResponse : UpdateWorkItemsResponse
Visual Basic (Declaration)
Public Class UpdateStateVoterActivityCreatedMessagesResponse _
    Inherits UpdateWorkItemsResponse
Visual C++
public ref class UpdateStateVoterActivityCreatedMessagesResponse : public UpdateWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterActivityCreatedMessagesResponse

See Also

UpdateStateVoterActivityCreatedMessagesResponse Members


UpdateStateVoterActivityCreatedMessagesResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterActivityCreatedMessagesResponse Members
UpdateStateVoterActivityCreatedMessagesResponse Class Constructors Properties See Also Send Feedback

The UpdateStateVoterActivityCreatedMessagesResponse type exposes the following members.

Constructors

Name | Description
UpdateStateVoterActivityCreatedMessagesResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedStateVoterActivityCreatedMessages |

See Also

UpdateStateVoterActivityCreatedMessagesResponse Class


UpdateStateVoterActivityCreatedMessagesResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterActivityCreatedMessagesResponse Constructor
UpdateStateVoterActivityCreatedMessagesResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateStateVoterActivityCreatedMessagesResponse()()() |
UpdateStateVoterActivityCreatedMessagesResponse(ResponseStatus) |

See Also

UpdateStateVoterActivityCreatedMessagesResponse Class
UpdateStateVoterActivityCreatedMessagesResponse Members


UpdateStateVoterActivityCreatedMessagesResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterActivityCreatedMessagesResponse Constructor
UpdateStateVoterActivityCreatedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterActivityCreatedMessagesResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateStateVoterActivityCreatedMessagesResponse()

See Also

UpdateStateVoterActivityCreatedMessagesResponse Class
UpdateStateVoterActivityCreatedMessagesResponse Overload


UpdateStateVoterActivityCreatedMessagesResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterActivityCreatedMessagesResponse Constructor (ResponseStatus)
UpdateStateVoterActivityCreatedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterActivityCreatedMessagesResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateStateVoterActivityCreatedMessagesResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateStateVoterActivityCreatedMessagesResponse Class
UpdateStateVoterActivityCreatedMessagesResponse Overload


UpdateStateVoterActivityCreatedMessagesResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterActivityCreatedMessagesResponse Properties
UpdateStateVoterActivityCreatedMessagesResponse Class See Also Send Feedback

The UpdateStateVoterActivityCreatedMessagesResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedStateVoterActivityCreatedMessages |

See Also

UpdateStateVoterActivityCreatedMessagesResponse Class


UpdatedStateVoterActivityCreatedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterActivityCreatedMessagesResponse..::.UpdatedStateVoterActivityCreatedMessages Property
UpdateStateVoterActivityCreatedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterActivityCreatedMessage UpdatedStateVoterActivityCreatedMessages { get; set; }
Visual Basic (Declaration)
Public Property UpdatedStateVoterActivityCreatedMessages As StateVoterActivityCreatedMessage
Visual C++
public:
property StateVoterActivityCreatedMessage^ UpdatedStateVoterActivityCreatedMessages {
    StateVoterActivityCreatedMessage^ get ();
    void set (StateVoterActivityCreatedMessage^ value);
}

See Also

UpdateStateVoterActivityCreatedMessagesResponse Class


UpdateStateVoterProperties Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateStateVoterProperties
Visual Basic (Declaration)
Public Class UpdateStateVoterProperties
Visual C++
public ref class UpdateStateVoterProperties

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterProperties

See Also

UpdateStateVoterProperties Members


UpdateStateVoterProperties Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties Members
UpdateStateVoterProperties Class Constructors Fields See Also Send Feedback

The UpdateStateVoterProperties type exposes the following members.

Constructors

Name | Description
UpdateStateVoterProperties |

Fields

Name | Description
duplicatesToIgnoreStateVoterIdKeys |
isDiscard |
RefDMVChangeOfAddressRecordReceivedMessageId |
RefNationalChangeOfAddressRecordReceivedMessageId |
RefNewVoterReceivedMessageId |
transferStateVoterIdKey |

See Also

UpdateStateVoterProperties Class


UpdateStateVoterProperties Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties Constructor
UpdateStateVoterProperties Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterProperties()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateStateVoterProperties()

See Also

UpdateStateVoterProperties Class


UpdateStateVoterProperties Fields

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties Fields
UpdateStateVoterProperties Class See Also Send Feedback

The UpdateStateVoterProperties type exposes the following members.

Fields

Name | Description
duplicatesToIgnoreStateVoterIdKeys |
isDiscard |
RefDMVChangeOfAddressRecordReceivedMessageId |
RefNationalChangeOfAddressRecordReceivedMessageId |
RefNewVoterReceivedMessageId |
transferStateVoterIdKey |

See Also

UpdateStateVoterProperties Class


duplicatesToIgnoreStateVoterIdKeys Field

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties..::.duplicatesToIgnoreStateVoterIdKeys Field
UpdateStateVoterProperties Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid[] duplicatesToIgnoreStateVoterIdKeys
Visual Basic (Declaration)
Public duplicatesToIgnoreStateVoterIdKeys As Guid()
Visual C++
public:
array<Guid>^ duplicatesToIgnoreStateVoterIdKeys

See Also

UpdateStateVoterProperties Class


isDiscard Field

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties..::.isDiscard Field
UpdateStateVoterProperties Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool isDiscard
Visual Basic (Declaration)
Public isDiscard As Boolean
Visual C++
public:
bool isDiscard

See Also

UpdateStateVoterProperties Class


RefDMVChangeOfAddressRecordReceivedMessageId Field

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties..::.RefDMVChangeOfAddressRecordReceivedMessageId Field
UpdateStateVoterProperties Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid RefDMVChangeOfAddressRecordReceivedMessageId
Visual Basic (Declaration)
Public RefDMVChangeOfAddressRecordReceivedMessageId As Guid
Visual C++
public:
Guid RefDMVChangeOfAddressRecordReceivedMessageId

See Also

UpdateStateVoterProperties Class


RefNationalChangeOfAddressRecordReceivedMessageId Field

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties..::.RefNationalChangeOfAddressRecordReceivedMessageId Field
UpdateStateVoterProperties Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid RefNationalChangeOfAddressRecordReceivedMessageId
Visual Basic (Declaration)
Public RefNationalChangeOfAddressRecordReceivedMessageId As Guid
Visual C++
public:
Guid RefNationalChangeOfAddressRecordReceivedMessageId

See Also

UpdateStateVoterProperties Class


RefNewVoterReceivedMessageId Field

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties..::.RefNewVoterReceivedMessageId Field
UpdateStateVoterProperties Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid RefNewVoterReceivedMessageId
Visual Basic (Declaration)
Public RefNewVoterReceivedMessageId As Guid
Visual C++
public:
Guid RefNewVoterReceivedMessageId

See Also

UpdateStateVoterProperties Class


transferStateVoterIdKey Field

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterProperties..::.transferStateVoterIdKey Field
UpdateStateVoterProperties Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid transferStateVoterIdKey
Visual Basic (Declaration)
Public transferStateVoterIdKey As Guid
Visual C++
public:
Guid transferStateVoterIdKey

See Also

UpdateStateVoterProperties Class


UpdateStateVoterResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateStateVoterResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class UpdateStateVoterResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class UpdateStateVoterResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterResponse

See Also

UpdateStateVoterResponse Members


UpdateStateVoterResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse Members
UpdateStateVoterResponse Class Constructors Properties See Also Send Feedback

The UpdateStateVoterResponse type exposes the following members.

Constructors

Name | Description
UpdateStateVoterResponse | Overloaded.

Properties

Name | Description
DuplicatesToIgnoreStateVoterIdKeys |
ReferencedDMVChangeOfAddressRecordReceivedMessage |
ReferencedNationalChangeOfAddressRecordReceivedMessage |
ReferencedNewVoterReceivedMessage |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
StateVoterUpdatedMessage | Specifies updates made to a state voter in response to the UpdateStateVoter call. If this object is not null, the County EMS must update their local copy of the voter to match the state record, and update the StateVoterUpdatedMessage with a status of "VoterUpdateApplied". Note that in the case of new registrations the voter object in the message contains the StateVoterId, StateVoterIdKey, VoterStatus, and VoterStatusReason as determined by VoteCal.
TransferedStateVoterIdKey |
WasDiscarded |

See Also

UpdateStateVoterResponse Class


UpdateStateVoterResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse Constructor
UpdateStateVoterResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateStateVoterResponse()()() |
UpdateStateVoterResponse(ResponseStatus) |

See Also

UpdateStateVoterResponse Class
UpdateStateVoterResponse Members


UpdateStateVoterResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse Constructor
UpdateStateVoterResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateStateVoterResponse()

See Also

UpdateStateVoterResponse Class
UpdateStateVoterResponse Overload


UpdateStateVoterResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse Constructor (ResponseStatus)
UpdateStateVoterResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateStateVoterResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateStateVoterResponse Class
UpdateStateVoterResponse Overload


UpdateStateVoterResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse Properties
UpdateStateVoterResponse Class See Also Send Feedback

The UpdateStateVoterResponse type exposes the following members.

Properties

Name | Description
DuplicatesToIgnoreStateVoterIdKeys |
ReferencedDMVChangeOfAddressRecordReceivedMessage |
ReferencedNationalChangeOfAddressRecordReceivedMessage |
ReferencedNewVoterReceivedMessage |
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
StateVoterUpdatedMessage | Specifies updates made to a state voter in response to the UpdateStateVoter call. If this object is not null, the County EMS must update their local copy of the voter to match the state record, and update the StateVoterUpdatedMessage with a status of "VoterUpdateApplied". Note that in the case of new registrations the voter object in the message contains the StateVoterId, StateVoterIdKey, VoterStatus, and VoterStatusReason as determined by VoteCal.
TransferedStateVoterIdKey |
WasDiscarded |

See Also

UpdateStateVoterResponse Class


DuplicatesToIgnoreStateVoterIdKeys Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse..::.DuplicatesToIgnoreStateVoterIdKeys Property
UpdateStateVoterResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid[] DuplicatesToIgnoreStateVoterIdKeys { get; set; }
Visual Basic (Declaration)
Public Property DuplicatesToIgnoreStateVoterIdKeys As Guid()
Visual C++
public:
property array<Guid>^ DuplicatesToIgnoreStateVoterIdKeys {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

See Also

UpdateStateVoterResponse Class


ReferencedDMVChangeOfAddressRecordReceivedMessage Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse..::.ReferencedDMVChangeOfAddressRecordReceivedMessage Property
UpdateStateVoterResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordReceivedMessage ReferencedDMVChangeOfAddressRecordReceivedMessage { get; set; }
Visual Basic (Declaration)
Public Property ReferencedDMVChangeOfAddressRecordReceivedMessage As DMVChangeOfAddressRecordReceivedMessage
Visual C++
public:
property DMVChangeOfAddressRecordReceivedMessage^ ReferencedDMVChangeOfAddressRecordReceivedMessage {
    DMVChangeOfAddressRecordReceivedMessage^ get ();
    void set (DMVChangeOfAddressRecordReceivedMessage^ value);
}

See Also

UpdateStateVoterResponse Class


ReferencedNationalChangeOfAddressRecordReceivedMessage Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse..::.ReferencedNationalChangeOfAddressRecordReceivedMessage Property
UpdateStateVoterResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordReceivedMessage ReferencedNationalChangeOfAddressRecordReceivedMessage { get; set; }
Visual Basic (Declaration)
Public Property ReferencedNationalChangeOfAddressRecordReceivedMessage As NationalChangeOfAddressRecordReceivedMessage
Visual C++
public:
property NationalChangeOfAddressRecordReceivedMessage^ ReferencedNationalChangeOfAddressRecordReceivedMessage {
    NationalChangeOfAddressRecordReceivedMessage^ get ();
    void set (NationalChangeOfAddressRecordReceivedMessage^ value);
}

See Also

UpdateStateVoterResponse Class


ReferencedNewVoterReceivedMessage Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse..::.ReferencedNewVoterReceivedMessage Property
UpdateStateVoterResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NewVoterReceivedMessage ReferencedNewVoterReceivedMessage { get; set; }
Visual Basic (Declaration)
Public Property ReferencedNewVoterReceivedMessage As NewVoterReceivedMessage
Visual C++
public:
property NewVoterReceivedMessage^ ReferencedNewVoterReceivedMessage {
    NewVoterReceivedMessage^ get ();
    void set (NewVoterReceivedMessage^ value);
}

See Also

UpdateStateVoterResponse Class


ResponseStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse..::.ResponseStatusReason Property
UpdateStateVoterResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterResponseStatusReason ResponseStatusReason { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatusReason As UpdateStateVoterResponseStatusReason
Visual C++
public:
property UpdateStateVoterResponseStatusReason ResponseStatusReason {
    UpdateStateVoterResponseStatusReason get ();
    void set (UpdateStateVoterResponseStatusReason value);
}

See Also

UpdateStateVoterResponse Class


StateVoterUpdatedMessage Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse..::.StateVoterUpdatedMessage Property
UpdateStateVoterResponse Class See Also Send Feedback
Specifies updates made to a state voter in response to the UpdateStateVoter call. If this object is not null, the County EMS must update their local copy of the voter to match the state record, and update the StateVoterUpdatedMessage with a status of "VoterUpdateApplied". Note that in the case of new registrations the voter object in the message contains the StateVoterId, StateVoterIdKey, VoterStatus, and VoterStatusReason as determined by VoteCal.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterUpdatedMessage StateVoterUpdatedMessage { get; set; }
Visual Basic (Declaration)
Public Property StateVoterUpdatedMessage As StateVoterUpdatedMessage
Visual C++
public:
property StateVoterUpdatedMessage^ StateVoterUpdatedMessage {
    StateVoterUpdatedMessage^ get ();
    void set (StateVoterUpdatedMessage^ value);
}

See Also

UpdateStateVoterResponse Class


TransferedStateVoterIdKey Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse..::.TransferedStateVoterIdKey Property
UpdateStateVoterResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid TransferedStateVoterIdKey { get; set; }
Visual Basic (Declaration)
Public Property TransferedStateVoterIdKey As Guid
Visual C++
public:
property Guid TransferedStateVoterIdKey {
    Guid get ();
    void set (Guid value);
}

See Also

UpdateStateVoterResponse Class


WasDiscarded Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponse..::.WasDiscarded Property
UpdateStateVoterResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public bool WasDiscarded { get; set; }
Visual Basic (Declaration)
Public Property WasDiscarded As Boolean
Visual C++
public:
property bool WasDiscarded {
    bool get ();
    void set (bool value);
}

See Also

UpdateStateVoterResponse Class


UpdateStateVoterResponseStatusReason Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterResponseStatusReason Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum UpdateStateVoterResponseStatusReason
Visual Basic (Declaration)
Public Enumeration UpdateStateVoterResponseStatusReason
Visual C++
public enum class UpdateStateVoterResponseStatusReason

Members

Member name | Description
None |
DataValidationErrorDeficiencyOnly |
DataValidationErrorFatal |
MissingCountyVoterIdPrimaryKey |
InvalidTransfer |
InvalidCredentials |
Unknown |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


UpdateStateVoterStatusUpdatedMessagesResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterStatusUpdatedMessagesResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateStateVoterStatusUpdatedMessagesResponse : UpdateMessagesResponse
Visual Basic (Declaration)
Public Class UpdateStateVoterStatusUpdatedMessagesResponse _
    Inherits UpdateMessagesResponse
Visual C++
public ref class UpdateStateVoterStatusUpdatedMessagesResponse : public UpdateMessagesResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterStatusUpdatedMessagesResponse

See Also

UpdateStateVoterStatusUpdatedMessagesResponse Members


UpdateStateVoterStatusUpdatedMessagesResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterStatusUpdatedMessagesResponse Members
UpdateStateVoterStatusUpdatedMessagesResponse Class Constructors Properties See Also Send Feedback

The UpdateStateVoterStatusUpdatedMessagesResponse type exposes the following members.

Constructors

Name | Description
UpdateStateVoterStatusUpdatedMessagesResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
UpdatedStateVoterStatusUpdatedMessages |

See Also

UpdateStateVoterStatusUpdatedMessagesResponse Class


UpdateStateVoterStatusUpdatedMessagesResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterStatusUpdatedMessagesResponse Constructor
UpdateStateVoterStatusUpdatedMessagesResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateStateVoterStatusUpdatedMessagesResponse()()() |
UpdateStateVoterStatusUpdatedMessagesResponse(ResponseStatus) |

See Also

UpdateStateVoterStatusUpdatedMessagesResponse Class
UpdateStateVoterStatusUpdatedMessagesResponse Members


UpdateStateVoterStatusUpdatedMessagesResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterStatusUpdatedMessagesResponse Constructor
UpdateStateVoterStatusUpdatedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterStatusUpdatedMessagesResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateStateVoterStatusUpdatedMessagesResponse()

See Also

UpdateStateVoterStatusUpdatedMessagesResponse Class
UpdateStateVoterStatusUpdatedMessagesResponse Overload


UpdateStateVoterStatusUpdatedMessagesResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterStatusUpdatedMessagesResponse Constructor (ResponseStatus)
UpdateStateVoterStatusUpdatedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterStatusUpdatedMessagesResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateStateVoterStatusUpdatedMessagesResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateStateVoterStatusUpdatedMessagesResponse Class
UpdateStateVoterStatusUpdatedMessagesResponse Overload


UpdateStateVoterStatusUpdatedMessagesResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterStatusUpdatedMessagesResponse Properties
UpdateStateVoterStatusUpdatedMessagesResponse Class See Also Send Feedback

The UpdateStateVoterStatusUpdatedMessagesResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
UpdatedStateVoterStatusUpdatedMessages |

See Also

UpdateStateVoterStatusUpdatedMessagesResponse Class


UpdatedStateVoterStatusUpdatedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterStatusUpdatedMessagesResponse..::.UpdatedStateVoterStatusUpdatedMessages Property
UpdateStateVoterStatusUpdatedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterStatusUpdatedMessage[] UpdatedStateVoterStatusUpdatedMessages { get; set; }
Visual Basic (Declaration)
Public Property UpdatedStateVoterStatusUpdatedMessages As StateVoterStatusUpdatedMessage()
Visual C++
public:
property array<StateVoterStatusUpdatedMessage^>^ UpdatedStateVoterStatusUpdatedMessages {
    array<StateVoterStatusUpdatedMessage^>^ get ();
    void set (array<StateVoterStatusUpdatedMessage^>^ value);
}

See Also

UpdateStateVoterStatusUpdatedMessagesResponse Class


UpdateStateVoterUpdatedMessagesResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterUpdatedMessagesResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateStateVoterUpdatedMessagesResponse : UpdateMessagesResponse
Visual Basic (Declaration)
Public Class UpdateStateVoterUpdatedMessagesResponse _
    Inherits UpdateMessagesResponse
Visual C++
public ref class UpdateStateVoterUpdatedMessagesResponse : public UpdateMessagesResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterUpdatedMessagesResponse

See Also

UpdateStateVoterUpdatedMessagesResponse Members


UpdateStateVoterUpdatedMessagesResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterUpdatedMessagesResponse Members
UpdateStateVoterUpdatedMessagesResponse Class Constructors Properties See Also Send Feedback

The UpdateStateVoterUpdatedMessagesResponse type exposes the following members.

Constructors

Name | Description
UpdateStateVoterUpdatedMessagesResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
UpdatedStateVoterUpdatedMessages |

See Also

UpdateStateVoterUpdatedMessagesResponse Class


UpdateStateVoterUpdatedMessagesResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterUpdatedMessagesResponse Constructor
UpdateStateVoterUpdatedMessagesResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateStateVoterUpdatedMessagesResponse()()() |
UpdateStateVoterUpdatedMessagesResponse(ResponseStatus) |

See Also

UpdateStateVoterUpdatedMessagesResponse Class
UpdateStateVoterUpdatedMessagesResponse Members


UpdateStateVoterUpdatedMessagesResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterUpdatedMessagesResponse Constructor
UpdateStateVoterUpdatedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterUpdatedMessagesResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateStateVoterUpdatedMessagesResponse()

See Also

UpdateStateVoterUpdatedMessagesResponse Class
UpdateStateVoterUpdatedMessagesResponse Overload


UpdateStateVoterUpdatedMessagesResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterUpdatedMessagesResponse Constructor (ResponseStatus)
UpdateStateVoterUpdatedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterUpdatedMessagesResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateStateVoterUpdatedMessagesResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateStateVoterUpdatedMessagesResponse Class
UpdateStateVoterUpdatedMessagesResponse Overload


UpdateStateVoterUpdatedMessagesResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterUpdatedMessagesResponse Properties
UpdateStateVoterUpdatedMessagesResponse Class See Also Send Feedback

The UpdateStateVoterUpdatedMessagesResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
UpdatedStateVoterUpdatedMessages |

See Also

UpdateStateVoterUpdatedMessagesResponse Class


UpdatedStateVoterUpdatedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterUpdatedMessagesResponse..::.UpdatedStateVoterUpdatedMessages Property
UpdateStateVoterUpdatedMessagesResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterUpdatedMessage[] UpdatedStateVoterUpdatedMessages { get; set; }
Visual Basic (Declaration)
Public Property UpdatedStateVoterUpdatedMessages As StateVoterUpdatedMessage()
Visual C++
public:
property array<StateVoterUpdatedMessage^>^ UpdatedStateVoterUpdatedMessages {
    array<StateVoterUpdatedMessage^>^ get ();
    void set (array<StateVoterUpdatedMessage^>^ value);
}

See Also

UpdateStateVoterUpdatedMessagesResponse Class


UpdateStateVoterVoteByMailActivityResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterVoteByMailActivityResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateStateVoterVoteByMailActivityResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class UpdateStateVoterVoteByMailActivityResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class UpdateStateVoterVoteByMailActivityResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterVoteByMailActivityResponse

See Also

UpdateStateVoterVoteByMailActivityResponse Members


UpdateStateVoterVoteByMailActivityResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterVoteByMailActivityResponse Members
UpdateStateVoterVoteByMailActivityResponse Class Constructors Properties See Also Send Feedback

The UpdateStateVoterVoteByMailActivityResponse type exposes the following members.

Constructors

Name | Description
UpdateStateVoterVoteByMailActivityResponse |

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |

See Also

UpdateStateVoterVoteByMailActivityResponse Class


UpdateStateVoterVoteByMailActivityResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterVoteByMailActivityResponse Constructor
UpdateStateVoterVoteByMailActivityResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterVoteByMailActivityResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateStateVoterVoteByMailActivityResponse()

See Also

UpdateStateVoterVoteByMailActivityResponse Class


UpdateStateVoterVoteByMailActivityResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterVoteByMailActivityResponse Properties
UpdateStateVoterVoteByMailActivityResponse Class See Also Send Feedback

The UpdateStateVoterVoteByMailActivityResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |

See Also

UpdateStateVoterVoteByMailActivityResponse Class


ResponseStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterVoteByMailActivityResponse..::.ResponseStatusReason Property
UpdateStateVoterVoteByMailActivityResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateStateVoterVoteByMailActivityResponseStatusReason ResponseStatusReason { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatusReason As UpdateStateVoterVoteByMailActivityResponseStatusReason
Visual C++
public:
property UpdateStateVoterVoteByMailActivityResponseStatusReason ResponseStatusReason {
    UpdateStateVoterVoteByMailActivityResponseStatusReason get ();
    void set (UpdateStateVoterVoteByMailActivityResponseStatusReason value);
}

See Also

UpdateStateVoterVoteByMailActivityResponse Class


UpdateStateVoterVoteByMailActivityResponseStatusReason Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
UpdateStateVoterVoteByMailActivityResponseStatusReason Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum UpdateStateVoterVoteByMailActivityResponseStatusReason
Visual Basic (Declaration)
Public Enumeration UpdateStateVoterVoteByMailActivityResponseStatusReason
Visual C++
public enum class UpdateStateVoterVoteByMailActivityResponseStatusReason

Members

Member name | Description
None |
InvalidVoter |
InvalidCredentials |
Unknown |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


UpdateTransferOutWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateTransferOutWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateTransferOutWorkItemsResponse : UpdateWorkItemsResponse
Visual Basic (Declaration)
Public Class UpdateTransferOutWorkItemsResponse _
    Inherits UpdateWorkItemsResponse
Visual C++
public ref class UpdateTransferOutWorkItemsResponse : public UpdateWorkItemsResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateTransferOutWorkItemsResponse

See Also

UpdateTransferOutWorkItemsResponse Members


UpdateTransferOutWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateTransferOutWorkItemsResponse Members
UpdateTransferOutWorkItemsResponse Class Constructors Properties See Also Send Feedback

The UpdateTransferOutWorkItemsResponse type exposes the following members.

Constructors

Name | Description
UpdateTransferOutWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedTransferOutWorkItems |

See Also

UpdateTransferOutWorkItemsResponse Class


UpdateTransferOutWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateTransferOutWorkItemsResponse Constructor
UpdateTransferOutWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateTransferOutWorkItemsResponse()()() |
UpdateTransferOutWorkItemsResponse(ResponseStatus) |

See Also

UpdateTransferOutWorkItemsResponse Class
UpdateTransferOutWorkItemsResponse Members


UpdateTransferOutWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateTransferOutWorkItemsResponse Constructor
UpdateTransferOutWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateTransferOutWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateTransferOutWorkItemsResponse()

See Also

UpdateTransferOutWorkItemsResponse Class
UpdateTransferOutWorkItemsResponse Overload


UpdateTransferOutWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateTransferOutWorkItemsResponse Constructor (ResponseStatus)
UpdateTransferOutWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateTransferOutWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateTransferOutWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateTransferOutWorkItemsResponse Class
UpdateTransferOutWorkItemsResponse Overload


UpdateTransferOutWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateTransferOutWorkItemsResponse Properties
UpdateTransferOutWorkItemsResponse Class See Also Send Feedback

The UpdateTransferOutWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason | (Inherited from UpdateWorkItemsResponse.)
UpdatedTransferOutWorkItems |

See Also

UpdateTransferOutWorkItemsResponse Class


UpdatedTransferOutWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateTransferOutWorkItemsResponse..::.UpdatedTransferOutWorkItems Property
UpdateTransferOutWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TransferOutWorkItem[] UpdatedTransferOutWorkItems { get; set; }
Visual Basic (Declaration)
Public Property UpdatedTransferOutWorkItems As TransferOutWorkItem()
Visual C++
public:
property array<TransferOutWorkItem^>^ UpdatedTransferOutWorkItems {
    array<TransferOutWorkItem^>^ get ();
    void set (array<TransferOutWorkItem^>^ value);
}

See Also

UpdateTransferOutWorkItemsResponse Class


UpdateWorkItemsResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
UpdateWorkItemsResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class UpdateWorkItemsResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class UpdateWorkItemsResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class UpdateWorkItemsResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateDataValidationErrorWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateDeathRecordMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateDMVChangeOfAddressRecordMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateDuplicateVoterMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateFelonRecordMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateNationalChangeOfAddressRecordMatchCaseWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.UpdateNewVoterReceivedMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterActivityCreatedMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateTransferOutWorkItemsResponse

See Also

UpdateWorkItemsResponse Members


UpdateWorkItemsResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateWorkItemsResponse Members
UpdateWorkItemsResponse Class Constructors Properties See Also Send Feedback

The UpdateWorkItemsResponse type exposes the following members.

Constructors

Name | Description
UpdateWorkItemsResponse | Overloaded.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |

See Also

UpdateWorkItemsResponse Class


UpdateWorkItemsResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateWorkItemsResponse Constructor
UpdateWorkItemsResponse Class See Also Send Feedback

Overload List

Name | Description
UpdateWorkItemsResponse()()() |
UpdateWorkItemsResponse(ResponseStatus) |

See Also

UpdateWorkItemsResponse Class
UpdateWorkItemsResponse Members


UpdateWorkItemsResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
UpdateWorkItemsResponse Constructor
UpdateWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateWorkItemsResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UpdateWorkItemsResponse()

See Also

UpdateWorkItemsResponse Class
UpdateWorkItemsResponse Overload


UpdateWorkItemsResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
UpdateWorkItemsResponse Constructor (ResponseStatus)
UpdateWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public UpdateWorkItemsResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
UpdateWorkItemsResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

UpdateWorkItemsResponse Class
UpdateWorkItemsResponse Overload


UpdateWorkItemsResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
UpdateWorkItemsResponse Properties
UpdateWorkItemsResponse Class See Also Send Feedback

The UpdateWorkItemsResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |

See Also

UpdateWorkItemsResponse Class


ResponseStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
UpdateWorkItemsResponse..::.ResponseStatusReason Property
UpdateWorkItemsResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WorkItemsResponseStatusReason ResponseStatusReason { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatusReason As WorkItemsResponseStatusReason
Visual C++
public:
property WorkItemsResponseStatusReason ResponseStatusReason {
    WorkItemsResponseStatusReason get ();
    void set (WorkItemsResponseStatusReason value);
}

See Also

UpdateWorkItemsResponse Class


VerifyVoterIdentificationResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
VerifyVoterIdentificationResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class VerifyVoterIdentificationResponse : VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class VerifyVoterIdentificationResponse _
    Inherits VoteCalWebServiceResponse
Visual C++
public ref class VerifyVoterIdentificationResponse : public VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.VerifyVoterIdentificationResponse

See Also

VerifyVoterIdentificationResponse Members


VerifyVoterIdentificationResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
VerifyVoterIdentificationResponse Members
VerifyVoterIdentificationResponse Class Constructors Properties See Also Send Feedback

The VerifyVoterIdentificationResponse type exposes the following members.

Constructors

Name | Description
VerifyVoterIdentificationResponse |

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
SuggestedDL |
VoterIdentificationMatchType |

See Also

VerifyVoterIdentificationResponse Class


VerifyVoterIdentificationResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
VerifyVoterIdentificationResponse Constructor
VerifyVoterIdentificationResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VerifyVoterIdentificationResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VerifyVoterIdentificationResponse()

See Also

VerifyVoterIdentificationResponse Class


VerifyVoterIdentificationResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
VerifyVoterIdentificationResponse Properties
VerifyVoterIdentificationResponse Class See Also Send Feedback

The VerifyVoterIdentificationResponse type exposes the following members.

Properties

Name | Description
ResponseStatus | (Inherited from VoteCalWebServiceResponse.)
ResponseStatusReason |
SuggestedDL |
VoterIdentificationMatchType |

See Also

VerifyVoterIdentificationResponse Class


ResponseStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
VerifyVoterIdentificationResponse..::.ResponseStatusReason Property
VerifyVoterIdentificationResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VerifyVoterIdentificationResponseStatusReason ResponseStatusReason { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatusReason As VerifyVoterIdentificationResponseStatusReason
Visual C++
public:
property VerifyVoterIdentificationResponseStatusReason ResponseStatusReason {
    VerifyVoterIdentificationResponseStatusReason get ();
    void set (VerifyVoterIdentificationResponseStatusReason value);
}

See Also

VerifyVoterIdentificationResponse Class


SuggestedDL Property

[image]

VoteCal EMS Vendor Integration API Reference
VerifyVoterIdentificationResponse..::.SuggestedDL Property
VerifyVoterIdentificationResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SuggestedDL { get; set; }
Visual Basic (Declaration)
Public Property SuggestedDL As String
Visual C++
public:
property String^ SuggestedDL {
    String^ get ();
    void set (String^ value);
}

See Also

VerifyVoterIdentificationResponse Class


VoterIdentificationMatchType Property

[image]

VoteCal EMS Vendor Integration API Reference
VerifyVoterIdentificationResponse..::.VoterIdentificationMatchType Property
VerifyVoterIdentificationResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoterIdentificationMatchType VoterIdentificationMatchType { get; set; }
Visual Basic (Declaration)
Public Property VoterIdentificationMatchType As VoterIdentificationMatchType
Visual C++
public:
property VoterIdentificationMatchType VoterIdentificationMatchType {
    VoterIdentificationMatchType get ();
    void set (VoterIdentificationMatchType value);
}

See Also

VerifyVoterIdentificationResponse Class


VerifyVoterIdentificationResponseStatusReason Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
VerifyVoterIdentificationResponseStatusReason Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum VerifyVoterIdentificationResponseStatusReason
Visual Basic (Declaration)
Public Enumeration VerifyVoterIdentificationResponseStatusReason
Visual C++
public enum class VerifyVoterIdentificationResponseStatusReason

Members

Member name | Description
None |
InvalidCredentials |
Unknown |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


VoteByMailActivityType Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
VoteByMailActivityType Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum VoteByMailActivityType
Visual Basic (Declaration)
Public Enumeration VoteByMailActivityType
Visual C++
public enum class VoteByMailActivityType

Members

Member name | Description
RequestOneTimeBallot |
RequestPermanent |
BallotReceived |
BallotCounted |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


VoteCalWebServiceResponse Class

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalWebServiceResponse Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class VoteCalWebServiceResponse
Visual Basic (Declaration)
Public Class VoteCalWebServiceResponse
Visual C++
public ref class VoteCalWebServiceResponse

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoteCalWebServiceResponse
VoteCal.Management.Web.Services.Models..::.GetOpenMessagesResponse
VoteCal.Management.Web.Services.Models..::.GetOpenWorkItemCountsResponse
VoteCal.Management.Web.Services.Models..::.GetOpenWorkItemsListResponse
VoteCal.Management.Web.Services.Models..::.GetStateVotersResponse
VoteCal.Management.Web.Services.Models..::.GetWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.SearchStateVotersResponse
VoteCal.Management.Web.Services.Models..::.UpdateMessagesResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterResponse
VoteCal.Management.Web.Services.Models..::.UpdateStateVoterVoteByMailActivityResponse
VoteCal.Management.Web.Services.Models..::.UpdateWorkItemsResponse
VoteCal.Management.Web.Services.Models..::.VerifyVoterIdentificationResponse

See Also

VoteCalWebServiceResponse Members


VoteCalWebServiceResponse Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoteCalWebServiceResponse Members
VoteCalWebServiceResponse Class Constructors Properties See Also Send Feedback

The VoteCalWebServiceResponse type exposes the following members.

Constructors

Name | Description
VoteCalWebServiceResponse | Overloaded.

Properties

Name | Description
ResponseStatus |

See Also

VoteCalWebServiceResponse Class


VoteCalWebServiceResponse Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoteCalWebServiceResponse Constructor
VoteCalWebServiceResponse Class See Also Send Feedback

Overload List

Name | Description
VoteCalWebServiceResponse()()() |
VoteCalWebServiceResponse(ResponseStatus) |

See Also

VoteCalWebServiceResponse Class
VoteCalWebServiceResponse Members


VoteCalWebServiceResponse Constructor

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalWebServiceResponse Constructor
VoteCalWebServiceResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoteCalWebServiceResponse()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoteCalWebServiceResponse()

See Also

VoteCalWebServiceResponse Class
VoteCalWebServiceResponse Overload


VoteCalWebServiceResponse Constructor (ResponseStatus)

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalWebServiceResponse Constructor (ResponseStatus)
VoteCalWebServiceResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoteCalWebServiceResponse(
    ResponseStatus responseStatus
)
Visual Basic (Declaration)
Public Sub New ( _
    responseStatus As ResponseStatus _
)
Visual C++
public:
VoteCalWebServiceResponse(
    ResponseStatus responseStatus
)

Parameters

responseStatus
Type: VoteCal.Management.Web.Services.Models..::.ResponseStatus

See Also

VoteCalWebServiceResponse Class
VoteCalWebServiceResponse Overload


VoteCalWebServiceResponse Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoteCalWebServiceResponse Properties
VoteCalWebServiceResponse Class See Also Send Feedback

The VoteCalWebServiceResponse type exposes the following members.

Properties

Name | Description
ResponseStatus |

See Also

VoteCalWebServiceResponse Class


ResponseStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
VoteCalWebServiceResponse..::.ResponseStatus Property
VoteCalWebServiceResponse Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public ResponseStatus ResponseStatus { get; set; }
Visual Basic (Declaration)
Public Property ResponseStatus As ResponseStatus
Visual C++
public:
property ResponseStatus ResponseStatus {
    ResponseStatus get ();
    void set (ResponseStatus value);
}

See Also

VoteCalWebServiceResponse Class


Voter Class

[image]

VoteCal EMS Vendor Integration API Reference
Voter Class
Members See Also Send Feedback
Represents a VoteCal State Voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class Voter
Visual Basic (Declaration)
Public Class Voter
Visual C++
public ref class Voter

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.Voter

See Also

Voter Members


Voter Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
Voter Members
Voter Class Constructors Properties See Also Send Feedback

The Voter type exposes the following members.

Constructors

Name | Description
Voter |

Properties

Name | Description
AccessibilityCode | Corresponding Database Type: Alphanumeric(1) Per Table A-28, the type of assistance this voter requires
AddressLine1 | Corresponding Database Type: Alphanumeric(40) Free Form Residential for non-standard addresses. This field should remain null for standardized addresses.
AddressLine2 | Corresponding Database Type: Alphanumeric(40) Free Form Residential for non-standard addresses. This field should remain null for standardized addresses.
AffidavitDateExecuted | Corresponding Database Type: DateTime The date this voter's affidavit was executed
AffidavitDateRecieved | Corresponding Database Type: DateTime The date this voter's affidavit was received by the local jurisdiction
AffidavitNumber | Corresponding Database Type: Alphanumeric(15) The number associated to the Registration Affidavit for this voter
AlternateName | Corresponding Database Type: Alphanumeric(60) Any alternate names maintained for this voter
City | Corresponding Database Type: Alphanumeric(25) The name of the city associated with the voter’s current residence address.
ConfidentialityAppDate | Corresponding Database Type: DateTime Date this voter was assigned a confidential status
ConfidentialityCode | Corresponding Database Type: Alphanumeric(1) 'Y’ if this voter is authorized as a confidential voter, else ‘N’.
CountyVoterIdPrimaryKey | Corresponding Database Type: Alphanumeric(64) The County EMS database primary key for a voter
DateOfBirth | Corresponding Database Type: DateTime Date of birth for this voter
DLVerificationDate | Corresponding Database Type: DateTime The date this registrant’s drivers license was verified
DLVerificationStatus | Corresponding Database Type: Alphanumeric(1) Y = Verified N = Not Verified P = Pending Verification
DriversLicense | Corresponding Database Type: Alphanumeric(15) This registrant’s drivers license or State-issued ID number, if available.
Email | Corresponding Database Type: Alphanumeric(60) This voter’s primary email address (if available).
FirstName | Corresponding Database Type: Alphanumeric(25) First name of this voter
Gender | Corresponding Database Type: Alphanumeric(1) Per Table A-8 (M, F)
HouseFractionNumber | Corresponding Database Type: Alphanumeric(4) A fractional value associated to this registrant’s residential address. Example:123 ½ Main St
HouseNumber | Corresponding Database Type: Alphanumeric(9) The building number associated with the voter's current residence, not to be confused with the number of the street. For non-standard addresses, these parsed field values should be null.
HouseNumberSuffix | Corresponding Database Type: Alphanumeric(4) A suffix, such as “A” associated to this registrant’s residential address. Example: 123 A Main St
IdRequirement | Corresponding Database Type: Alphanumeric(1) Per Table A-9, the status of ID requirements for voters who register by mail. If registration method is not by-mail, this field should remain null.
JurisdictionId | Corresponding Database Type: Alphanumeric(2) A code from Table A-1 identifying the county to which this voter belongs.
LanguageCode | Corresponding Database Type: Alphanumeric(1) Per Table A-4, the language preference of this voter
LastName | Corresponding Database Type: Alphanumeric(25) Last name of this voter
LastVoterInitiatedChangeDate | Corresponding Database Type: DateTime The date of the last Voter initiated change to their record
MailAddressLine1 | Corresponding Database Type: Alphanumeric(40) Free form mailing. Use only if mailing address is different than the residential address
MailAddressLine2 | Corresponding Database Type: Alphanumeric(40) Free form mailing. Use only if mailing address is different than the residential address.
MailCity | Corresponding Database Type: Alphanumeric(60) If domestic: The city name of the voter’s current mailing address. If foreign: include city, nation, and postal code in this field. (Optional – use only if mailing address is different then residence address.)
MailState | Corresponding Database Type: Alphanumeric(2) Per Table A-11, the USPS state code associated to this voter’s mailing address (if domestic).
MailZip4 | Corresponding Database Type: Alphanumeric(4) The four-digit zip+4 value assigned to this voter’s mailing address (if domestic).
MailZipCode | Corresponding Database Type: Alphanumeric(5) The five-digit zip code associated to this voter’s mailing address (if domestic).
MiddleName | Corresponding Database Type: Alphanumeric(25) Middle name or initial of this voter
NameSuffix | Corresponding Database Type: Alphanumeric(4) Per Table A-10, the name suffix associated to this registrant. If no suffix is specified, this field remains null.
PartyCode | Corresponding Database Type: Alphanumeric(3) Per Table A-6, the partisan preference of this voter
PlaceOfBirthCode | Corresponding Database Type: Alphanumeric(2) Per Table A-5, the place of birth for this voter (if available).
PlaceOfBirthText | Corresponding Database Type: Alphanumeric(25) If no entry in Table A-5 matches this registrant’s information, a free-form place of birth.
PostDirection | Corresponding Database Type: Alphanumeric(2) Per Table A-12, the post-directional value assigned to this voter’s residential address.
PrecinctPart | Corresponding Database Type: Alphanumeric(10) Precinct Number and Precinct Part, separated by a period as defined in the Precinct Detail View (example: 99999.02)
PreDirection | Corresponding Database Type: Alphanumeric(2) Per Table A-12, the pre-directional value assigned to this voter’s residential address.
RegistrationDate | Corresponding Database Type: DateTime The effective date of this voter's registration
RegistrationMethod | Corresponding Database Type: Alphanumeric(1) Per Table A-3, the method of registration (Counter, Mail, etc)
RegistrationSource | Corresponding Database Type: Alphanumeric(3) Per Table A-2, this voter's source of registration (DMV, Other Agency, etc)
SignatureImage | BASE64 encoded tiff image
Ssn4 | Corresponding Database Type: Alphanumeric(4) Last four digits of SSN (if available)
SSNVerificationDate | Corresponding Database Type: DateTime The date this registrant’s Social Security Number was verified
SsnVerificationStatus | Corresponding Database Type: Alphanumeric(1) Y = Verified N = Not Verified P = Pending Verification
State | Corresponding Database Type: Alphanumeric(2) The USPS state code for the voter’s current residence address. This will typically be “CA” for voter data stored in County VR Systems. If outside of California, this field must conform to the State codes provided in Table A-11
StateVoterIdPrimaryKey | Corresponding Database Type: Guid The State VoteCal database primary key for a voter
StreetName | Corresponding Database Type: Alphanumeric(30) The name (or number) of the street associated with the voter's current residence address.
StreetType | Corresponding Database Type: Alphanumeric(4) Per Table A-13, the street type associated to this voter’s residential address (ST, DR, etc)
Telephone | Corresponding Database Type: Alphanumeric(14) The 10-digit primary telephone number associated to this voter immediately followed by up to 4-digit extension (if any). Use no parenthesis, dashes, or special characters. Example: 91655533441111
Uid |
Unitnumber | Corresponding Database Type: Alphanumeric(10) The alphanumeric representation of the unit number associated with the voter’s current residence building number.
UnitType | Corresponding Database Type: Alphanumeric(4) Per Table A-30, the type of unit located within a multi-residential community such as, Apartment, Building, Lot, etc.
UOCAVACode | Corresponding Database Type: Alphanumeric(1) Per Table A-29, the UOCAVA category applicable to this registrant, or null
VoterMessages | VoteCal Messages pertaining to this voter
VoterStatus | Corresponding Database Type: Alphanumeric(1) Per Table A-26, the status of this voter
VoterStatusReason | Corresponding Database Type: Alphanumeric(5) If a non-active status, the reason associated to this registrant’s status per Table A-27. Status reasons for Active voters are optional.
VoterWorkItems | VoteCal work items pertaining to this voter
ZipCode | Corresponding Database Type: Alphanumeric(5) The five-digit zip code for the voter's current address.
ZipCode4 | Corresponding Database Type: Alphanumeric(4) The four-digit zip+4 code for the voter's current address.

See Also

Voter Class


Voter Constructor

[image]

VoteCal EMS Vendor Integration API Reference
Voter Constructor
Voter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Voter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Voter()

See Also

Voter Class


Voter Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
Voter Properties
Voter Class See Also Send Feedback

The Voter type exposes the following members.

Properties

Name | Description
AccessibilityCode | Corresponding Database Type: Alphanumeric(1) Per Table A-28, the type of assistance this voter requires
AddressLine1 | Corresponding Database Type: Alphanumeric(40) Free Form Residential for non-standard addresses. This field should remain null for standardized addresses.
AddressLine2 | Corresponding Database Type: Alphanumeric(40) Free Form Residential for non-standard addresses. This field should remain null for standardized addresses.
AffidavitDateExecuted | Corresponding Database Type: DateTime The date this voter's affidavit was executed
AffidavitDateRecieved | Corresponding Database Type: DateTime The date this voter's affidavit was received by the local jurisdiction
AffidavitNumber | Corresponding Database Type: Alphanumeric(15) The number associated to the Registration Affidavit for this voter
AlternateName | Corresponding Database Type: Alphanumeric(60) Any alternate names maintained for this voter
City | Corresponding Database Type: Alphanumeric(25) The name of the city associated with the voter’s current residence address.
ConfidentialityAppDate | Corresponding Database Type: DateTime Date this voter was assigned a confidential status
ConfidentialityCode | Corresponding Database Type: Alphanumeric(1) 'Y’ if this voter is authorized as a confidential voter, else ‘N’.
CountyVoterIdPrimaryKey | Corresponding Database Type: Alphanumeric(64) The County EMS database primary key for a voter
DateOfBirth | Corresponding Database Type: DateTime Date of birth for this voter
DLVerificationDate | Corresponding Database Type: DateTime The date this registrant’s drivers license was verified
DLVerificationStatus | Corresponding Database Type: Alphanumeric(1) Y = Verified N = Not Verified P = Pending Verification
DriversLicense | Corresponding Database Type: Alphanumeric(15) This registrant’s drivers license or State-issued ID number, if available.
Email | Corresponding Database Type: Alphanumeric(60) This voter’s primary email address (if available).
FirstName | Corresponding Database Type: Alphanumeric(25) First name of this voter
Gender | Corresponding Database Type: Alphanumeric(1) Per Table A-8 (M, F)
HouseFractionNumber | Corresponding Database Type: Alphanumeric(4) A fractional value associated to this registrant’s residential address. Example:123 ½ Main St
HouseNumber | Corresponding Database Type: Alphanumeric(9) The building number associated with the voter's current residence, not to be confused with the number of the street. For non-standard addresses, these parsed field values should be null.
HouseNumberSuffix | Corresponding Database Type: Alphanumeric(4) A suffix, such as “A” associated to this registrant’s residential address. Example: 123 A Main St
IdRequirement | Corresponding Database Type: Alphanumeric(1) Per Table A-9, the status of ID requirements for voters who register by mail. If registration method is not by-mail, this field should remain null.
JurisdictionId | Corresponding Database Type: Alphanumeric(2) A code from Table A-1 identifying the county to which this voter belongs.
LanguageCode | Corresponding Database Type: Alphanumeric(1) Per Table A-4, the language preference of this voter
LastName | Corresponding Database Type: Alphanumeric(25) Last name of this voter
LastVoterInitiatedChangeDate | Corresponding Database Type: DateTime The date of the last Voter initiated change to their record
MailAddressLine1 | Corresponding Database Type: Alphanumeric(40) Free form mailing. Use only if mailing address is different than the residential address
MailAddressLine2 | Corresponding Database Type: Alphanumeric(40) Free form mailing. Use only if mailing address is different than the residential address.
MailCity | Corresponding Database Type: Alphanumeric(60) If domestic: The city name of the voter’s current mailing address. If foreign: include city, nation, and postal code in this field. (Optional – use only if mailing address is different then residence address.)
MailState | Corresponding Database Type: Alphanumeric(2) Per Table A-11, the USPS state code associated to this voter’s mailing address (if domestic).
MailZip4 | Corresponding Database Type: Alphanumeric(4) The four-digit zip+4 value assigned to this voter’s mailing address (if domestic).
MailZipCode | Corresponding Database Type: Alphanumeric(5) The five-digit zip code associated to this voter’s mailing address (if domestic).
MiddleName | Corresponding Database Type: Alphanumeric(25) Middle name or initial of this voter
NameSuffix | Corresponding Database Type: Alphanumeric(4) Per Table A-10, the name suffix associated to this registrant. If no suffix is specified, this field remains null.
PartyCode | Corresponding Database Type: Alphanumeric(3) Per Table A-6, the partisan preference of this voter
PlaceOfBirthCode | Corresponding Database Type: Alphanumeric(2) Per Table A-5, the place of birth for this voter (if available).
PlaceOfBirthText | Corresponding Database Type: Alphanumeric(25) If no entry in Table A-5 matches this registrant’s information, a free-form place of birth.
PostDirection | Corresponding Database Type: Alphanumeric(2) Per Table A-12, the post-directional value assigned to this voter’s residential address.
PrecinctPart | Corresponding Database Type: Alphanumeric(10) Precinct Number and Precinct Part, separated by a period as defined in the Precinct Detail View (example: 99999.02)
PreDirection | Corresponding Database Type: Alphanumeric(2) Per Table A-12, the pre-directional value assigned to this voter’s residential address.
RegistrationDate | Corresponding Database Type: DateTime The effective date of this voter's registration
RegistrationMethod | Corresponding Database Type: Alphanumeric(1) Per Table A-3, the method of registration (Counter, Mail, etc)
RegistrationSource | Corresponding Database Type: Alphanumeric(3) Per Table A-2, this voter's source of registration (DMV, Other Agency, etc)
SignatureImage | BASE64 encoded tiff image
Ssn4 | Corresponding Database Type: Alphanumeric(4) Last four digits of SSN (if available)
SSNVerificationDate | Corresponding Database Type: DateTime The date this registrant’s Social Security Number was verified
SsnVerificationStatus | Corresponding Database Type: Alphanumeric(1) Y = Verified N = Not Verified P = Pending Verification
State | Corresponding Database Type: Alphanumeric(2) The USPS state code for the voter’s current residence address. This will typically be “CA” for voter data stored in County VR Systems. If outside of California, this field must conform to the State codes provided in Table A-11
StateVoterIdPrimaryKey | Corresponding Database Type: Guid The State VoteCal database primary key for a voter
StreetName | Corresponding Database Type: Alphanumeric(30) The name (or number) of the street associated with the voter's current residence address.
StreetType | Corresponding Database Type: Alphanumeric(4) Per Table A-13, the street type associated to this voter’s residential address (ST, DR, etc)
Telephone | Corresponding Database Type: Alphanumeric(14) The 10-digit primary telephone number associated to this voter immediately followed by up to 4-digit extension (if any). Use no parenthesis, dashes, or special characters. Example: 91655533441111
Uid |
Unitnumber | Corresponding Database Type: Alphanumeric(10) The alphanumeric representation of the unit number associated with the voter’s current residence building number.
UnitType | Corresponding Database Type: Alphanumeric(4) Per Table A-30, the type of unit located within a multi-residential community such as, Apartment, Building, Lot, etc.
UOCAVACode | Corresponding Database Type: Alphanumeric(1) Per Table A-29, the UOCAVA category applicable to this registrant, or null
VoterMessages | VoteCal Messages pertaining to this voter
VoterStatus | Corresponding Database Type: Alphanumeric(1) Per Table A-26, the status of this voter
VoterStatusReason | Corresponding Database Type: Alphanumeric(5) If a non-active status, the reason associated to this registrant’s status per Table A-27. Status reasons for Active voters are optional.
VoterWorkItems | VoteCal work items pertaining to this voter
ZipCode | Corresponding Database Type: Alphanumeric(5) The five-digit zip code for the voter's current address.
ZipCode4 | Corresponding Database Type: Alphanumeric(4) The four-digit zip+4 code for the voter's current address.

See Also

Voter Class


AccessibilityCode Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.AccessibilityCode Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

Per Table A-28, the type of assistance this voter requires

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AccessibilityCode { get; set; }
Visual Basic (Declaration)
Public Property AccessibilityCode As String
Visual C++
public:
property String^ AccessibilityCode {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


AddressLine1 Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.AddressLine1 Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(40)

Free Form Residential for non-standard addresses. This field should remain null for standardized addresses.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AddressLine1 { get; set; }
Visual Basic (Declaration)
Public Property AddressLine1 As String
Visual C++
public:
property String^ AddressLine1 {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


AddressLine2 Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.AddressLine2 Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(40)

Free Form Residential for non-standard addresses. This field should remain null for standardized addresses.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AddressLine2 { get; set; }
Visual Basic (Declaration)
Public Property AddressLine2 As String
Visual C++
public:
property String^ AddressLine2 {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


AffidavitDateExecuted Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.AffidavitDateExecuted Property
Voter Class See Also Send Feedback

Corresponding Database Type: DateTime

The date this voter's affidavit was executed

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime AffidavitDateExecuted { get; set; }
Visual Basic (Declaration)
Public Property AffidavitDateExecuted As DateTime
Visual C++
public:
property DateTime AffidavitDateExecuted {
    DateTime get ();
    void set (DateTime value);
}

See Also

Voter Class


AffidavitDateRecieved Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.AffidavitDateRecieved Property
Voter Class See Also Send Feedback

Corresponding Database Type: DateTime

The date this voter's affidavit was received by the local jurisdiction

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime AffidavitDateRecieved { get; set; }
Visual Basic (Declaration)
Public Property AffidavitDateRecieved As DateTime
Visual C++
public:
property DateTime AffidavitDateRecieved {
    DateTime get ();
    void set (DateTime value);
}

See Also

Voter Class


AffidavitNumber Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.AffidavitNumber Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(15)

The number associated to the Registration Affidavit for this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AffidavitNumber { get; set; }
Visual Basic (Declaration)
Public Property AffidavitNumber As String
Visual C++
public:
property String^ AffidavitNumber {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


AlternateName Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.AlternateName Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(60)

Any alternate names maintained for this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AlternateName { get; set; }
Visual Basic (Declaration)
Public Property AlternateName As String
Visual C++
public:
property String^ AlternateName {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


City Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.City Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(25)

The name of the city associated with the voter’s current residence address.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string City { get; set; }
Visual Basic (Declaration)
Public Property City As String
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


ConfidentialityAppDate Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.ConfidentialityAppDate Property
Voter Class See Also Send Feedback

Corresponding Database Type: DateTime

Date this voter was assigned a confidential status

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime ConfidentialityAppDate { get; set; }
Visual Basic (Declaration)
Public Property ConfidentialityAppDate As DateTime
Visual C++
public:
property DateTime ConfidentialityAppDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Voter Class


ConfidentialityCode Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.ConfidentialityCode Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

'Y’ if this voter is authorized as a confidential voter, else ‘N’.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ConfidentialityCode { get; set; }
Visual Basic (Declaration)
Public Property ConfidentialityCode As String
Visual C++
public:
property String^ ConfidentialityCode {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


CountyVoterIdPrimaryKey Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.CountyVoterIdPrimaryKey Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(64)

The County EMS database primary key for a voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string CountyVoterIdPrimaryKey { get; set; }
Visual Basic (Declaration)
Public Property CountyVoterIdPrimaryKey As String
Visual C++
public:
property String^ CountyVoterIdPrimaryKey {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


DateOfBirth Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.DateOfBirth Property
Voter Class See Also Send Feedback

Corresponding Database Type: DateTime

Date of birth for this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime DateOfBirth { get; set; }
Visual Basic (Declaration)
Public Property DateOfBirth As DateTime
Visual C++
public:
property DateTime DateOfBirth {
    DateTime get ();
    void set (DateTime value);
}

See Also

Voter Class


DLVerificationDate Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.DLVerificationDate Property
Voter Class See Also Send Feedback

Corresponding Database Type: DateTime

The date this registrant’s drivers license was verified

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime DLVerificationDate { get; set; }
Visual Basic (Declaration)
Public Property DLVerificationDate As DateTime
Visual C++
public:
property DateTime DLVerificationDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Voter Class


DLVerificationStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.DLVerificationStatus Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

Y = Verified

N = Not Verified

P = Pending Verification

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DLVerificationStatus { get; set; }
Visual Basic (Declaration)
Public Property DLVerificationStatus As String
Visual C++
public:
property String^ DLVerificationStatus {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


DriversLicense Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.DriversLicense Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(15)

This registrant’s drivers license or State-issued ID number, if available.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DriversLicense { get; set; }
Visual Basic (Declaration)
Public Property DriversLicense As String
Visual C++
public:
property String^ DriversLicense {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


Email Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.Email Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(60)

This voter’s primary email address (if available).

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Email { get; set; }
Visual Basic (Declaration)
Public Property Email As String
Visual C++
public:
property String^ Email {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


FirstName Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.FirstName Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(25)

First name of this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


Gender Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.Gender Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

Per Table A-8 (M, F)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Gender { get; set; }
Visual Basic (Declaration)
Public Property Gender As String
Visual C++
public:
property String^ Gender {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


HouseFractionNumber Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.HouseFractionNumber Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(4)

A fractional value associated to this registrant’s residential address. Example:123 ½ Main St

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string HouseFractionNumber { get; set; }
Visual Basic (Declaration)
Public Property HouseFractionNumber As String
Visual C++
public:
property String^ HouseFractionNumber {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


HouseNumber Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.HouseNumber Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(9)

The building number associated with the voter's current residence, not to be confused with the number of the street. For non-standard addresses, these parsed field values should be null.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string HouseNumber { get; set; }
Visual Basic (Declaration)
Public Property HouseNumber As String
Visual C++
public:
property String^ HouseNumber {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


HouseNumberSuffix Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.HouseNumberSuffix Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(4)

A suffix, such as “A” associated to this registrant’s residential address. Example: 123 A Main St

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string HouseNumberSuffix { get; set; }
Visual Basic (Declaration)
Public Property HouseNumberSuffix As String
Visual C++
public:
property String^ HouseNumberSuffix {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


IdRequirement Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.IdRequirement Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

Per Table A-9, the status of ID requirements for voters who register by mail. If registration method is not by-mail, this field should remain null.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string IdRequirement { get; set; }
Visual Basic (Declaration)
Public Property IdRequirement As String
Visual C++
public:
property String^ IdRequirement {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


JurisdictionId Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.JurisdictionId Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(2)

A code from Table A-1 identifying the county to which this voter belongs.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int JurisdictionId { get; set; }
Visual Basic (Declaration)
Public Property JurisdictionId As Integer
Visual C++
public:
property int JurisdictionId {
    int get ();
    void set (int value);
}

See Also

Voter Class


LanguageCode Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.LanguageCode Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

Per Table A-4, the language preference of this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LanguageCode { get; set; }
Visual Basic (Declaration)
Public Property LanguageCode As String
Visual C++
public:
property String^ LanguageCode {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


LastName Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.LastName Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(25)

Last name of this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


LastVoterInitiatedChangeDate Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.LastVoterInitiatedChangeDate Property
Voter Class See Also Send Feedback

Corresponding Database Type: DateTime

The date of the last Voter initiated change to their record

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime LastVoterInitiatedChangeDate { get; set; }
Visual Basic (Declaration)
Public Property LastVoterInitiatedChangeDate As DateTime
Visual C++
public:
property DateTime LastVoterInitiatedChangeDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Voter Class


MailAddressLine1 Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.MailAddressLine1 Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(40)

Free form mailing. Use only if mailing address is different than the residential address

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MailAddressLine1 { get; set; }
Visual Basic (Declaration)
Public Property MailAddressLine1 As String
Visual C++
public:
property String^ MailAddressLine1 {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


MailAddressLine2 Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.MailAddressLine2 Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(40)

Free form mailing. Use only if mailing address is different than the residential address.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MailAddressLine2 { get; set; }
Visual Basic (Declaration)
Public Property MailAddressLine2 As String
Visual C++
public:
property String^ MailAddressLine2 {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


MailCity Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.MailCity Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(60)

If domestic: The city name of the voter’s current mailing address. If foreign: include city, nation, and postal code in this field. (Optional – use only if mailing address is different then residence address.)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MailCity { get; set; }
Visual Basic (Declaration)
Public Property MailCity As String
Visual C++
public:
property String^ MailCity {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


MailState Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.MailState Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(2)

Per Table A-11, the USPS state code associated to this voter’s mailing address (if domestic).

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MailState { get; set; }
Visual Basic (Declaration)
Public Property MailState As String
Visual C++
public:
property String^ MailState {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


MailZip4 Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.MailZip4 Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(4)

The four-digit zip+4 value assigned to this voter’s mailing address (if domestic).

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MailZip4 { get; set; }
Visual Basic (Declaration)
Public Property MailZip4 As String
Visual C++
public:
property String^ MailZip4 {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


MailZipCode Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.MailZipCode Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(5)

The five-digit zip code associated to this voter’s mailing address (if domestic).

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MailZipCode { get; set; }
Visual Basic (Declaration)
Public Property MailZipCode As String
Visual C++
public:
property String^ MailZipCode {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


MiddleName Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.MiddleName Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(25)

Middle name or initial of this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MiddleName { get; set; }
Visual Basic (Declaration)
Public Property MiddleName As String
Visual C++
public:
property String^ MiddleName {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


NameSuffix Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.NameSuffix Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(4)

Per Table A-10, the name suffix associated to this registrant. If no suffix is specified, this field remains null.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string NameSuffix { get; set; }
Visual Basic (Declaration)
Public Property NameSuffix As String
Visual C++
public:
property String^ NameSuffix {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


PartyCode Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.PartyCode Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(3)

Per Table A-6, the partisan preference of this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PartyCode { get; set; }
Visual Basic (Declaration)
Public Property PartyCode As String
Visual C++
public:
property String^ PartyCode {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


PlaceOfBirthCode Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.PlaceOfBirthCode Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(2)

Per Table A-5, the place of birth for this voter (if available).

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PlaceOfBirthCode { get; set; }
Visual Basic (Declaration)
Public Property PlaceOfBirthCode As String
Visual C++
public:
property String^ PlaceOfBirthCode {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


PlaceOfBirthText Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.PlaceOfBirthText Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(25)

If no entry in Table A-5 matches this registrant’s information, a free-form place of birth.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PlaceOfBirthText { get; set; }
Visual Basic (Declaration)
Public Property PlaceOfBirthText As String
Visual C++
public:
property String^ PlaceOfBirthText {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


PostDirection Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.PostDirection Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(2)

Per Table A-12, the post-directional value assigned to this voter’s residential address.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PostDirection { get; set; }
Visual Basic (Declaration)
Public Property PostDirection As String
Visual C++
public:
property String^ PostDirection {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


PrecinctPart Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.PrecinctPart Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(10)

Precinct Number and Precinct Part, separated by a period as defined in the Precinct Detail View (example: 99999.02)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PrecinctPart { get; set; }
Visual Basic (Declaration)
Public Property PrecinctPart As String
Visual C++
public:
property String^ PrecinctPart {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


PreDirection Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.PreDirection Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(2)

Per Table A-12, the pre-directional value assigned to this voter’s residential address.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string PreDirection { get; set; }
Visual Basic (Declaration)
Public Property PreDirection As String
Visual C++
public:
property String^ PreDirection {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


RegistrationDate Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.RegistrationDate Property
Voter Class See Also Send Feedback

Corresponding Database Type: DateTime

The effective date of this voter's registration

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime RegistrationDate { get; set; }
Visual Basic (Declaration)
Public Property RegistrationDate As DateTime
Visual C++
public:
property DateTime RegistrationDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Voter Class


RegistrationMethod Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.RegistrationMethod Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

Per Table A-3, the method of registration (Counter, Mail, etc)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string RegistrationMethod { get; set; }
Visual Basic (Declaration)
Public Property RegistrationMethod As String
Visual C++
public:
property String^ RegistrationMethod {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


RegistrationSource Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.RegistrationSource Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(3)

Per Table A-2, this voter's source of registration (DMV, Other Agency, etc)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string RegistrationSource { get; set; }
Visual Basic (Declaration)
Public Property RegistrationSource As String
Visual C++
public:
property String^ RegistrationSource {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


SignatureImage Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.SignatureImage Property
Voter Class See Also Send Feedback
BASE64 encoded tiff image

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SignatureImage { get; set; }
Visual Basic (Declaration)
Public Property SignatureImage As String
Visual C++
public:
property String^ SignatureImage {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


Ssn4 Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.Ssn4 Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(4)

Last four digits of SSN (if available)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Ssn4 { get; set; }
Visual Basic (Declaration)
Public Property Ssn4 As String
Visual C++
public:
property String^ Ssn4 {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


SSNVerificationDate Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.SSNVerificationDate Property
Voter Class See Also Send Feedback

Corresponding Database Type: DateTime

The date this registrant’s Social Security Number was verified

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime SSNVerificationDate { get; set; }
Visual Basic (Declaration)
Public Property SSNVerificationDate As DateTime
Visual C++
public:
property DateTime SSNVerificationDate {
    DateTime get ();
    void set (DateTime value);
}

See Also

Voter Class


SsnVerificationStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.SsnVerificationStatus Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

Y = Verified

N = Not Verified

P = Pending Verification

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string SsnVerificationStatus { get; set; }
Visual Basic (Declaration)
Public Property SsnVerificationStatus As String
Visual C++
public:
property String^ SsnVerificationStatus {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


State Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.State Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(2)

The USPS state code for the voter’s current residence address. This will typically be “CA” for voter data stored in County VR Systems. If outside of California, this field must conform to the State codes provided in Table A-11

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string State { get; set; }
Visual Basic (Declaration)
Public Property State As String
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


StateVoterIdPrimaryKey Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.StateVoterIdPrimaryKey Property
Voter Class See Also Send Feedback

Corresponding Database Type: Guid

The State VoteCal database primary key for a voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid StateVoterIdPrimaryKey { get; set; }
Visual Basic (Declaration)
Public Property StateVoterIdPrimaryKey As Guid
Visual C++
public:
property Guid StateVoterIdPrimaryKey {
    Guid get ();
    void set (Guid value);
}

See Also

Voter Class


StreetName Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.StreetName Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(30)

The name (or number) of the street associated with the voter's current residence address.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string StreetName { get; set; }
Visual Basic (Declaration)
Public Property StreetName As String
Visual C++
public:
property String^ StreetName {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


StreetType Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.StreetType Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(4)

Per Table A-13, the street type associated to this voter’s residential address (ST, DR, etc)

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string StreetType { get; set; }
Visual Basic (Declaration)
Public Property StreetType As String
Visual C++
public:
property String^ StreetType {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


Telephone Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.Telephone Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(14)

The 10-digit primary telephone number associated to this voter immediately followed by up to 4-digit extension (if any). Use no parenthesis, dashes, or special characters. Example: 91655533441111

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Telephone { get; set; }
Visual Basic (Declaration)
Public Property Telephone As String
Visual C++
public:
property String^ Telephone {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


Uid Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.Uid Property
Voter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Uid { get; set; }
Visual Basic (Declaration)
Public Property Uid As String
Visual C++
public:
property String^ Uid {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


Unitnumber Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.Unitnumber Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(10)

The alphanumeric representation of the unit number associated with the voter’s current residence building number.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Unitnumber { get; set; }
Visual Basic (Declaration)
Public Property Unitnumber As String
Visual C++
public:
property String^ Unitnumber {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


UnitType Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.UnitType Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(4)

Per Table A-30, the type of unit located within a multi-residential community such as, Apartment, Building, Lot, etc.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UnitType { get; set; }
Visual Basic (Declaration)
Public Property UnitType As String
Visual C++
public:
property String^ UnitType {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


UOCAVACode Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.UOCAVACode Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

Per Table A-29, the UOCAVA category applicable to this registrant, or null

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string UOCAVACode { get; set; }
Visual Basic (Declaration)
Public Property UOCAVACode As String
Visual C++
public:
property String^ UOCAVACode {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


VoterMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.VoterMessages Property
Voter Class See Also Send Feedback
VoteCal Messages pertaining to this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoterMessages VoterMessages { get; set; }
Visual Basic (Declaration)
Public Property VoterMessages As VoterMessages
Visual C++
public:
property VoterMessages^ VoterMessages {
    VoterMessages^ get ();
    void set (VoterMessages^ value);
}

See Also

Voter Class


VoterStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.VoterStatus Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(1)

Per Table A-26, the status of this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string VoterStatus { get; set; }
Visual Basic (Declaration)
Public Property VoterStatus As String
Visual C++
public:
property String^ VoterStatus {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


VoterStatusReason Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.VoterStatusReason Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(5)

If a non-active status, the reason associated to this registrant’s status per Table A-27. Status reasons for Active voters are optional.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string VoterStatusReason { get; set; }
Visual Basic (Declaration)
Public Property VoterStatusReason As String
Visual C++
public:
property String^ VoterStatusReason {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


VoterWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.VoterWorkItems Property
Voter Class See Also Send Feedback
VoteCal work items pertaining to this voter

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoterWorkItems VoterWorkItems { get; set; }
Visual Basic (Declaration)
Public Property VoterWorkItems As VoterWorkItems
Visual C++
public:
property VoterWorkItems^ VoterWorkItems {
    VoterWorkItems^ get ();
    void set (VoterWorkItems^ value);
}

See Also

Voter Class


ZipCode Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.ZipCode Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(5)

The five-digit zip code for the voter's current address.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ZipCode { get; set; }
Visual Basic (Declaration)
Public Property ZipCode As String
Visual C++
public:
property String^ ZipCode {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


ZipCode4 Property

[image]

VoteCal EMS Vendor Integration API Reference
Voter..::.ZipCode4 Property
Voter Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(4)

The four-digit zip+4 code for the voter's current address.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ZipCode4 { get; set; }
Visual Basic (Declaration)
Public Property ZipCode4 As String
Visual C++
public:
property String^ ZipCode4 {
    String^ get ();
    void set (String^ value);
}

See Also

Voter Class


VoterIdentificationMatchType Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdentificationMatchType Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum VoterIdentificationMatchType
Visual Basic (Declaration)
Public Enumeration VoterIdentificationMatchType
Visual C++
public enum class VoterIdentificationMatchType

Members

Member name | Description
NoMatchDL |
MatchDL |
AlternateDLSuggested |
MatchSSN |
NoMatchSSN |
MatchSSNDeceased |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


VoterIdInfo Class

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class VoterIdInfo
Visual Basic (Declaration)
Public Class VoterIdInfo
Visual C++
public ref class VoterIdInfo

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoterIdInfo

See Also

VoterIdInfo Members


VoterIdInfo Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo Members
VoterIdInfo Class Constructors Properties See Also Send Feedback

The VoterIdInfo type exposes the following members.

Constructors

Name | Description
VoterIdInfo |

Properties

Name | Description
AddressLine1 |
AddressLine2 |
City |
DateOfBirth |
DriversLicense | Corresponding Database Type: Alphanumeric(15) This registrant’s drivers license or State-issued ID number, if available.
FirstName |
LastName |
MiddleName |
Ssn4 |
State |
ZipCode |

See Also

VoterIdInfo Class


VoterIdInfo Constructor

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo Constructor
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoterIdInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoterIdInfo()

See Also

VoterIdInfo Class


VoterIdInfo Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo Properties
VoterIdInfo Class See Also Send Feedback

The VoterIdInfo type exposes the following members.

Properties

Name | Description
AddressLine1 |
AddressLine2 |
City |
DateOfBirth |
DriversLicense | Corresponding Database Type: Alphanumeric(15) This registrant’s drivers license or State-issued ID number, if available.
FirstName |
LastName |
MiddleName |
Ssn4 |
State |
ZipCode |

See Also

VoterIdInfo Class


AddressLine1 Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.AddressLine1 Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AddressLine1 { get; set; }
Visual Basic (Declaration)
Public Property AddressLine1 As String
Visual C++
public:
property String^ AddressLine1 {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


AddressLine2 Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.AddressLine2 Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string AddressLine2 { get; set; }
Visual Basic (Declaration)
Public Property AddressLine2 As String
Visual C++
public:
property String^ AddressLine2 {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


City Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.City Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string City { get; set; }
Visual Basic (Declaration)
Public Property City As String
Visual C++
public:
property String^ City {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


DateOfBirth Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.DateOfBirth Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DateTime DateOfBirth { get; set; }
Visual Basic (Declaration)
Public Property DateOfBirth As DateTime
Visual C++
public:
property DateTime DateOfBirth {
    DateTime get ();
    void set (DateTime value);
}

See Also

VoterIdInfo Class


DriversLicense Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.DriversLicense Property
VoterIdInfo Class See Also Send Feedback

Corresponding Database Type: Alphanumeric(15)

This registrant’s drivers license or State-issued ID number, if available.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string DriversLicense { get; set; }
Visual Basic (Declaration)
Public Property DriversLicense As String
Visual C++
public:
property String^ DriversLicense {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


FirstName Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.FirstName Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string FirstName { get; set; }
Visual Basic (Declaration)
Public Property FirstName As String
Visual C++
public:
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


LastName Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.LastName Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string LastName { get; set; }
Visual Basic (Declaration)
Public Property LastName As String
Visual C++
public:
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


MiddleName Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.MiddleName Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string MiddleName { get; set; }
Visual Basic (Declaration)
Public Property MiddleName As String
Visual C++
public:
property String^ MiddleName {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


Ssn4 Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.Ssn4 Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string Ssn4 { get; set; }
Visual Basic (Declaration)
Public Property Ssn4 As String
Visual C++
public:
property String^ Ssn4 {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


State Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.State Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string State { get; set; }
Visual Basic (Declaration)
Public Property State As String
Visual C++
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


ZipCode Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterIdInfo..::.ZipCode Property
VoterIdInfo Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public string ZipCode { get; set; }
Visual Basic (Declaration)
Public Property ZipCode As String
Visual C++
public:
property String^ ZipCode {
    String^ get ();
    void set (String^ value);
}

See Also

VoterIdInfo Class


VoterMessages Class

[image]

VoteCal EMS Vendor Integration API Reference
VoterMessages Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class VoterMessages
Visual Basic (Declaration)
Public Class VoterMessages
Visual C++
public ref class VoterMessages

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoterMessages

See Also

VoterMessages Members


VoterMessages Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoterMessages Members
VoterMessages Class Constructors Properties See Also Send Feedback

The VoterMessages type exposes the following members.

Constructors

Name | Description
VoterMessages |

Properties

Name | Description
DMVChangeOfAddressRecordReceivedMessages |
NationalChangeOfAddressRecordReceivedMessages |
NewVoterReceivedMessages |
StateVoterActivityCreatedMessages |
StateVoterStatusUpdatedMessages |
StateVoterUpdatedMessages |

See Also

VoterMessages Class


VoterMessages Constructor

[image]

VoteCal EMS Vendor Integration API Reference
VoterMessages Constructor
VoterMessages Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoterMessages()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoterMessages()

See Also

VoterMessages Class


VoterMessages Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoterMessages Properties
VoterMessages Class See Also Send Feedback

The VoterMessages type exposes the following members.

Properties

Name | Description
DMVChangeOfAddressRecordReceivedMessages |
NationalChangeOfAddressRecordReceivedMessages |
NewVoterReceivedMessages |
StateVoterActivityCreatedMessages |
StateVoterStatusUpdatedMessages |
StateVoterUpdatedMessages |

See Also

VoterMessages Class


DMVChangeOfAddressRecordReceivedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterMessages..::.DMVChangeOfAddressRecordReceivedMessages Property
VoterMessages Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordReceivedMessage[] DMVChangeOfAddressRecordReceivedMessages { get; set; }
Visual Basic (Declaration)
Public Property DMVChangeOfAddressRecordReceivedMessages As DMVChangeOfAddressRecordReceivedMessage()
Visual C++
public:
property array<DMVChangeOfAddressRecordReceivedMessage^>^ DMVChangeOfAddressRecordReceivedMessages {
    array<DMVChangeOfAddressRecordReceivedMessage^>^ get ();
    void set (array<DMVChangeOfAddressRecordReceivedMessage^>^ value);
}

See Also

VoterMessages Class


NationalChangeOfAddressRecordReceivedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterMessages..::.NationalChangeOfAddressRecordReceivedMessages Property
VoterMessages Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordReceivedMessage[] NationalChangeOfAddressRecordReceivedMessages { get; set; }
Visual Basic (Declaration)
Public Property NationalChangeOfAddressRecordReceivedMessages As NationalChangeOfAddressRecordReceivedMessage()
Visual C++
public:
property array<NationalChangeOfAddressRecordReceivedMessage^>^ NationalChangeOfAddressRecordReceivedMessages {
    array<NationalChangeOfAddressRecordReceivedMessage^>^ get ();
    void set (array<NationalChangeOfAddressRecordReceivedMessage^>^ value);
}

See Also

VoterMessages Class


NewVoterReceivedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterMessages..::.NewVoterReceivedMessages Property
VoterMessages Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NewVoterReceivedMessage[] NewVoterReceivedMessages { get; set; }
Visual Basic (Declaration)
Public Property NewVoterReceivedMessages As NewVoterReceivedMessage()
Visual C++
public:
property array<NewVoterReceivedMessage^>^ NewVoterReceivedMessages {
    array<NewVoterReceivedMessage^>^ get ();
    void set (array<NewVoterReceivedMessage^>^ value);
}

See Also

VoterMessages Class


StateVoterActivityCreatedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterMessages..::.StateVoterActivityCreatedMessages Property
VoterMessages Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterActivityCreatedMessage[] StateVoterActivityCreatedMessages { get; set; }
Visual Basic (Declaration)
Public Property StateVoterActivityCreatedMessages As StateVoterActivityCreatedMessage()
Visual C++
public:
property array<StateVoterActivityCreatedMessage^>^ StateVoterActivityCreatedMessages {
    array<StateVoterActivityCreatedMessage^>^ get ();
    void set (array<StateVoterActivityCreatedMessage^>^ value);
}

See Also

VoterMessages Class


StateVoterStatusUpdatedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterMessages..::.StateVoterStatusUpdatedMessages Property
VoterMessages Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterStatusUpdatedMessage[] StateVoterStatusUpdatedMessages { get; set; }
Visual Basic (Declaration)
Public Property StateVoterStatusUpdatedMessages As StateVoterStatusUpdatedMessage()
Visual C++
public:
property array<StateVoterStatusUpdatedMessage^>^ StateVoterStatusUpdatedMessages {
    array<StateVoterStatusUpdatedMessage^>^ get ();
    void set (array<StateVoterStatusUpdatedMessage^>^ value);
}

See Also

VoterMessages Class


StateVoterUpdatedMessages Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterMessages..::.StateVoterUpdatedMessages Property
VoterMessages Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public StateVoterUpdatedMessage[] StateVoterUpdatedMessages { get; set; }
Visual Basic (Declaration)
Public Property StateVoterUpdatedMessages As StateVoterUpdatedMessage()
Visual C++
public:
property array<StateVoterUpdatedMessage^>^ StateVoterUpdatedMessages {
    array<StateVoterUpdatedMessage^>^ get ();
    void set (array<StateVoterUpdatedMessage^>^ value);
}

See Also

VoterMessages Class


VoterWorkItems Class

[image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class VoterWorkItems
Visual Basic (Declaration)
Public Class VoterWorkItems
Visual C++
public ref class VoterWorkItems

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.VoterWorkItems

See Also

VoterWorkItems Members


VoterWorkItems Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems Members
VoterWorkItems Class Constructors Properties See Also Send Feedback

The VoterWorkItems type exposes the following members.

Constructors

Name | Description
VoterWorkItems |

Properties

Name | Description
DeathRecordMatchCaseWorkItems |
DMVChangeOfAddressMatchCaseWorkItems |
DuplicateVoterMatchCaseWorkItems |
FelonRecordMatchCaseWorkItems |
NationalChangeOfAddressMatchCaseWorkItems |
TransferOutWorkItems |

See Also

VoterWorkItems Class


VoterWorkItems Constructor

[image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems Constructor
VoterWorkItems Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public VoterWorkItems()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
VoterWorkItems()

See Also

VoterWorkItems Class


VoterWorkItems Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems Properties
VoterWorkItems Class See Also Send Feedback

The VoterWorkItems type exposes the following members.

Properties

Name | Description
DeathRecordMatchCaseWorkItems |
DMVChangeOfAddressMatchCaseWorkItems |
DuplicateVoterMatchCaseWorkItems |
FelonRecordMatchCaseWorkItems |
NationalChangeOfAddressMatchCaseWorkItems |
TransferOutWorkItems |

See Also

VoterWorkItems Class


DeathRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems..::.DeathRecordMatchCaseWorkItems Property
VoterWorkItems Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DeathRecordMatchCaseWorkItem[] DeathRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property DeathRecordMatchCaseWorkItems As DeathRecordMatchCaseWorkItem()
Visual C++
public:
property array<DeathRecordMatchCaseWorkItem^>^ DeathRecordMatchCaseWorkItems {
    array<DeathRecordMatchCaseWorkItem^>^ get ();
    void set (array<DeathRecordMatchCaseWorkItem^>^ value);
}

See Also

VoterWorkItems Class


DMVChangeOfAddressMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems..::.DMVChangeOfAddressMatchCaseWorkItems Property
VoterWorkItems Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DMVChangeOfAddressRecordMatchCaseWorkItem[] DMVChangeOfAddressMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property DMVChangeOfAddressMatchCaseWorkItems As DMVChangeOfAddressRecordMatchCaseWorkItem()
Visual C++
public:
property array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ DMVChangeOfAddressMatchCaseWorkItems {
    array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ get ();
    void set (array<DMVChangeOfAddressRecordMatchCaseWorkItem^>^ value);
}

See Also

VoterWorkItems Class


DuplicateVoterMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems..::.DuplicateVoterMatchCaseWorkItems Property
VoterWorkItems Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public DuplicateVoterMatchCaseWorkItem[] DuplicateVoterMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property DuplicateVoterMatchCaseWorkItems As DuplicateVoterMatchCaseWorkItem()
Visual C++
public:
property array<DuplicateVoterMatchCaseWorkItem^>^ DuplicateVoterMatchCaseWorkItems {
    array<DuplicateVoterMatchCaseWorkItem^>^ get ();
    void set (array<DuplicateVoterMatchCaseWorkItem^>^ value);
}

See Also

VoterWorkItems Class


FelonRecordMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems..::.FelonRecordMatchCaseWorkItems Property
VoterWorkItems Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public FelonRecordMatchCaseWorkItem[] FelonRecordMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property FelonRecordMatchCaseWorkItems As FelonRecordMatchCaseWorkItem()
Visual C++
public:
property array<FelonRecordMatchCaseWorkItem^>^ FelonRecordMatchCaseWorkItems {
    array<FelonRecordMatchCaseWorkItem^>^ get ();
    void set (array<FelonRecordMatchCaseWorkItem^>^ value);
}

See Also

VoterWorkItems Class


NationalChangeOfAddressMatchCaseWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems..::.NationalChangeOfAddressMatchCaseWorkItems Property
VoterWorkItems Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public NationalChangeOfAddressRecordMatchCaseWorkItem[] NationalChangeOfAddressMatchCaseWorkItems { get; set; }
Visual Basic (Declaration)
Public Property NationalChangeOfAddressMatchCaseWorkItems As NationalChangeOfAddressRecordMatchCaseWorkItem()
Visual C++
public:
property array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ NationalChangeOfAddressMatchCaseWorkItems {
    array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ get ();
    void set (array<NationalChangeOfAddressRecordMatchCaseWorkItem^>^ value);
}

See Also

VoterWorkItems Class


TransferOutWorkItems Property

[image]

VoteCal EMS Vendor Integration API Reference
VoterWorkItems..::.TransferOutWorkItems Property
VoterWorkItems Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public TransferOutWorkItem[] TransferOutWorkItems { get; set; }
Visual Basic (Declaration)
Public Property TransferOutWorkItems As TransferOutWorkItem()
Visual C++
public:
property array<TransferOutWorkItem^>^ TransferOutWorkItems {
    array<TransferOutWorkItem^>^ get ();
    void set (array<TransferOutWorkItem^>^ value);
}

See Also

VoterWorkItems Class


WorkItem Class

[image]

VoteCal EMS Vendor Integration API Reference
WorkItem Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class WorkItem
Visual Basic (Declaration)
Public Class WorkItem
Visual C++
public ref class WorkItem

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItem
VoteCal.Management.Web.Services.Models..::.DataValidationErrorWorkItem
VoteCal.Management.Web.Services.Models..::.DeathRecordMatchCaseWorkItem
VoteCal.Management.Web.Services.Models..::.DMVChangeOfAddressRecordMatchCaseWorkItem
VoteCal.Management.Web.Services.Models..::.DuplicateVoterMatchCaseWorkItem
VoteCal.Management.Web.Services.Models..::.FelonRecordMatchCaseWorkItem
VoteCal.Management.Web.Services.Models..::.NationalChangeOfAddressRecordMatchCaseWorkItem
VoteCal.Management.Web.Services.Models..::.TransferOutWorkItem

See Also

WorkItem Members


WorkItem Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
WorkItem Members
WorkItem Class Constructors Properties See Also Send Feedback

The WorkItem type exposes the following members.

Constructors

Name | Description
WorkItem | Overloaded.

Properties

Name | Description
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item.
WorkItemId |
WorkItemStatus |
WorkItemType |

See Also

WorkItem Class


WorkItem Constructor

[image] [image]

VoteCal EMS Vendor Integration API Reference
WorkItem Constructor
WorkItem Class See Also Send Feedback

Overload List

Name | Description
WorkItem()()() |
WorkItem(Guid, WorkItemType, WorkItemStatus, array<AbbreviatedVoter>[]()[]) |

See Also

WorkItem Class
WorkItem Members


WorkItem Constructor

[image]

VoteCal EMS Vendor Integration API Reference
WorkItem Constructor
WorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WorkItem()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkItem()

See Also

WorkItem Class
WorkItem Overload


WorkItem Constructor (Guid, WorkItemType, WorkItemStatus, AbbreviatedVoter[])

[image]

VoteCal EMS Vendor Integration API Reference
WorkItem Constructor (Guid, WorkItemType, WorkItemStatus, array<AbbreviatedVoter>[]()[])
WorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WorkItem(
    Guid workItemId,
    WorkItemType workItemType,
    WorkItemStatus workItemStatus,
    AbbreviatedVoter[] workItemAbbreviatedVoters
)
Visual Basic (Declaration)
Public Sub New ( _
    workItemId As Guid, _
    workItemType As WorkItemType, _
    workItemStatus As WorkItemStatus, _
    workItemAbbreviatedVoters As AbbreviatedVoter() _
)
Visual C++
public:
WorkItem(
    Guid workItemId,
    WorkItemType workItemType,
    WorkItemStatus workItemStatus,
    array<AbbreviatedVoter^>^ workItemAbbreviatedVoters
)

Parameters

workItemId
Type: System..::.Guid
workItemType
Type: VoteCal.Management.Web.Services.Models..::.WorkItemType
workItemStatus
Type: VoteCal.Management.Web.Services.Models..::.WorkItemStatus
workItemAbbreviatedVoters
Type: array< VoteCal.Management.Web.Services.Models..::.AbbreviatedVoter >[]()[]

See Also

WorkItem Class
WorkItem Overload


WorkItem Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
WorkItem Properties
WorkItem Class See Also Send Feedback

The WorkItem type exposes the following members.

Properties

Name | Description
WorkItemAbbreviatedVoters | The Voter(s) associated with this work item.
WorkItemId |
WorkItemStatus |
WorkItemType |

See Also

WorkItem Class


WorkItemAbbreviatedVoters Property

[image]

VoteCal EMS Vendor Integration API Reference
WorkItem..::.WorkItemAbbreviatedVoters Property
WorkItem Class See Also Send Feedback

The Voter(s) associated with this work item.

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public AbbreviatedVoter[] WorkItemAbbreviatedVoters { get; set; }
Visual Basic (Declaration)
Public Property WorkItemAbbreviatedVoters As AbbreviatedVoter()
Visual C++
public:
property array<AbbreviatedVoter^>^ WorkItemAbbreviatedVoters {
    array<AbbreviatedVoter^>^ get ();
    void set (array<AbbreviatedVoter^>^ value);
}

See Also

WorkItem Class


WorkItemId Property

[image]

VoteCal EMS Vendor Integration API Reference
WorkItem..::.WorkItemId Property
WorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid WorkItemId { get; set; }
Visual Basic (Declaration)
Public Property WorkItemId As Guid
Visual C++
public:
property Guid WorkItemId {
    Guid get ();
    void set (Guid value);
}

See Also

WorkItem Class


WorkItemStatus Property

[image]

VoteCal EMS Vendor Integration API Reference
WorkItem..::.WorkItemStatus Property
WorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WorkItemStatus WorkItemStatus { get; set; }
Visual Basic (Declaration)
Public Property WorkItemStatus As WorkItemStatus
Visual C++
public:
property WorkItemStatus WorkItemStatus {
    WorkItemStatus get ();
    void set (WorkItemStatus value);
}

See Also

WorkItem Class


WorkItemType Property

[image]

VoteCal EMS Vendor Integration API Reference
WorkItem..::.WorkItemType Property
WorkItem Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WorkItemType WorkItemType { get; set; }
Visual Basic (Declaration)
Public Property WorkItemType As WorkItemType
Visual C++
public:
property WorkItemType WorkItemType {
    WorkItemType get ();
    void set (WorkItemType value);
}

See Also

WorkItem Class


WorkItemListFilter Class

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemListFilter Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class WorkItemListFilter
Visual Basic (Declaration)
Public Class WorkItemListFilter
Visual C++
public ref class WorkItemListFilter

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItemListFilter

See Also

WorkItemListFilter Members


WorkItemListFilter Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
WorkItemListFilter Members
WorkItemListFilter Class Constructors Properties See Also Send Feedback

The WorkItemListFilter type exposes the following members.

Constructors

Name | Description
WorkItemListFilter |

Properties

Name | Description
CurrentPage |
ItemsPerPage |
WorkItemTypesToInclude |

See Also

WorkItemListFilter Class


WorkItemListFilter Constructor

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemListFilter Constructor
WorkItemListFilter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WorkItemListFilter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkItemListFilter()

See Also

WorkItemListFilter Class


WorkItemListFilter Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
WorkItemListFilter Properties
WorkItemListFilter Class See Also Send Feedback

The WorkItemListFilter type exposes the following members.

Properties

Name | Description
CurrentPage |
ItemsPerPage |
WorkItemTypesToInclude |

See Also

WorkItemListFilter Class


CurrentPage Property

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemListFilter..::.CurrentPage Property
WorkItemListFilter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int CurrentPage { get; set; }
Visual Basic (Declaration)
Public Property CurrentPage As Integer
Visual C++
public:
property int CurrentPage {
    int get ();
    void set (int value);
}

See Also

WorkItemListFilter Class


ItemsPerPage Property

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemListFilter..::.ItemsPerPage Property
WorkItemListFilter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public int ItemsPerPage { get; set; }
Visual Basic (Declaration)
Public Property ItemsPerPage As Integer
Visual C++
public:
property int ItemsPerPage {
    int get ();
    void set (int value);
}

See Also

WorkItemListFilter Class


WorkItemTypesToInclude Property

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemListFilter..::.WorkItemTypesToInclude Property
WorkItemListFilter Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WorkItemType[] WorkItemTypesToInclude { get; set; }
Visual Basic (Declaration)
Public Property WorkItemTypesToInclude As WorkItemType()
Visual C++
public:
property array<WorkItemType>^ WorkItemTypesToInclude {
    array<WorkItemType>^ get ();
    void set (array<WorkItemType>^ value);
}

See Also

WorkItemListFilter Class


WorkItemsResponseStatusReason Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemsResponseStatusReason Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum WorkItemsResponseStatusReason
Visual Basic (Declaration)
Public Enumeration WorkItemsResponseStatusReason
Visual C++
public enum class WorkItemsResponseStatusReason

Members

Member name | Description
None |
InvalidWorkItemsDetected |
InvalidCredentials |
Unknown |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


WorkItemStatus Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemStatus Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum WorkItemStatus
Visual Basic (Declaration)
Public Enumeration WorkItemStatus
Visual C++
public enum class WorkItemStatus

Members

Member name | Description
Open |
Closed |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


WorkItemType Enumeration

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemType Enumeration
See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public enum WorkItemType
Visual Basic (Declaration)
Public Enumeration WorkItemType
Visual C++
public enum class WorkItemType

Members

Member name | Description
DeathRecordMatchCase |
DuplicateVoterMatchCase |
FelonRecordMatchCase |
TransferOut |
DMVChangeOfAddressRecordMatchCase |
NationalChangeOfAddressRecordMatchCase |
DataValidationError |

See Also

VoteCal.Management.Web.Services.Models Namespace

Send comments on this topic to ken.miller@catconsult.com

Catalyst Consulting Group


WorkItemUpdate Class

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemUpdate Class
Members See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public class WorkItemUpdate
Visual Basic (Declaration)
Public Class WorkItemUpdate
Visual C++
public ref class WorkItemUpdate

Inheritance Hierarchy

System..::.Object
VoteCal.Management.Web.Services.Models..::.WorkItemUpdate

See Also

WorkItemUpdate Members


WorkItemUpdate Members

[image] [image]

VoteCal EMS Vendor Integration API Reference
WorkItemUpdate Members
WorkItemUpdate Class Constructors Properties See Also Send Feedback

The WorkItemUpdate type exposes the following members.

Constructors

Name | Description
WorkItemUpdate |

Properties

Name | Description
WorkItemId | The Id of the work item to be updated

See Also

WorkItemUpdate Class


WorkItemUpdate Constructor

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemUpdate Constructor
WorkItemUpdate Class See Also Send Feedback

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public WorkItemUpdate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkItemUpdate()

See Also

WorkItemUpdate Class


WorkItemUpdate Properties

[image] [image]

VoteCal EMS Vendor Integration API Reference
WorkItemUpdate Properties
WorkItemUpdate Class See Also Send Feedback

The WorkItemUpdate type exposes the following members.

Properties

Name | Description
WorkItemId | The Id of the work item to be updated

See Also

WorkItemUpdate Class


WorkItemId Property

[image]

VoteCal EMS Vendor Integration API Reference
WorkItemUpdate..::.WorkItemId Property
WorkItemUpdate Class See Also Send Feedback
The Id of the work item to be updated

Namespace: VoteCal.Management.Web.Services.Models
Assembly: VoteCal.Management.Web.Services (in VoteCal.Management.Web.Services.dll) Version: 1.0.0.0 (1.0.0.0)

Syntax

C#
public Guid WorkItemId { get; set; }
Visual Basic (Declaration)
Public Property WorkItemId As Guid
Visual C++
public:
property Guid WorkItemId {
    Guid get ();
    void set (Guid value);
}

See Also

WorkItemUpdate Class